Skip navigation
vertex_shader
Currently Being Moderated

flexunit breaks when using -load-config

Apr 29, 2011 6:18 PM

1. I dump the compiler options using -dump-config=config.xml

2. I then load those options using -load-config+=config.xml

3. I can no longer right-click and 'Execute FlexUnit Test'

 

The error says: unable to open c'onfig.xml'

However, if I clean and build the project, it's just fine.

 
Replies
  • Currently Being Moderated
    Apr 29, 2011 6:58 PM   in reply to vertex_shader

    hi, sorry but i dont know that there is much we can do to help. this sound like a flash builder bug. these forums  are for the open source flexunit project. the execute flexunit stuff inside builder was implemented by the flash builder team and is not part of the project nor maintained outside of adobe engineering. i would file a bug at bugs.adobe.com and post the bug number here. i can try to get some attention drawn to it, but we dont even have  access to that source

     

    mike

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 29, 2011 7:20 PM   in reply to vertex_shader

    you can. the other thing you can do is make a separate regular project and add the tests in the library project as an additional source path to the project. that is what i generally do

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points