Skip navigation
Currently Being Moderated

JSXBIN Syntax Error?

May 7, 2011 4:08 PM


Im trying to convert  jsx file to jxcbin, and then embad it in a jsx script using: "app.doScript" without sucsses.. i tried the "eval" method but fail again.

Before i export my jsx file to "bin" format, i removed the "#target photoshop" and all the line breaks.

I just can't find the reason to the Syntax Error i get any time..


What is the correct way to Prepare a JSX script to JSXCBIN? is there somthing else to "clean" exept the line-breaks?

whice characters are not allowd in the jsx intend for jsxbin conversation?


I really would appreciate help on this issue... I'm really frustrated



  • Currently Being Moderated
    May 7, 2011 4:41 PM   in reply to nirkaufman

    "app.doScript" looks like it might be part of a BridgeTalk message. Is it? I have not needed to remove linebreaks when converting to jsxbin. But BridgeTalk messages can't have comments.

    Mark as:
  • Currently Being Moderated
    May 8, 2011 2:06 AM   in reply to nirkaufman

    BridgeTalk is not Bridge the App although that could be a possible target. It is the ESTK's inter-app messaging system… There is NO app.doScript() in Photoshop that method is InDesign only. Where are you running the script from? Have you tried using $.fileEval()

    Mark as:
  • Currently Being Moderated
    May 8, 2011 2:40 AM   in reply to nirkaufman

    From the toolkit guide…


    $.evalFile (path[, timeout]) // Loads a JavaScript script file from disk, evaluates it, and returns the result of evaluation.

    path: The name and location of the file.

    timeout: Optional. A number of milliseconds to wait before returning undefined, if the script cannot be evaluated. Default is 10000 milliseconds.


    Do you not have the toolkit guide PDF? It covers all the inter-app, file system access, bridgetalk stuff including the $ object…


    Could you give an overview of what this script is intended to do and where you are calling it from?

    Mark as:
  • Currently Being Moderated
    May 9, 2011 12:15 PM   in reply to nirkaufman

    As a side note, if you export a binary code with, say, ESTK CS5, it will run properly in PS CS5 only.

    If you need it to make it work with legacy versions, you have to use the older one, AFAIK (so for instance, I've been using ESTK to export scripts that need to run from CS3 to CS5).

    That said something like,




    never gave me any trouble.




    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points