Skip navigation
Currently Being Moderated

AssembleStatementBatch Failed

May 6, 2011 7:32 AM

Hi,

I'm trying to run this sample process but it keeps saying FAILED every time.

The web examples runs ok, so I confgured I-Statements well I guess.

At the begining a process variable called tmpdir is set with a script using java.io.tmpdir, that gives "C:\WINDOW~1\"

I think is maybe the batch processor path. I tryed it empty, and others values, like C:\TEMP, C:\WINDOWS, C:\WINDOW~1\

I tryed to change batch_input.xml with other paths too with no results...

 

any help on this topic?

 

Thanks a lot...

 

PD: sorry for my english...

 
Replies
  • Currently Being Moderated
    May 6, 2011 10:07 AM   in reply to pmoralesm

    Hi,

     

    In order to be able to help you, I need more details about the error you get.  It would be very useful if you could post the error as you see it in the server.log file. Assuming you're using a Windows server with JBoss then the server.log file is located at C:\Adob\LiveCycle ES2.5\jboss\server\log\server.log.

     

    Basically the process you invoke has a couple of steps before actually invoking the Batch service: locate tmp directory, configure input path, read batch data file, save input data to path. The purpose of all those steps is to copy the file batch_data.xml to a local directory on your server (i. e. C:\Windows\Temp) and populate the process variable batchInputDataPath with the location of the file, so Batch service can access it. The failure you get might be because the batch_data.xml file is not accessible to the Batch service or because the process AssembleStatementEnhanced is failing. Common reasons for AssembleSttaementEnhanced failures are: demo certificates AKIRATANAKA and JOHNJACOBS are not installed; the certificate READER for Reader Extensions is not installed. A very useful way to monitor how a multi-step process is running is to use the Record and Playback feature. To start recording right click the process-->Record and playback-->start recording. Once the recording is set, just invoke the process and wait until it finishes. To play the recording right click the process-->Record and playback --> play process recording --> and select the top entry. Once the recording shows up, play it step by step (click the forward button); the failed steps will turn red.

     

    In case you're missing the certificates, you can get the demo certificates AKIRATANAKA and JOHNJACOBS by deploying the Sample Setup Utility application to your server. Browse to http://help.adobe.com/en_US/livecycle/9.0/samples/lc_sample_product.ht ml and click the link "Download" located at the top right corner of the page. By deploying this application the 2 certificates will be automatically created. For more info about certificates read section "Managing certificates and credentials" here http://help.adobe.com/en_US/livecycle/9.0/adminHelp/admin.htm.

     

    In case you're missing the certificate READER, then you have to obtain one. For more info about Reader Extensions, see section "Configuring Reader Extensions" here http://help.adobe.com/en_US/livecycle/9.0/adminHelp/admin.htm.

     

    If none of the above will fix the failure, please post the error message found in the server.xml file.

     

    Hope it helps,

    Oana

     
    |
    Mark as:
  • Currently Being Moderated
    May 9, 2011 9:23 AM   in reply to Oana Adobe Employee

    Ok... I solved the problem

    The problem was the name of the reader extension credential, I had one called NEWRECRED, but, the process needed a credential named READER.

    I found this issue really weird...

    Is it possible to configure the accelerator to use the current default credential?...

     

    Thanks for your help!

     

    Regards...

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points