Skip navigation
Currently Being Moderated

I am very disappointed in CFBuilder 2

Jun 1, 2011 9:13 AM

I have been using CFBuilder since it first came out. I went through some of the early beta annoyances and even some of the situations where a new beta version came out and stopped the current one from working, effectively halting my production until it was fixed. That being said, I love CFBuilder and it has been a mostly positive experience. It has all of the good things about CFEclipse, with a lot of helpful enhancements.

 

When CFBuilder 2 came out, I was very excited to get my hands on it. I am sure I don't need to go into detail about how important a functional and feature rich IDE is to a developers day, so I am always looking forward to the latest and greatest. CFBuilder 2 falls short in so many ways and after talking many other developers, I realize that I am not the only one with that opinion. I am surprised that Adobe has produced such a bug ridden product.

 

Being a developer myself, I understand all to well the need to get a product released and making money, but this product is unusable and is making Adobe look bad. I talked to a number of developers at cf.Objective about this and I wasn't surprised that many of them shared my negative experience.

 

Because I have had issues upgrading from one version to the next in the past, it is my practice to install a fresh version, so there are less issues. I am running Windows 7, but I have talked to friends that are working on Macs and have experienced these problems as well. Here are just a few of my gripes:

 

- In early versions of Builder and CFEclipse as well, syntax highlighting would occasionally break and would leave your code looking like it was in notepad. Sometimes it would repair itself after time, or you just needed to type something, or highlight code and it would correct itself. In later versions this got much better and all but disappeared. In CFBuilder 2 the problem is back and worse than it ever was. The only way I could fix it much of the time was to just close the file and reopen it.

 

- In addition to the syntax highlighting breaking, it seems to hang much of the time. It actually crashed my editor a couple of times. Even when I set the setting to make it only refresh when you save, it still seemed to try to update anyway.

 

- When going to a new line, for some reason it is inserting an extra tab. I see that there is some new code formatting functionality, and I tried to change this behavior, but I couldn't find a way. This is changed behavior from how it worked before and it is frustrating having to search for options just to have it work the way it was originally. I am not really sure who would want the extra tab anyway. It is a tab that doesn't follow the flow of your regular indentation.

 

- The auto closing of tags doesn't seem to work properly anymore. I tried toggling the settings to see if that would help, but I wasn't able to get it working.

 

- The previous version gave us some really cool hotkeys. CTRL+SHIFT+A to insert an abort, CTRL+SHIFT+D to insert a cfdump, C and CTRL+SHIFT+M to wrap code in a comment. In CFB2, all of those keys have been remapped by default... I understand that the functions are still there, but it doesn't make sense to me that they were moved.

 

Honestly, after fighting these issues for only a very short period of time, I got frustrated, uninstalled the app and went back to CFBuilder 1. It seems like this was a complete rewrite and wasn't very well tested. I realize that I could have been a little more detailed on the explanation of some of these issues, but I really don't have anymore time to waste on this unfinished product...

 

I am very disappointed that this was pushed out in such a non-functional state and I won't feel comfortable giving it another chance until I start hearing that things are vastly improved.

 

I realize that the tone of this is somewhat negative, but it comes from hours of frustration and wasted time. I only decided to post this after I spoke with a number of my peers that are equally disappointed. I hope this can serve as a nudge to improve the quality of future releases.

 

Jeff

 

 
Replies
  • Currently Being Moderated
    Jun 1, 2011 9:19 AM   in reply to thermyte

    --^ everything this guy says.

     

    installed standalone;  installed as a plugin.

     

    searched high and low for a fix to the code coloring giving up half way through a file.

     

    the tag auto-close makes cf builder 2 loose its mind for 5-10 seconds (an eternity when developing).

     

    ive turned off all the features to get some ground but it still fails miserably.

     

    im reverting to cf builder 1 until version 2 is fixed.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 9:34 AM   in reply to thermyte

    I am experiencing none of the problems you are having. CFB2 has been working great for me.

     

    I have used it as both a plugin and standalone.

     

    I do have the occasional problem with auto-closing tags not working right, but it can usually be traced back to my own code (like not properly closing a prior tag).

     

    Many of the hot keys were remapped. I recall a lot of discussion about this. The explination was that they wanted to have a consistent way of getting to all of the CFB shortcuts by default (Ctrl + T + <some key>). You can easily remap them back to what you were used to, and many people have done that.  I have found that getting used to the new key commands has not been that bad.

     

    I have found CFB2 to be a treat to work with.

     

    Can you post some sample code that reproduces any of these problems?

     

    Also, keep in mind that CFB rides on top of Eclipse. Eclipse can be a bit tricky on its own and it would be impossible to test CFb with every possible combination of plugins and Eclipse settings and on every JVM. It is possible that your issues are a result of any number of things. Plugin conflicts, JVM issues, Eclipse version, 32-bit vs 64-bit, etc could all be factors.

     

    I hope that if you know a way to consistently reproduce the problems you are having that you will report bugs to the development team along with explainations and sample code. It is not right to say that you want something improved but then not let the right people know what needs to be improved.

     

    https://bugbase.adobe.com/

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 9:38 AM   in reply to 12Robots

    i see other posts from developers experiencing the same probs as i am.  its not just me.

     

    since yours is working, can you just zip up your install and send it over?  much appreciated.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 9:46 AM   in reply to noraaron

    Where did I say it was "just you"?

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 9:50 AM   in reply to 12Robots

    --^ everything this guy says.

     

    It's such a shame to see some people want always to suggest that because something doesn't work for them (and even some of their peers) that therefore it must be true for everyone, and that the product and team are shoddy. We hear the same of CF sometimes, and since I do CF server (and sometimes CFBuilder) troubleshooting for a living, I can affirm that rarely if ever is the problem (or rarely are "all the problems" someone experiences) really due to inferiority of the product.

     

    There's usually an explanation in there somewhere, for why what fails miserably for someone does seem to work just fine for others. Often, it seems to have to do with some configuration issue.

     

    In CFB, particularly, it's indeed important to get many config things right: some features won't work unless a file is opened within a project, and further some will only work if the file is opened in a project that is connected to a server. Then, too, you may connect a project to a server, but not do it right, or have something that's just not working (like connecting to a remote server and specifying the JNDI port but it's not the one on which the connected CF server is listening on, or you provide the RDS password but RDS is not enabled on the server, or the ports for either are blocked, and so on.)

     

    I will grant that someone will see that and say, "well see, that's what I mean: you have to be a bloody technician to get it all working". Well, yes, to a degree. CFB tries to do a LOT for you. It isn't "just an editor" (but most here know that), but it's more than even most Eclipse plugins--they (nearly all) work with source code alone. CFB is working with both source code and the configuration of stuff on a back-end server, such as what datasources exist (in CF), what components exist (on the CF server, as defined by CF admin mappings, custom tag paths, and the web server root), and so on.

     

    It can't "just look at your code". It needs to do this back-end communication to bring all the hotness that it does. But if that connection doesn't work, then it can either fail (obviously or silently), or perform poorly.

     

    So yes, it's a shame when someone's configuration gets in the way and makes it seem that CFB sucks. But the reason you hear from others "no it doesn't" is just that either they don't have the same setup, or don't have the same configuration challenges, or they have solved them, or whatever.

     

    But please, I wish people would stop with the "it sucks" mantra, just because it doesn't work for them (and some of their peers).

     

    Jason and I (and others, I'm sure) are at least here to say, "it doesn't suck for us".

     

    That doesn't make you wrong. It just means that your assertion that it sucks in general (calling it " unfinished product...pushed out in such a non-functional state"). I realize that countering your point, I run the risk of your (and noraaron's) wrath. Please don't shoot us as the messengers. We're just offering a contrasting viewpoint.

     

    /charlie

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 10:01 AM   in reply to thermyte

    I find it completely usable.  In fact, I am using it right now. It does not seem like beta software to me at all.  Perhaps you are suggesting I am a liar.

     

    Report bugs.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 10:13 AM   in reply to thermyte

    " It may work for you and some others, but if it is failing for so many, that is proof that it needs more testing in more environments..."

     

    So many others?  Can you back that up with a number?  You seem to imply that it is failing for more than it is working.  I know far more people who think it rocks.

     

    I was just at cf.Objective() and heard no one complaining about it.

     

    You seem to think that a few forum posts and some people at work == "mass failure"

     

    Instead of ranting perhaps you should spend your time more productively. You seem to have enough time to sit on the forums and defend your rant, why don't you use that time to help out by reporting these problems properly. The engineering team has more important things to do than scour the forums looking for rants with no specific detail and trying to work from that. You claim to be a developer, is that how you want to have bugs reported to you?  Or do you want people to use your issue management system and report detailed, specific reproduction cases?  I know how I would answer that question.

     

    Now get back to your unfinished project, finish it, and then reinstall CFB2 and then I would be happy to help you figure out what's up and report bugs if needed.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 10:48 AM   in reply to thermyte

    And if you had read my responses, at no time did I say that "it works well on my machine" should be an excuse.  I have only offered to help and offered some explanaitions. 

     

    Good luck. 

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 10:59 AM   in reply to 12Robots

    " I didn't sign up to test for Adobe and CFBuilder is not an open source project."

     

    ding!

     

    i paid for a license and expect it to work decently out of the box... like Dreamweaver does.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 12:29 PM   in reply to thermyte

    I feel your pain. I think my problem has to do with the cfml code not being able to be parsed correctly. The new Advanced CFSearch has a great Tag search option but with my code it is unusable. I search and it hangs up while maxes out the cpu.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 1:00 PM   in reply to thermyte

    I too am having many issues. The synax highlighting problem is one of the more annoying ones. Also have problems where CFB gets too slow to use when editing large files. I have switched back to CFEclipse for now and am anxiously awaiting a 2.1 release.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 1:19 PM   in reply to Ryan Stille

    Like I said, I hope you guys are reporting these issues with reproduction cases.

     

    I do not deny that CFB2 may have issues. But it would likely make it eaiser to fix them if the bugs are reported in the proper places.

     

    https://bugbase.adobe.com/

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 2:00 PM   in reply to noraaron

    I admire the ambition of CFBuilder, but even at this, its official 2.0 release, I can't help but wish the team would scrap the project and focus on simply adding better ColdFusion integration to Dreamweaver.

     

    Having logged endless hours with both IDEs, though I love the heart and promise in some of CFB's cooler features, it just can't compete with Dreamweaver for me. I would literally pay a few thousand dollars to get a CF-enhanced Dreamweaver, but even as it is now, with little CF improvement over the lasts X versions, it lets me code CFML at a pace and fluidity that's just unattainable in CFBuilder in my experience.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 2, 2011 3:29 PM   in reply to thermyte

    To the guys having issues, lets get back to basics and see what could be causing you any issues.

     

    What plugins do you have installed ontop of the standard install, if any of course not going to point the finger at this as the cause but we have to start somwhere.

     

    Also did you reuse your projects? Or did you delete and create new ones in CFB2? Again just trying to rule this out.

     

    Something you could try to see if it helps your issue

     

    create a batch file on your desktop with the following in:

    "c:\Program Files\Adobe\Adobe ColdFusion Builder 2\CFBuilder.exe" -initialize

     

    (You may need to change the path for your install)

     

    Run this batch file, you won't see CFB2 start, it may flash up and go again, if you check your task manager while you run this you'll see it come and then go again.

     

    Once it's closed again, reopen CFB2 with your normal link, 1) You should see it start a lot faster 2) lets hope it sorts your issues

     

    To note this also works with CFB1 and also any Eclipse

     

    I took the advise from: http://www.dopefly.com/techblog/entry.cfm?entry=290

    "Initializes the configuration being run. All runtime related data structures and caches are refreshed. Handy with shared installs: running Eclipse once with this option from an account with write privileges will improve startup performance."

     

    If you still have issues in this session of using CFB2 try to run this from Start > Run

    "c:\Program Files\Adobe\Adobe ColdFusion Builder 2\CFBuilder.exe" -clean

    (Or create a batch file)

     

    I have both of these ready, and I run them at least once a week to keep to my install tip top.

     

    If none of the above helps, if you could just let us know what extra plugins you have, plus if you recreated your workspaces / projects at least that we help us help you.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 3, 2011 7:13 AM   in reply to Big Mad Kev

    Thanks for the tip about -initialize

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points