Skip navigation
dwanegos
Currently Being Moderated

Cairngorm Module Library - RSLData error with Flex 4.1 & Parsley 2.4

Aug 12, 2011 4:09 AM

After upgrading a project from Parsley 2.3.2 to Parsley 2.4.0 I'm am experiencing the following error when compiling in Flex 4.1

 

1046: Type was not found or was not a compile-time constant: RSLData.

 

As part of the change I upgraded some of the Cairngorm librarys for Parsley 2.4 support but it appears that Module 0.17 is dependant on Flex 4.5? Is my assumption correct?

 

 

Here are a full list of the dependenies upgraded for reference:

 

  • com.adobe.cairngorm.module 0.17 (Upgraded from 0.15)
  • com.adobe.cairngorm.navigationParsley 1.7 (Upgraded from 1.3)
  • com.adobe.cairngorm.integrationParsley 0.17 (Upgraded from 0.15)
  • org.spicefactory.parsley-flex4 2.4.0 (Upgraded from 2.3.2)
  • org.spicefactory.spicelib-flex 2.4.0 (Upgraded from 2.3.2)

 

 

Additional dependencies which weren't changed:

  • com.adobe.cairngorm.task 1.10
  • com.adobe.cairngorm.validation 1.12
  • com.adobe.cairngorm.popup 1.13
  • com.adobe.cairngorm.popupParsley 1.13
 
Replies
  • Currently Being Moderated
    Feb 26, 2012 6:36 PM   in reply to dwanegos

    Did you ever find an answer to this?  I am running into the same issue with needing to upgrade parsley to 2.4.x, but with parts of application heavily relying on cairngorm module, upgrading it from module-0.11 to 0.17 seems to break compile! 

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 23, 2012 2:48 AM   in reply to dwanegos

    I also run in to this error? does anyone has a solution for this?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points