Skip navigation
Currently Being Moderated

Files deleted using RSC Explorer - now getting "invalid path" error msgs

Apr 15, 2011 12:59 AM

Yesterday I deleted about 10 images from RSC because (1) they were no longer used in the help project and (2) RH had not deleted them from source control itself. Note: I did not just hide these files - I deleted them.

 

Today when I try to "get" the whole project, I get error messages for each of those files. Caption: RoboSource Error. Message: "Error - path '[path & filename]' is invalid."

 

Since these files are in various subdirectories of the project, and RSC refuses to continue getting the rest of the files after it encounters this type of problem, this means I now have to "get" the project directory by directory. Grr.

 

Ok, so RSC did not like me deleting the files from RSC Explorer. So how do I fix this problem? I tried adding the files back into RSC, but I get a different error message: "Error - node '[path & filename]' already exists." (Um, which is it -- is the path invalid, as claimed by the first error message, or does it already exist, as claimed by the second one?)

 

I don't know what else to try.

 

The other (less urgent) question is, if I can't delete old images from RSC Explorer, and RH doesn't see to it that unused images are deleted from source control, then how do I get unused images out of source control?

 

Any help would be appreciated -- especially quick help! :-)

 

/Eileen

 
Replies
  • Currently Being Moderated
    Aug 21, 2011 11:03 PM   in reply to EileenPalsson

    Eileen, this is very similar to a situation my team faced a few weeks ago, though our error was related to deleted topics and not images.

     

    I'm not sure why exactly RoboSource throws up this error, but we did notice that the root.fpj file retains references to the deleted files, which makes RoboSource look for them, and when it doesn't find them it starts acting all wonky. Adding the files back doesn't work b'se for some reason RoboSource recognizes the deleted files as still being part of the project. Talk about ghosts in the system!

     

    However, we did find a workaround that worked in our case. Open the root.fpj file in a text editor like TextPad, and remove *all* references to the deleted files. (In case of our topic, this also included the HHC file.)

     

    Do post back if this solution worked for you, or if you found another fix for this issue!

     

    - Richa

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2011 12:16 AM   in reply to FirstScript

    @First Script

     

    Are you by any chance using RoboHelp 8 without the 802 patch applied? If you are, then that could explain missing topics. See Opening Projects on my site if relevant.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 22, 2011 1:51 AM   in reply to Peter Grainge

    @Peter

     

    Actually, we were using RH 8 with 802 applied when this error cropped up. We've moved on to RH9 and a whole different set of problems since.

     

    Just to clarify, my topics didn't really go missing - I deleted a couple of troublesome topics from RSC (instead of being good and deleting from within RH as I should have) and then tried recreating them using RH, but I simply could not create them b'se RSC detected them as "already exists". When I tried retrieving these supposedly extant files, I couldn't retrieve them either b'se RSC prclaimed them "invalid".

     

    Removing references from root.fpj worked for us - I think it made sure RSC wouldn't expect those files in the project.

     

    - Richa

     

    P.S. - Your site is one of my first stops when I run into any RH-related issue. Thanks for all your help!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points