Skip navigation
elvisgreenchina
Currently Being Moderated

Free transform scale problem with border

Aug 26, 2011 12:40 PM

When "show transform controls" is checked and I have a layer selected, a white border shows at the edges of the layer with small boxes at the corners and midpoints. Hovering above one of these boxes changes the cursor into the "scale arrow." Traditionally, clicking the border with that arrow and holding down the mouse button allows you to scale down the layer by dragging the mouse.

 

In Photoshop CS5 (and perhaps other new versions), clicking the border and holding the mouse button has no effect. Dragging the mouse reverts the pointer into the "selection arrow" and drags the image across the screen instead of resizing it. This is because when you click on the border, it suddenly expands into a larger area. Only by clicking once and then letting go can you move your mouse cursor to the newly defined edge and then scale down the image. This is incredibly frustrating and adds a second, unneeded step in the process. Because I instinctively try to grab hold of the border as is, I usually wind up dragging the image by mistake.

 

What's up with this?

 
Replies
  • JJMack
    5,979 posts
    Jan 9, 2006
    Currently Being Moderated
    Aug 26, 2011 2:00 PM   in reply to elvisgreenchina

    Post a screen capture. CS5 Transform works fine om my machines. However I do no see ane white border around the layer just see the 8 transform boxes.

     
    |
    Mark as:
  • JJMack
    5,979 posts
    Jan 9, 2006
    Currently Being Moderated
    Aug 27, 2011 8:39 AM   in reply to elvisgreenchina

    Text layers seem to work the same way as other layers on my machines and yes with text I see a border in the controlls.

    The Shift Ctrl and Alt keys also act as modifiers. Shift constrains the scale, Alt Tramsforms from the center and Ctrl can distort the tramsform.

     
    |
    Mark as:
  • Noel Carboni
    23,471 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 27, 2011 8:21 AM   in reply to elvisgreenchina

    I just tried it with a text layer as well...  No problems here.

     

    TransformControl1.jpg

     

    TransformControl2.jpg

     

    I'm thinking something may be wrong with your display driver.

     

    Try this:  Edit - Preferences - Performance, disable OpenGL Drawing, restart Photoshop, and test again.

     

    If the problem is eliminated, visit the web page of the maker of your video card and look for an updated display driver to match your hardware and OS.  Once installed, re-enable OpenGL Drawing, restart Photoshop, and retest.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2011 12:40 PM   in reply to elvisgreenchina

    Maybe just shut off the checkbox for  "Show Transform Controls" and simply use a Control T to engage the Free Transform Box.

     
    |
    Mark as:
  • Noel Carboni
    23,471 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 28, 2011 12:51 PM   in reply to elvisgreenchina

    elvisgreenchina wrote:

     

    still no joy

     

    I suppose this could be an issue with Text settings somehow...  Have you tried using the Reset Character menu entry in the CHARACTER panel?

     

    ResetCharacter2.jpg

     

    Try the same concept with the PARAGRAPH panel.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2011 12:54 PM   in reply to Noel Carboni

    Yeah, Noel's suggestion is probably the cure!

     
    |
    Mark as:
  • Noel Carboni
    23,471 posts
    Dec 23, 2006
    Currently Being Moderated
    Aug 28, 2011 1:10 PM   in reply to elvisgreenchina

    One last thought...

     

    Are you sure you haven't "baked" the layer on which you're working into pixels into a higher layer, which is now obscuring the text layer?  It's almost hard to imagine the resizing rectangle could be moving without the contents changing.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2011 1:19 PM   in reply to Noel Carboni

    Sometimes "Smart Objects" don't show the change until after the transformation has been committed. Also it could be that they are not putting their mouse on a corner handle, and that's why it's just moving the position.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 1, 2011 5:48 AM   in reply to elvisgreenchina

    2 questions:

    1. Does it do this if you uncheck the move tool options for auto select and show transform controls? In other words, using just the Edit Transform (Ctrl T) command?
    2. Do you have Comcast as your ISP?
     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points