Skip navigation
Xavier Beautoir 12 posts
Sep 23, 2011
Currently Being Moderated

"Cannot find the following asset(s) referenced in the catalog:" error found in catalog.

Sep 23, 2011 10:18 PM

I created a catalog within the catalog folder for the workspace, the same place the Default.cxml is. I created a library for service interfaces and a library for service implementations following the instructions at http://help.adobe.com/en_US/enterpriseplatform/10.0/AEPDeveloperGuide/ WSabb771403789c7a3-31e63d5312fb7375fac-8000.html#WSe851854fd1e0856a3ad f5f4513046ea7dc4-7ffe. When I use the annotations described my service interfaces and interface library are added automatically.

 

When I deploy my catalog there are no errors. I use CRXDE Lite and go to /content/mosaic/catalogs/[my catalog name] and I can see my interfaces and service classes in there.

 

I create a new Flex Project for ADEP Experience Services and selected the catalog I created. Within there I create a new stylesheet in the styleSheets package and it is created at [project]/src/styleSheets/[stylesheet name].I right clicked on the style sheet and selected "Compile CSS to SWF". My style sheet is added to the catalog automatically.

 

I try to deploy the catalog at this point and it give me the error, "Cannot find the following asset(s) referenced in the catalog: " and then it lists my stylesheet.

 

Has anyone had this problem and have an idea of what hole I am falling into?

 
Replies
  • Currently Being Moderated
    Sep 23, 2011 11:43 PM   in reply to Xavier Beautoir

    Is it possible that there is a case difference in the name of the stylesheet? Maybe something was renamed or changed case between the time it was created and when it was deployed.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 24, 2011 10:32 PM   in reply to Xavier Beautoir

    Please use Flex SDK 4.5.0.

     

    And please be sure, after the re-install,  you've not missed any steps such as enabling RDS.  Seems you're not getting the same error now.

     

    Is there a possibilty you have a prereleased version of the FB plugin (AES Tooling)?

     

    - Janice

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 25, 2011 9:17 AM   in reply to Xavier Beautoir

    I tried the original steps and discovered that there is a bug related to the generation of the catalog zip in the case where the desired stylesheet resides a a package (the handling is only reliable when the CSS is in the root of the project's src folder). The bug results in the message "Cannot find the following assets..." when an attempt to deploy the catalog occurs.

     

    It seems that you have 'reset' your environment in an effort to resolve the issue. If you have recycled the CXML that was present in your original attempt ensure that the reference to the 'stylesheet in a package' is removed. Tiles/interfaces/services and other 'loose assets' do not suffer from this package name limitation.

     

    Using Flex SDK 4.5.1 requires an updated CAF (Mosaic) client runtime (we have not released that yet).

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points