Skip navigation
Currently Being Moderated

Cannot Install Item. Please restart your app…

Sep 26, 2011 5:43 AM

A folio which downloaded perfectly last week is now failing to download. The folio has been shared to a number of people whom are now getting the same message "Please restart the app and download your purchase again". It gets exactly 4.6mb in before notification.  Are there any known problems at the moment?

  • Currently Being Moderated
    Sep 26, 2011 6:52 AM   in reply to Yellow Christian

    Content Viewer, right? , Not developmnet build or production?Free/retail ? Maybe someone changed folio status in Folio Producer panel?

    I would start with reinstalling Content Viewer.

    Mark as:
  • Currently Being Moderated
    Sep 26, 2011 10:00 AM   in reply to Yellow Christian

    I've been having the same issue since Friday morning.


    I had a working 3-article folio; post-update (a very simple text change) it gives same error message, stopping at 1MB every time. I've deleted and rebuilt the entire thing several times: I deleted the workspace itself, then started with each article alone, to see if there was something in a single article it was gagging on. Finally I just threw everything back together. I've also reinstalled the Content Viewer app. Nothing has fixed it.


    While that led me to suspect it's related to the announcement about the Apple receipt issue on the front page of the forum, I'm not having the problem with downloading issues of the New Yorker (subscriber) nor with purchasing single issues of National Geographic.



    Mark as:
  • Bob Bringhurst
    4,645 posts
    May 29, 2007
    Currently Being Moderated
    Sep 26, 2011 10:41 AM   in reply to Yellow Christian

    Try using the Folio Producer Organizer to update the published folio again. Does the error still occur?

    Mark as:
  • Currently Being Moderated
    Sep 26, 2011 10:58 AM   in reply to Bob Bringhurst

    Nope, it's still erroring out at 1MB (of 28). I've also been through all the suggestions here; however, I can't "babysit" the download, since it's not enough to light up the view button, and I can't try #2, as I'm a single-folio freelancer.

    Mark as:
  • Currently Being Moderated
    Sep 27, 2011 8:23 AM   in reply to Yellow Christian

    Hi all,

    I think I'm experiencing a similar problem. For me, it looks like the issue is the file. Here's my story;

    I create a new folio and then import an article (the HTML file), which uploads and displays in the iPad Viewer fine (sans images, css styling and script objects). I close the iPad viewer, and upload the in the Folio Producer. Start the iPad viewer again, which tells me that there is an update available for that folio. Hit download and boom, cannot install item, etc.


    I'm willing to accept that there is some error on my part, particularly in the folder structure Ive used, but Ive read and reread the guide and think Ive got it right. To wit;


    - Main folder

      - Chapter folder (contains HTML chapter file; this is the folder that I point at to import the article for the folio)

      - "HTMLResources" folder (contains images, css; no subfolders)


    The .zip file is comprised of the image and css files and not the "HTMLResources" folder itself.



    Does this sound similar to your situation?



    Mark as:
  • Currently Being Moderated
    Sep 27, 2011 9:41 AM   in reply to D_Wilton


    Publishing the whole thing via the Distribution Service (as suggested in another thread) seems to clear up the issue of the Going that route, the folio is viewable on the iPad with images and css styling.


    But still cant seem to get the JavaScript in the article HTML page to work. Matter of fact, it seems to choke on the article upload to folio until I comment out the line "<script type="text/javascript" src=""></script>"


    Im no scripting genius, so the error could be there, but does the Folio Producer validate/look at page code or scripting? Are we not permitted to link out to .js?



    p.s. this is what my <head> looks like;





    <title>Chapter 1</title>

    <meta charset="utf-8">

    <meta name="adobe-presentation" content="pagination=yes"/>

    <link href="../HTMLResources/test_page.css" rel="stylesheet" type="text/css">


    <script type="text/javascript" src=""></script>

    <script type="text/javascript">


    //Set default open/close settings

    $('.acc_container').hide(); //Hide/close all containers

    /*$('.acc_trigger:first').addClass('active').next().show();*/ //Add "active" class to first trigger, then show/open the immediate next container


    //On Click



        if( $(this).next().is(':hidden') ) { //If immediate next container is closed...

            $('.acc_trigger').removeClass('active').next().slideUp(); //Remove all .acc_trigger classes and slide up the immediate next container

            $(this).toggleClass('active').next().slideDown(); //Add .acc_trigger class to clicked trigger and slide down the immediate next container



        return false; //Prevent the browser jump to the link anchor





    Mark as:
  • Currently Being Moderated
    Sep 27, 2011 11:32 AM   in reply to D_Wilton


    Using the Distro Service option has definitely cleared things up. If I dont use the Distro Service, the folio will not download to the iPad Viewer - i get the "cannot install..." error.


    On the secondary problem from my post above (the .js) - I downloaded the .js file from the jQuery site, saved it to my HTMLResources file, pointed to it in my HTML article source and then followed the usual zipping procedures, rebuilt the folio, uploaded using Distro and pow - worked like a charm.


    But again I must ask - can we not link to the .js file (as in - <script type="text/javascript" src=""></script> )?


    Hope this helped.


    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points