Skip navigation
Currently Being Moderated

FrameMaker freezes after 60 minutes

Oct 12, 2011 1:38 AM

Tags: #windows #framemaker #freeze #60_minutes #one_hour

Over the years I have had insurmountable problems with FrameMaker version 5.5.6, 7, and 8 freezing exactly 60 minutes after FrameMaker startup on certain machines, including Dell, Lenovo and Asus hardware, and Windows XP and Windows 7 operating systems. At the 60 minute mark exactly, the FrameMaker process hammers the CPU up to 50% and stays there, and the program is then frozen ( " not responding " ). The rest of the system is still functioning. I (and several system administrators) have spent many days trying everything in the book, to no avail. I never found the source of the problem; I gave up and avoided it by using random Windows machines that don't exhibit the problem, and by using FrameMaker on Solaris. I am working at home now (actually, *trying* to work at home); I can no longer avoid the problem, and the lock-ups make FrameMaker practically unusable.

 

Although I appreciate any suggestions, each one takes 60 minutes to test (obviously) and I have tried so many that I feel like I can't try any more of them without some kind of a lead. To that end, I have a direct question to the Adobe FrameMaker programmers:

 

WHAT IS FRAMEMAKER DOING AT THE 60 MINUTE MARK?

 
Replies
  • Currently Being Moderated
    Oct 12, 2011 2:52 AM   in reply to Tigdave

    Dave,

     

    Have you heard of anyone else having the same issue?

    Can you avoid the problem by closing FrameMaker after 59 minutes and restarting the application?

    What is different with the "random machines that don’t exhibit the problem"?

     

    - Michael

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 12, 2011 8:06 AM   in reply to Tigdave

    Have you tried temporarily uninstalling all plugins/add-ons/startup

    scripts to see if any of them might be causing a conflict?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 12, 2011 8:35 AM   in reply to Tigdave

    The tie-in to your autosave setting seems wierd. I've been using various versions of FM for years on many different wintel plaforms, have autosave set to 5 minutes, often use it all day (& night with automation) and have never seen a freeze like you describe. As Mike suggests, if you have any plug-ins or scripts installed, try uninstalling them, set the autosave to a low value and see what happens.

     

    Also, you don't mentione what sort of hardware resources you have on the platforms where this happens. How much RAM, how much free space in the TEMP folders, how much free space in your working folders, do you have full permissions in your environments, do you have aggressive anti-virus apps that might be grabbing the auto-save, etc.?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 12, 2011 9:05 AM   in reply to Mike Wickham

    Have you tried temporarily uninstalling all plugins/add-ons/startup

    scripts to see if any of them might be causing a conflict?

     

    Concur. This sounds like a memory leak in a plug-in.

     

    I've been using Frame since 3.1, on every version of Windows, and two different Unix systems, and have never seen a 60 minute implosion.

     

    To rule out plug-ins, I'd try installing the trial version of FM10 on a machine on which I'd never had an account before, and which I.T. has never messed with (i.e. installed some standard enterprise environment, which might include who knows what FM extensions).

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 13, 2011 12:10 PM   in reply to Tigdave

    Dave,

     

    500Mb of RAM in an XP system is a very tight fit. I suspect that your machine is thrashing to the paging file when FM is running. However, that may have nothing to do with your autosave issue. Perhaps something in the permissions for the Groups or the individual user is preventing FM from creating the autosave file. Have you checked at the system level to see if an autosave file has been created? Also, have you tried turning autosave off?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2011 2:08 PM   in reply to Tigdave

    You are not the only one suffering from this.  I have a WinXP laptop with 2G memory.  I have admin (full) permissions on the laptop.  It has 10s of Gig available in TEMP and work areas, including networked drives. The problem occurs with or without anti-virus software running.  The problem occurs right after reboot with everything except the minimal services and absolutely necessary startup software having run, or it occurs after the laptop has been up for weeks with tons of usage.

     

    The problem happened with me on framemaker 7.  Just recently I deleted everything for framemaker 7 and installed framemaker 8, with nothing extra, and it happened the first time I ran framemaker 8.  I installed the necessary bits for PDF and it still occurs.  I have done nothing else to framemaker 8 and for the past two months it keeps doing it.  I know of no plug-ins or add-ons, but would appreciate any pointers on how to look for them if the audience insists they may be the problem.

     

    More on the problem itself:  Besides occurring at exactly 60 minutes, it occurs every 60 minutes.  You can bring up the Print... dialog at 59 minutes, wait a couple minutes, close the dialog, and keep working for another 58 minutes until you have to open the dialog again.  Otherwise, it will hang at 120 minutes, precisely.

     

    And if you put the laptop to sleep at, say, 30 minutes after the last hang should have occurred (or since starting framemaker 8), it will hang 30 minutes after waking up the laptop.  Thus, there is some timer inside of framemaker 8 that fires every 60 minutes and is not tied to wall-clock time.

     

    If anyone has any suggestions, I am very interested.  I am currently forced to use framemaker 8 for a specification document our company is creating.  The hangs are incredibly painful, especially if I forget to save/quit before the hang occurs.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 25, 2011 2:21 PM   in reply to rhbeers

    I forgot to mention that this occurs with all framemaker 8 patches, version 8.0p277.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2011 5:10 AM   in reply to rhbeers

    2 GB is pretty skinny to run FM on IMHO

     

    You don't mention if you have the auto-save turned on or not. What about your power management settings on the laptop - have you tried the "always on" setting to see if that had any effect?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2011 3:32 PM   in reply to Jeff_Coatsworth

    Actually, my laptop has 3G RAM (that'll learn me for not checking system properties before posting).  Power management is always on; it's a workstation laptop.  Anything else about my laptop's configuration you would like to know?

     

    I did not mention the auto-save because the OP's description matches exactly what I see.  I only mentioned additional behaviors not previously mentioned.  To clarify, I default to auto-save off, and get the hangs at 60-minute intervals, and if I set auto-save to anything less than 60 minutes, I get the hang at intervals matching the auto-save setting.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2011 4:39 PM   in reply to rhbeers

    Further information on the framemaker runaway:  Note that the process is running away.   It is not freezing or hanging, the hang is only a side effect of some code inside framemaker going into an endless loop and taking 100% of the processor.

     

    After a reboot, I started framemaker without opening a document.  I went into preferences and set auto-save on and to 2 minutes.  Exactly 2 minutes (to the second) after I clicked on the preferences dialog's Set button, the runaway started.

     

    With no .fm files open, framemaker just started, plenty of free RAM, and power management full throttle, framemaker still tries to do something at the auto-save interval that sends it into a tail-spin.  Any suggestions?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2011 8:55 PM   in reply to rhbeers

    This certainly is weird behaviour, however, since this is happening with older (i.e. non-supported) versions of FM, there's probably not much that Adobe will do about it. However, if you try the FM10 trial version and still see the same freeze/runaway happening, then it's something that they should repsond to.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2011 9:27 PM   in reply to Arnis Gubins

    Thank you for your time.  I agree that it is weird and not to expect Adobe to do anything about it.  I was here on the off chance someone among the vast audience might have worked around something similar before.  If I have some free time after a few more weeks yet of having to use FM 8, I will try the FM 10 trial to satisfy my curiosity.  Thanks again.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2011 11:43 PM   in reply to rhbeers

    Very strange indeed. If we look at the available information, we can notice:

    • Freezing means that FrameMaker needs 100 % of the processor power.
    • Some installations show this behaviour.
    • If FrameMaker freezes, this behaviour is shown always.
    • This behaviour is already there, even if no other applications are started.
    • If I recall correctly, this behaviour is also shown on new installations of Windows and FrameMaker.
    • This behaviour is reported only by very few users.

     

    Therefore I would conclude:

    • It could be that certain settings in an ini file do not work with a certain PC configuration or hardware.
    • It could be that FrameMaker generally has problems with certain PC configurations or hardware. Can this be sorted out?
    • If FrameMaker has general problems with a configuration or hardware, it could be that also other software has similar problems. Did anyone hear something similar of other software applications?

     

    I guess you must check further, whether there are any differences to working installations.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2011 1:16 PM   in reply to Tigdave

    I know what you mean, Tigdave.  After searching many times across many months after many FM hangs, stumbling upon your thread warmed my FM-frozen heart.  (Suffering FM alone is far worse than sharing in our FM suffering?)

     

    Your "create a new Windows user account" workaround worked for me.  Thank you for sharing that discovery.  Although most of my FM work is on protected documents and cannot use the new account, using the new account and having an autosaving framemaker survive for a few hours of how-to document writing was quite refreshing.  Cheers!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2011 1:44 PM   in reply to rhbeers

    @Tigdave & @rhbeers - you never say if you've have Adobe Tech support ever look at what's going on. Perhaps that might be a better route to take. The fact that creating a new user account seems to fix the issue & that nobody else in the FM community seems to be experiencing this issue leads me to believe that there's something restricted or damaged in the account profile.

     

    @rhbeers - I don't get what a "protected" document is & why you can't work on it. Are you in some sort of restricted environment like government or military? That may play a part in your FM's peculiar behaviour.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2011 2:09 PM   in reply to Jeff_Coatsworth

    We use rights management software for classified documents.  One way to control access to these documents is by setting which users can edit them (and which users can change these settings).  I cannot edit those with the other account.

     

    I have not attempted contacting Adobe Tech support because folks said it was not worth trying for FM 8.  Please provide a contact link or means if you disagree.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2011 2:25 PM   in reply to rhbeers

    I wonder if this "rights management software" is the cause of your troubles somehow. BTW - how could your IT set you up with another profile & not give you the rights you need to work on things? Seems counter-productive...

     

    Anyway, if you never contact Adobe Support, then they'll never know that there's an issue - these are strictly user-to-user forums & while Adobe staff stick their head in once in a while, you can't count on them paying any attention to issues raised here.

     

    I had this stored from another forum thread when they announced a revamp to support:

     

    Contact Adobe Support for Adobe Captivate, Adobe RoboHelp, Adobe FrameMaker, Adobe Tech Comm. Suite & Adobe E-Learning Suite by dialing :

     

     

     

    Via Phone:                          USA   1-800-833-6687  Option 2 > Option 5 > Option 3

     

     

     

    Via Email:                             mailto:TCS.SUPPORT@adobe.com

     

     

     

    You can dial this number for any customer service and technical question.

     

    You can also use the bug reporter here: https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 20, 2011 2:49 PM   in reply to Jeff_Coatsworth

    The rights management software is not the cause because it is not installed yet.  It will be a New Years gift from IT.  Forgive me for not using future tense when talking about this limitation.

     

    The workaround requires only a new local account.  No IT ergs were wasted in the testing of Tigdave's workaround.  Their productivity remains as high as ever.

     

    Thank you for the contact information.  I will try it out.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2012 10:23 AM   in reply to Tigdave

    > It turns out that if I set the Cursor blink rate to None then I get the freezing problem.

     

    Now that you've isolated it, I see that there are other applications that are sensitive to that.

     

    Apparently, Windows internally codes blink rate "none" as -1, rather than 0. Applications which use a "non-zero" blink rate value as an increment to determine the next blink time, come up with "already passed" every time, when the offset is -1. They can loop continuously as a result, which may be as good as locked-up.

     

    Now, as to why it's taking an hour for Frame to get tripped up ...

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2012 10:18 AM   in reply to Tigdave

    You may want to report that fix to Adobe at the bug report form. That

    way, they may be able to fix it in future versions, or at least know how

    to help others that report the problem. The bug report form is here:

     

    https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2012 10:28 AM   in reply to Tigdave

    Great find, tigdave!  It fixes the problem on my system.  Agreed that it needs to be reported.  I am going to report it for the version I have, but it is only 8.0p277.  If you have a version 10 to report on too, maybe we can draw more attention to it.

     

    Thank you for finding this workaround.  That bug cost me quite a bit of work the past three weeks while trying to meet a deadline.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2012 10:45 AM   in reply to Tigdave

    Very nice catch Dave! I'll make certain that the Adobe engineers are aware of this issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2012 8:44 PM   in reply to Tigdave

    FYI, I can confirm that Adobe's engineers have reproduced the bug.

     
    |
    Mark as:
  • Currently Being Moderated
    May 31, 2012 6:39 AM   in reply to Tigdave

    This didn't work for me but I am experimenting with the work around from http://forums.adobe.com/message/3458994 in which DWM is disabled. I would get the "not responding" message at the "Automatic Save every" time if set, or 60 minutes whichever was soonest.

     

    Since disabling DWM I have exceeded the Automatic Save time. I have been using this for a couple of days now and there have been no problems. I do encourage you to gice it a try, DWM can be enabled again, so you really have nothing to lose. BTW. Yowill either need to stop the DWM service every time you use FrameMake or disable the service!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points