Skip navigation
Currently Being Moderated

Viewer Builder v1.5 Bug

Sep 12, 2011 8:45 AM

The viewer builder will always forgot that I unchecked the "shine on app icon" while creating Viewer for iPad.

Very annoying when you build new viewers on a tight schedule.

 

—Johannes

 
Replies
  • Bob Bringhurst
    4,643 posts
    May 29, 2007
    Currently Being Moderated
    Sep 12, 2011 9:06 AM   in reply to Johannes Eckert

    Johannes - I can't reproduce that. When I used VB 1.5 to create a viewer, I turned on Shine, decided I didn't want it, and turned Shine off. Now my development app doesn't have Shine.

     

    One possibility is that the iPad remembered some app settings even though you deleted the app. I've seen that happen before. If you delete your app and add it again, I think Shine will be turned off.

     

    Sent from my iPad

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 12, 2011 9:14 AM   in reply to Bob Bringhurst

    It is a different problem, Bob

     

    Whe you build with VB, it remembers every setting from last build – except the shine/no shine toggle, which alway defaults to shine. But we often automatically click "build", expecting everything would be as it was last time.

     

    Tomek

     
    |
    Mark as:
  • Bob Bringhurst
    4,643 posts
    May 29, 2007
    Currently Being Moderated
    Sep 12, 2011 10:20 AM   in reply to Johannes Eckert

    OK, I understand now. I'll report that issue. Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 13, 2011 2:06 AM   in reply to Bob Bringhurst

    The issue is now in our bug database where it will be investigated and fixed. Apologies for the inconvenience caused.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 5:46 AM   in reply to Johannes Eckert

    Grrrr same problem with Viewer Builder 1.5.1

     

    I have rebuild my app, still without Shine, and it appear in my Ipad with the Shine icon !! Very annoying !

     

    Did I have to start from scratch? Waste of time !

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 5:51 AM   in reply to minia92

    mini92 - was this when you where edinting an existing app you had created in Viewer Builder? Did you try it with a new app built from scratch? Just trying to get to the root cause of the problem so we can get this fixed.

     

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 6:10 AM   in reply to Jonathan Ferman

    Well it appears when I update/edit my app in the VB. I will try to rebuild it from scratch... Hope it will works.

     

    But it is very strange because the icons seems ok when I add the app to Itunes (it appear whitout the shine like I asked) but when I synchronise my Ipad, the Icons appear on my Ipad with the shine !

     

    I'll let U know when I re built

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 6:29 AM   in reply to Jonathan Ferman

    Grrrr I have re built the app form scratch... Same prob

     

    Capture d’écran 2011-10-17 à 15.24.32.png

     

    App in Itunes Store : Capture d’écran 2011-10-17 à 15.25.31.png

     

    App in Ipad : APPEAR with the shine !!!! How can I process now ??? I don't want this XXXX shine on my icon !

     

    Any idea?

     

    I need to submit my app today to Apple and don't want to have a this shine on it !

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 7:06 AM   in reply to Jonathan Ferman

    Just an FYI: We have a bug open with Apple on this. Waiting for an OS upgrade to provide the fix.

     

    Sent from my iPhone

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 7:12 AM   in reply to jamesroche

    I just upgrade this morning to IOS 5 do you think it is due to Apple ?

     

    Because my icon seems to be ok but I soon as I synchronise it to my Ipad it appear with the shine

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 7:18 AM   in reply to minia92

    We do not preview how the icon will look with the shine on in Viewer Builder as Apple adds some code to create the shine effect. If there is shine on the optional 512 x 512 pixel icon in iTunes then yes the shine effexct is being applied, if not then no shine effect has been applied.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 7:18 AM   in reply to minia92

    I just check on a second Ipad where the Icon was OK las week. It appears now with the shine since we have updrage to IOS 5 !

     

    Going insane !! How can we fix that ?? I must submit my app

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 7:19 AM   in reply to minia92

    mini92, in your image of the app in iTunes i cannot see any shine effect, is it definitely showing up because your screenshot does not show any shine effect.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 7:24 AM   in reply to minia92

    Try creating it as a new app in Viewer Builder and make sure that the shine option is not selected. If that does not work, please let me know.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 7:24 AM   in reply to Jonathan Ferman

    Yes there is definetly no a shine on the icons.... So why it is add when i upload and synchronise to the Ipad?

     

    Seems to be an IOS 5 prob ??

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 7:27 AM   in reply to Jonathan Ferman

    Hey Jonathan

     

    It doesn't work, I have delete the app in the VB. And create a new one ... same prob

     

    Any idea?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 17, 2011 8:28 AM   in reply to Johannes Eckert

    Did you fond a solution Johannes on that to remove the Shine effect ? I want to be sure it will not appear in my Submitted app

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 18, 2011 1:13 AM   in reply to jamesroche

    Had confirmation from Adobe that their are dealing with Appel on that problem (IOS5)

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2011 11:09 AM   in reply to Johannes Eckert

    Just want to add that we've had the same problem with both a new and an updated app. There was a bit of confusion early on in the process with mixed up AppIDs so that may account for it, but I thought I might flag it all the same.

     

    Do we know yet if the unwanted shines are appearing on the final iTunes approved apps?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 21, 2011 12:08 PM   in reply to David Cooke

    I am dealing with this exact issue as well right now. Would also like to know if apps are appearing in the store with the unwanted shine.

     
    |
    Mark as:
  • Bob Bringhurst
    4,643 posts
    May 29, 2007
    Currently Being Moderated
    Oct 21, 2011 1:17 PM   in reply to Jerry Cooley

    Yes, this is a known bug. Shine is applied to the app icon even when the option is turned off in the Viewer Builder. It happens in both the development build and the final approved app. I don't have details as to whether Apple or Adobe needs to fix this issue, but it's been reported.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 23, 2011 6:19 AM   in reply to minia92

    Just want to add that we exeprienced more or less confusing situation when creating brand new app three weeks ago. We created new app (record) in itunes connect - and we got by deafault shine on our app icon. The app itself had no shine neither during the creation process in VB nor in developer testing. When we got OK from Apple we no longer see shine on our app in iTunes Connect. As creating app in itunes connect has nothing to do with app creation in VB we think that Apple gives this shine be deafult to every new app created within itunes connect. Then it synchronises with app file that is sent via application loadres and shows right app image. That is our theory only

     

    On the other hand - we have one app that we can't remove shine on it . We rebulit it from the scratch while changing from multifolio to itunes sub, no shine in tick box, but still we have shine in app store and itunes connect. Strange.

     
    |
    Mark as:
  • Bob Bringhurst
    4,643 posts
    May 29, 2007
    Currently Being Moderated
    Oct 23, 2011 8:10 AM   in reply to Lukasz Kawecki

    Unwanted shine is a known bug. I ran into it myself twice. My understanding is that Apple made a slight code change for iOS5, Adobe didn't discover it, and now Adobe needs to make a minor change for the next version of Viewer Builder to allow shine to be turned off.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2011 1:52 PM   in reply to Bob Bringhurst

    really annoying... The problem is still unsolved after 10 days!!! My app is on Apple reviewing (strangely it appears first on Itunes Connect with the shine, but not when we zoom/click on the icon, and now it appears whitout the shine)

     

    How can I be sure that when my app will be approved that there is are not this damned shine?

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 26, 2011 2:24 PM   in reply to minia92

    Sorry to tell you, but you can be sure that there will be a shine on it when it is approved. I just put an update for my app through the store, and it was there. I may push out an update for it once this bug is fixed, just to remove the darn thing.

     
    |
    Mark as:
  • Bob Bringhurst
    4,643 posts
    May 29, 2007
    Currently Being Moderated
    Oct 26, 2011 2:32 PM   in reply to Jerry Cooley

    The Viewer Builder server should be updated within the next day or so. When that happens, you can turn off Shine, re-build your app and submit it to Apple.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 27, 2011 3:57 AM   in reply to Bob Bringhurst

    Great !

     

    Can you please confirmed when it's done ?

     

    Many thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 27, 2011 4:13 AM   in reply to minia92

    Hi everyone,

     

    I wanted to provide a little more information about the 'shine on' bug and what we are doing to fix it and what you will need to do. We hope to have these fixes in place by 10am PST (6pm GMT). This is an update tot he server you will not need to download a new Viewer Builder client.

     

    On October 27 the Viewer Builder server is being updated to provide two fixes for problems discovered with iOS 5 on the iPad:

     

    1.  Shine always appears on app icons – With iOS 5, Apple required an extra setting to turn shine on or off. We added this setting to the Viewer Builder server. For any apps in which you want to turn shine off, you must rebuild your app using the updated Viewer Builder and submit it to Apple.

     

    2. Progressive-download pausing on idle - We made a change to address the progressive-download pausing problem on iOS5. In this update, we prevent the iPad from going to sleep while downloading a folio. When the folio finishes downloading, we will re-enable any sleep settings the user has applied on their iPad. The change impacts only the sleep behavior of the iPad within your app; it's an application setting not a global setting. Your app will still let the iPad screen sleep when a download is interrupted or in the unlikely event that another error occurs.

     

    How to enable these changes into your apps

     

    If you are creating new apps in Viewer Builder after 10am (Pacific Standard Time) on October 27th, you will automatically have these two changes integrated. To enable these fixes, into an existing app you will need to do the following:

     

    1.  Log in to Viewer Builder with your Adobe ID

    2.  In the Manage Screen click on the app you want to Edit and click the 'Edit' button.

    3.  Move through the different pages and settings ensuring that all settings are correct and have not changed.

    4.  In the Icons and Splash screens page click ensure that the 'Shine on app icon' is unchecked if you do not want the shine effect applied to your icons.

    5.  After going through all the screens and settings in Viewer Builder click the 'Submit' button and wait for your app to rebuild.

    6.  Submit your app to Apple as a bug fix if it is already live on the iTunes Store

    7.  Repeat steps 2 – 6 for any other apps you have they you also want to rebuild.

     

    Jonathan Ferman, Viewer Builder Product Manager

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 27, 2011 8:47 AM   in reply to Jonathan Ferman

    Viewer Builder server deployment is now complete. The fix for the shine being on for all apps has been fixed. Please see my above post for further details. Apologies for any inconvenience for those of you that did not want shiny icons in iOS 5.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 27, 2011 11:31 AM   in reply to Jonathan Ferman

    Thanks for the update and specific instructions. I've updated mine and submitted to Apple.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2011 7:25 PM   in reply to Jerry Cooley

    Super thanks Jonathan

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)