Skip navigation
Currently Being Moderated

Plans for alchemy - 11.2 deactivates opcode with no upgrade option?

Nov 23, 2011 9:14 AM

Today i read this tweet from Nicolas Canasse, author and founder of the HaXe language:

 

https://twitter.com/#!/ncannasse/status/139285736636694528

 

Is this correct? Does the existing alchemy no longer work in 11.2, and is this a planned update for release?

 

Its not that I thought this day would never come, quite the opposite actually. I was looking forward to the new alchemy enhancements and when we'd be able to read more about them. But there has been nothing more so far from Adobe on what is being released and when - and the prospect of having no alchemy options at all for a time feels like an incredible dumb move from adobe as it

 

a) alienate communities producing alchemy-based libraries that offer features available nowhere else in flash.

 

b) alienate potential paying customers of alchemy who would be happy to upgrade to the new paid-license model, if only there were an upgrade available

 

 

just one question - is it intentional?

 

 

cheers

 

 

Rob

 
Replies
  • Currently Being Moderated
    Nov 23, 2011 9:52 AM   in reply to rob.bateman

    I just tried my Alchemy lib with 11.2.202.95 (on mac and win) and it works fine.

     

    Also, this guy seems to be doing stuff with domainMemory (tho not Alchemy):

         http://www.visualiser.fr/blog/index.php?q=blogs/samuel-girardin

    and he's using 11.2.

     

    And here's another tweet:

         http://twitter.com/#!/quasimondo/status/139303024496607233

     

    Looks like @inspirit's Alchemy demos still work with 11.2 beta. Is it maybe a haxe issue?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 23, 2011 3:50 PM   in reply to rob.bateman

    Here's another post by the guy who did the original tweet:

        http://ncannasse.fr/blog/adobe_make_some_alchemy

    who quotes this page

        http://blogs.adobe.com/flashplayer/2011/09/updates-from-the-lab.html

    Starting with Flash Player 11.2 and AIR 3.2, content targeting Flash Player 11 and AIR 3 (i.e., content using SWF version 13 and above) will not support the experimental Alchemy prototype.

    As I said earlier, my Alchemy project runs fine in 11.2.  But I think it may be because I've compiled it with swfversion=11 (FP 10.2).  It seems that you can't compile against swfversion=13 (FP 11.2) and use the pre-release Alchemy. 

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 23, 2011 4:43 PM   in reply to rob.bateman

    @rob.bateman: I get that same RangeError when I compile my Alchemy project for swf-version=13.  But when its compiled normally (swf-version=11) it works fine in FP 11.2.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 23, 2011 11:25 PM   in reply to rob.bateman

    Hi guys,

     

    Yes, staring from Flash Player 11.2 or AIR 3.2, if your content is targeting swf-version 13 and above, you will need Alchemy 2.

     

    We will share more details about Alchemy 2 as soon as possible.

     

    For third-party tools using the opcodes which may not require Alchemy 2, we are also looking at finding a solution.

     

    Mike posted some more thoughts on Nicolas's blog :

     

    The changes in the current Flash Player beta are targeted as part of the process of making Alchemy into a product. However, it is clear that the current solution is not optimal for developers using the undocumented op-code APIs directly. We don't have a solution for this just yet but our goal is to provide one. We are in the process of reaching out directly to developers to help come up with a solution that will ideally address these concerns.

    In the meantime, if you need to develop on the latest beta player, then you can use the beta standalone players (standard and debug). The op codes still work there (let me know if you see otherwise). You can grab it from here:

    http://labs.adobe.com/downloads/flashplayer11-2.html

    Please remember that this is currently a beta, and this type of feedback is one of the primary reasons we post the betas online.

    Thibault

    Sr. Product Manager | Flash Player and AIR

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 1, 2011 10:10 AM   in reply to Thibault Imbert

    Hey!

    Adobe changes fp 11.2 beta then we need to use alchemy 2? ok! it's fine for me!

    i'll buy it! no problem!

    ... but at least tell us when and where and how much $$ !!

    and please  tell it asap because our business and investiments depends on it.

     

    I know you , adobe guys, will understand the developers needs.

     

    ( hey Thibault!, hope to see you again at FGS in 2012 )

     

    cheers.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 21, 2011 3:08 AM   in reply to Dario Pelella

    go oracle javafx

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2011 5:39 PM   in reply to rob.bateman

    this is the last straw for me. Adobe seems intent on shooting itself in the foot. Over and over. I'm moving all my development into haXe + HTML5/WebGL. Goodbye

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 7, 2011 3:02 AM   in reply to Thibault Imbert

    Thanks for the update Thibault.

     

    While I certainly understand everyones concerns (I'm included), I most certainly look forward to Alchemy 2.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Dec 21, 2011 2:25 AM   in reply to rob.bateman

    Can anyone at Adobe tell us when Alchemy 2 will be available, and what the pricing structure will be?

     

    I am a games developer using Away3D with the Alchemy Bullet port.

     

    This is bad news enough for us developers with real-world projects and deadlines, however Adobe have taken this step without having any details on how they intend to make money from us via Alchemy 2. I am now considering porting to alternative technologies. In my 10+ years as a Flash developer the last 2 months have been the worst in terms of Adobe screwing up and getting greedy. Isn't a $billion a quarter enough for you guys?

     

    Adobe management need to think about the valuable developer mindshare and loyalty they are throwing away - its possibly not too late to reverse the damage.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 31, 2011 10:10 PM   in reply to Grime-P

    i just tried my game I'm making that targets fp11 swf version 13 and uses box2D alchemy and it worked in the fp11.2 beta but if  it does not  work in the release 11.2 it wud be bad adobe please let the old alchemy work, or atleast let the new alchemy be free for indie game developers. and please update us asap, a lot of projects are dependant on these fp11 and alchemy prototype, we would atleast like the old alchemy to keep runing, as many devs have released games that use the alchemy prototype on fp11. And even though its a prototype we need to release something with it otherwise we would never know if we wanted it

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points