Skip navigation
Currently Being Moderated

Animations imported into Captivate 5.5 not playing correctly.

Oct 6, 2011 11:39 AM

Tags: #publishing #not #version #working #files #library #links #visible #captivate #5.5 #in #upgrade #glitches #bugs #problems #broken #previous #swfs #5 #animations #projects #correctly #disappearing

This issue started when I tried to open a Cp 5 project in Cp 5.5.  The animations don't play at all if the "Synchronize with Project" option is On and the anmiation starts at 0 sec on the timeline. Also, there is a visible "blink" between animations on the same slide and between slides. 


I've been using Cp 5 for about a year and have worked out my issues with it so these are the things that AREN'T wrong:  The transitions for slides and swfs are set to "No Transitions," there is no space between swfs on the timeline that would be making the "blink," there are no blank frames at the end of the timeline in the swf files(inside of Flash), the swfs are AS3, they are only as long as their original timeline, my Preferences are set to no fades on Start and End slides, and my timelines do not extend beyond their content to show white space.


The files work fine in Cp 5.  The file animation links are also randomly missing/broken when brought into Cp 5.5 and even after I re-establish them, they periodically turn red (not up to date).


So I figured, "Maybe I can't work with previous version files.  I'll just start a new blank project in Cp 5.5." Right? . . . Not right.  Swfs still aren't visible when published if they are set to "Synchronize with Project" AND start at the 0 sec mark.  They still "blink" between swfs and slides.  So maybe I can't use Flash 5 files in Cp 5.5 either.  If that is the case, this upgrade was a waste of time and money and should not have been released until these MAJOR issues were resolved.


Someone from support is looking into it, but so far the only advice that I got was "Turn the Sync option off and fade into your next animations."  What?! The sync option is very important because that keeps your animations playing correctly when people scrub the playhead.  If Cp 5.5 is programmed to do that automatically, then why keep the option button?  If not, do you really expect me to NOT want my animations to play consistently when people drag around the playhead?  As for the fading, maybe fading out after every animation swf is not an option for me, maybe I need it to be seamless.  And to that I was told, "Put all your animations together in one Flash file." Duh, but that was how this needing Cp to assemble my separate swfs started in the first place. If any of you have tried importing 3D rendered pngs into Flash, you know that you can only have so many frames before the program can't handle the load and crashes.  I can only support aoubt 250-300 frames of optimized pngs before Flash crashes on me and thats WITH 16GB of ram on a new 64 bit operating system.


If anyone has had this issue and found a fix or some kind of pending patch, please let me know, because by now, I'm wanting a refund.

  • Currently Being Moderated
    Nov 3, 2011 11:35 PM   in reply to asura_Bs


    Were you able to solve this issue?

    I am currently encountering the same. I have upgraded my Captivate 4 (AS3) Project into Captivate 5.5 none of the publish setting is changed, preview it and all of a sudden none of the swf is working, which previously worked very well in version 4. Unchecking the "Synchronize to Project" makes things different, but unchecking it would result in my swfs flickering at the beginning and the end.

    Upgrading project should't result on problems like this.

    Or I might just be missing something.





    Mark as:
  • Currently Being Moderated
    Nov 3, 2011 11:59 PM   in reply to salvador_sorianojr

    Captivate 5 was a total rewrite from the Captivate 4 software architecture and it introduced a subtle but fundamental change in the way that Flash animations were handled in Captivate published content.


    Basically the change means that if your animation was built down a level or two inside a symbol rather than on the main timeline at the top level, then you will find that Captivate 5 or 5.5 loads and executes the animation on the first slide of the movie. This means that by the time you get to the actual slide where you WANTED the animation to perform it's magic, it's already run and finished.


    In Captivate 4 this did not happen.  The animation was not really loaded until later in the movie timeline so as to be ready for the slide where it was required.  It didn't matter if the animation was buried inside a symbol or not.


    You have two choices:

    1. Revamp your animation so that it all happens on the main timeline in the Flash FLA file that generates it.
    2. Get your Flash programmer to add some ActionScript code to the animation so that it does NOT play completely when first loaded at the beginning of the project at runtime.


    I agree that Captivate would have been regarded as less of a beast if this change had NOT been made, as users only find out about it AFTER upgrading projects with animations built as symbols.  However, I have to trust that if the change was introduced, there must have been a very good reason.

    Mark as:
  • Currently Being Moderated
    Nov 4, 2011 5:39 AM   in reply to asura_Bs

    Why can't you just use Loader in Flash to load your swfs, or ditch the IDE altogether and use Embed?  It seems to me that this isn't a problem Captivate was made to solve.

    Mark as:
  • Currently Being Moderated
    Nov 13, 2011 10:24 PM   in reply to asura_Bs

    Thank you very much, this is indeed a fix.

    I wonder why Captivate Developer's do not have a documentation about this.

    Mark as:
  • Currently Being Moderated
    Dec 3, 2011 4:03 AM   in reply to asura_Bs

    Could someone please direct me to a solution for this same issue on Mac?




    Mark as:
  • Currently Being Moderated
    Dec 8, 2011 12:10 PM   in reply to asura_Bs

    Thanks asura_Bs for the reply.  Will look into it.

    Mark as:
  • Currently Being Moderated
    Dec 9, 2011 10:40 AM   in reply to asura_Bs

    Someone else had a similar issue but posted in a different forum.  I'm adding a cross reference here:


    Jim Leichliter

    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 6:52 AM   in reply to asura_Bs

    We ran into the same problem. All we did was move the animation to 0.1 second on the timeline and it worked just fine. We kept the sync setting as well, which is imperative for us. Whew!

    Mark as:
  • Currently Being Moderated
    Nov 1, 2013 11:57 AM   in reply to Michelle Lasure

    I have interjected a swf animation slide in between others in a Captivate 5.5 project.

    I published it and put it up into our LMS.


    When the project plays and arrives at the swf slide I slide the progress bar ahead to the end of the swf slide.

    The slide goes white and then there's no way to progress further.


    If I allow the swf slide to progress all the way through by itself it progresses fine.


    Would the*Q  file mentioned above help with this issue or do I need to do something different?


    Also, where is this "sync" setting described above and should it be synced or not?


    Thank you

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points