Skip navigation
Currently Being Moderated

Shadow/Highlight flickering

Nov 30, 2010 6:54 AM

When I use the shadow/highlight effect, my image flickers.  I'm using manual settings.  Someone suggested changing black clip to 0%, but that did not help.  Is there another way to use this effect without flicker?

 

Thanks,

JB

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Dec 1, 2010 3:35 PM   in reply to Jack Banatoni

    Make sure that Temporal Smoothing is enabled. See this page for details:

    "Shadow/Highlight effect"

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 1, 2010 5:13 PM   in reply to Jack Banatoni

    JB,

     

    Are you leaving the Auto box checked? I find that it will likely introduce flickering, or strobing. I never use that, and will manually adjust S & H accordingly.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2010 12:28 PM   in reply to Jack Banatoni

    Did you try using 'Levels' instead.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 18, 2010 12:16 PM   in reply to Jack Banatoni

    I also use Levels and H&S. I never use the H&S Auto setting, as it will usually lead to "flickering," unless the lighting and exposure are exactly the same for the total Duration of that Clip. I do it with manual settings ONLY.

     

    Good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Apr 14, 2011 6:18 AM   in reply to Bill Hunt

    The solution to this problem:

     

    http://jdvos.com/?p=247

     

    Actually quite simple...

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 14, 2011 8:40 PM   in reply to jdv

    jvos213 wrote:

     

    The solution to this problem:

     

    http://jdvos.com/?p=247

     

    Actually quite simple...

    That is a silly solution.

     

    The answer was given early on .  Temporal smoothing  Did you enebale ti and increase the time value?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 14, 2011 10:40 PM   in reply to Curt Wrigley

    Yes, actually I did even though I dislike the Auto setting intensely and it did not work.

     

    Uneccesary to call something 'silly' just because its not conventional and if it fixes a problem which (despite your opinion) has not been adressed propperly then who cares how its done?

     

    To make it clear:

     

    TEMPORAL SMOOTHING IS ONLY AVAILIBLE WHEN USING THE AUTO FUNCTION IN THE SHADOWS HIGHLIGHTS EFFECT. This fix applies to people using maunal adjustments of this effect as mentioned in the link you mocked.

     

    Shadows and Highlights is pretty much a big no-go on Auto (feel free to google this topic, quite easy to see I'm not making this up) and if you have a look around you see that people who did indeed have this problem in 'Auto' mode and tried the suggested 'Temporal Shift' found that it does not work for this particular problem.

     

    To those who ran into the same wall, feel free to try this silly solution, wont take you more than 5 minutes to apply (minus rendering time of course:)

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 27, 2011 11:20 AM   in reply to jdv

    This solution isn't silly. It's completely ridiculous.

    Another example why Premiere isn't made properly and fails to be a professional tool, in my opinion.

     

    In 6 years running Premiere and teaching people in schools to use it, even I cannot say it's anything more than a glitchy piece of software that would be incredible if it was half as stable as it made out to be.

     

    I suggest Adobe beta test it more, as it feels like it's beta tested for a week on brand new machines for which every single component, down to the DVD drive is tailored with nothing in mind other than Premiere compatibility. Get real! Why does every competing package run so much better on a wider variety of machines?

     

    I used to be one of the people that kept making excuses for Premiere, thinking it was my fault, and now I just now I need to let go and see how much further competition has come.

     

    (this is all before addressing about 6 other issues ranging from Adobe losing information on my tech support cases, to failing to do callbacks...)

     

    Rant complete.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Apr 30, 2011 2:50 AM   in reply to Jack Banatoni

    Jack,

     

    Did you ever find a workable solution?  Runing into the same problem.  First time I have tried S/H since I upgraded from CS4.

     

    thanks,

    rod

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 28, 2011 8:53 PM   in reply to rodney_ray

    This is absolutely disgusting.  I'm getting intense flickering with manual Shadow & Highlight settings on Export.  Adobe hasn't done anything to resolve this.  It is thus an amateurish piece of toy software.  This is happening without any other effects applied to a simple clip but Shadow & Highlight.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 4:28 AM   in reply to hpmoon

    The information you need about using the Shadow/Highlight effect is here, as Todd mentioned previously:

     

    Adobe Premiere Pro CS5 & CS5.5 * Shadow/Highlight effect

     

    If you would like a different behavior, then please file a feature request here:

     

    Adobe - Feature Request/Bug Report Form

     

    -Jeff

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 3:40 PM   in reply to Jeff Bellune

    Jeff Bellune wrote:

     

    The information you need about using the Shadow/Highlight effect is here, as Todd mentioned previously:

     

    Adobe Premiere Pro CS5 & CS5.5 * Shadow/Highlight effect

     

    If you would like a different behavior, then please file a feature request here:

     

    Adobe - Feature Request/Bug Report Form

     

    -Jeff

     

    I have no idea why you keep linking people over to the help file for the Shadow/Highlight  effect.  There is absolutely no bit of information there that could lead  to any resolution of this issue.  It's an example of why people can get  so inflamed here; regulars like yourself -- though you are compensated, since your caption is a "Community Professional" -- purport to offer answers (a) without  thinking about whether it will actually address the problem; (b)  defending Adobe as a starting point; and (c) taking the easiest path of  citing already-established generalities.

     

    This is a bug,  plain and simple.  It dates back years, and hundreds of people have reported it across the Web.  [Advice:  spend a minute looking.]  I have submitted repeated bug  reports.  Many, many other users have too.  This is a simple case of  Adobe letting the issue slide.  Like a billion others.  One tiny  example:  ever wondered what those Auto Black Levels and Auto White  Levels buttons do in the Fast Color Corrector?  Absolutely nothing.   That's been the case for several years now.  Great job, Adobe.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 3:59 PM   in reply to hpmoon

    > I have no idea why you keep linking people over to the help file for the Shadow/Highlight  effect.  There is absolutely no bit of information there that could lead  to any resolution of this issue.

     

     

    The page that Jeff pointed to contains information about the Temporal Smoothing control, which is suppsed to prevent flickering. You never said whether you had tried to use that control, even though it was suggested earlier in this thread.

     

    > though you are compensated, since your caption is a "Community Professional"

     

     

    That is only an acknowledgment by a group here at Adobe that Jeff has shown himself to be a knowledgeable and helpful person---which he is. It is no indication of compensation by Adobe.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 4:06 PM   in reply to Todd_Kopriva

    Todd_Kopriva wrote:

     

    > I have no idea why you keep linking people over to the help file for the Shadow/Highlight  effect.  There is absolutely no bit of information there that could lead  to any resolution of this issue.

     

     

    The page that Jeff pointed to contains information about the Temporal Smoothing control, which is suppsed to prevent flickering. You never said whether you had tried to use that control, even though it was suggested earlier in this thread.

     

    > though you are compensated, since your caption is a "Community Professional"

     

     

    That is only an acknowledgment by a group here at Adobe that Jeff has shown himself to be a knowledgeable and helpful person---which he is. It is no indication of compensation by Adobe.

     

    Seriously, this is why I question the value of these forums altogether.  People don't simply read the threads, as is standard in true power user forums all across the Interwebs.  If you merely scroll up this short thread, you'll see how obviously Temporal Smoothing is no solution, and 100% irrelevant to the issue being complained about here, which is flickering and banding during both rendering and even paused playback on the timeline in full manual mode.  Temporal smoothing is totally unavailable in manual mode, and Jeff knew that.

     

    Since you are an actual Adobe employee, Todd, I have some advice:  presume that your customers are pointing out an error that Adobe can fix, instead of beginning with the hope that it's not Adobe's fault.  That's good customer service, or in other terms, the only way you'll survive as a business.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 6:34 PM   in reply to hpmoon

    Can you post all of the S & H settings, chosen, that are giving you that flicker?

     

    As I have never observed it, I want to duplicate it, if I possibly can.

     

    Thank you,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 6:42 PM   in reply to Bill Hunt

    Shadow-Highlight Effect Settings Sample.png

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 6:52 PM   in reply to hpmoon

    Thank you for that info.

     

    I just applied those settings to a DV-AVI Clip (SD), and Rendered that Clip. I could detect no flicker or banding, even with the Program Monitor nearly full screen on my laptop and the Magnification at 150%.

     

    What are the specs. of the Clip, where you observe those issues?

     

    I'll be glad to try with any Source Footage, that I can get my hands on.

     

    Appreciated, and good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 29, 2011 11:18 PM   in reply to Bill Hunt

    the_wine_snob wrote:

     

    Thank you for that info.

     

    I just applied those settings to a DV-AVI Clip (SD), and Rendered that Clip. I could detect no flicker or banding, even with the Program Monitor nearly full screen on my laptop and the Magnification at 150%.

     

    What are the specs. of the Clip, where you observe those issues?

     

    I'll be glad to try with any Source Footage, that I can get my hands on.

     

    Appreciated, and good luck,

     

    Hunt

     

    Thanks for checking it out.  Here's another thing to see, a screen grab that shows the Program Monitor view when the time marker is in the clip with the Shadow/Highlight effect enabled using those settings I mentioned earlier.  The source clip is a simple MPEG-2 1280x720p 29.97fps file at a moderate bitrate.

     

    Ribbons Color Reference.jpg

     

    The thin band at the top is showing the proper application of the effect; it moves around frame-by-frame (there are no keyframes, cropping, etc., of course) and that is the "flickering" that people are talking about/reporting.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2011 9:34 AM   in reply to hpmoon

    Wow, that IS obvious. I nearly went blind, looking for tiny flickers and banding (at least it did prompt me to clean the laptop's monitor!).

     

    I saw nothing even close.

     

    Am I correct that the problem exists in Exported footage too, and not just in the Program Monitor? If only in the Program Monitor, I would quickly check the video card's installed driver. If in Export, I am at a loss to explain what you show. I will definitely have to defer to Todd, Kevin, or someone else there.

     

    Thanks for the screen-cap and good luck,

     

    Hunt

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2011 10:32 PM   in reply to Bill Hunt

    the_wine_snob wrote:

     

    Wow, that IS obvious. I nearly went blind, looking for tiny flickers and banding (at least it did prompt me to clean the laptop's monitor!).

     

    I saw nothing even close.

     

    Am I correct that the problem exists in Exported footage too, and not just in the Program Monitor? If only in the Program Monitor, I would quickly check the video card's installed driver. If in Export, I am at a loss to explain what you show. I will definitely have to defer to Todd, Kevin, or someone else there.

     

    Thanks for the screen-cap and good luck,

     

    Hunt

     

    I'm afraid the same thing happens on rendering/export.  Definitely a bug.  Jeff Bellune keeps insisting it isn't.

     

    Thanks for taking a look.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 6, 2011 12:02 PM   in reply to Jack Banatoni

    I can confirm the flicker issue, and it is rather pronounced (=unacceptable) in certain videos, e.g. with high contrast shooting beach seaside in full sunshine.

    I am amazed at how some guys in this thread that are supposed to be community helper veterans ignore the issue, brush off the reports, and link us back to some basic help pages.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2011 8:46 PM   in reply to sunlit777

    I gave up entirely on shadow/ highlight, and this proposed alternative 'Levels'  is a different function entirley as far as I can work.

    Levels  does not 'even out' highlights or shadows.

    It narrows the dynamic range doesn't it. Almost the opposite.

    If Adobe Premiere could get this right it would bre a big plus, is there any update to resolving this problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 16, 2011 8:28 PM   in reply to Jack Banatoni

    Thanks for the update Jack, I didn't know that the RBG levels failed.

    I think I misunderstood the value of levels early on, and just never got round to trying RBG levels.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 27, 2012 10:22 PM   in reply to Jack Banatoni

    I have exactly the same issue but ONLY with DSLR footage, it's almost as if the rolling shutter affects the flicker...very strange. There are quite a few posts about this but no solution, so i presume it must be a bug.

    The quickest way i found to work around with the problem was delete the H/S effect on all the clips and use the Brightness/Contrast tool instead, which seems to work well with exposure issues.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 18, 2012 1:35 AM   in reply to quiche_me_quick

    Hello, I came as well into that issue, we are using a high quality highspeed camera with high quality images. Whenever I try to apply shadow & highlight with "Automatic" OFF it always creates dramatic flickering in the preview as well as in the exported material. It doesn't matter which setting.

     

    Is there any further solution than cutting the clip into very small parts?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2013 5:48 PM   in reply to quiche_me_quick

    I noticed the same thing.  When comparing the exact same video with my DSLR (1920/1080 30fps) and my camcorder (1080i/480i 30fps) the DSLR flickered while the other did not.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2013 8:18 PM   in reply to Jack Banatoni

    I'll chime in to and confirm Shadow/Highlight causes a visible and unacceptable flickering on at least half of the shots I apply it to. That is common across AE CS5/6 and PR CS5/6, in both Auto+Temporal Smoothing and full manual modes. I've found flickering across a range of sources (Red, AVCHD, HDSLR, Uncompressed digibeta, MiniDV) at range of resolutions. All clips that flicker were shot on full manual with no adjustment in exposure settings. I can't work out what causes the flickering - I haven't been able to find any pattern amongst the clips that do. It's a real shame because when it works the filter does some truly wonderful things to perceived dynamic range.

     

    Also, the bug/feature request form links to an error page whenever I submit an entry.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Mar 21, 2013 5:37 PM   in reply to Jack Banatoni

    I figured it out.

     

    Make sure there is no video BELOW the clip being effected, and the flicker magically disapears.  You can also just "de-enable" all the clips below, or insert a slug.  BOOM!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 26, 2013 7:57 PM   in reply to jessechandler

    I'm afraid to report I still get flickering no matter what, if anything, is sitting below the clip in question - I've had a few instances this morning on the timeline I'm working on. But I'm glad it's working for you Jesse!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 4:09 PM   in reply to Jack Banatoni

    I'm here reporting the same bug. For me, what worked was making sure I only had one video element active at a time, so no layers stacked on top of each other. A little annoying but it can be fixed by pre-rendering elements. Not sure if this will work for anyone else.

     

    I'd also like to note that reading this thread made me physically sick. All the old video pros coming in and chipping in their two cents without reading what people wrote before... "easy fix, just enable temporal smoothing." C'mon, pay attention.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2013 10:45 PM   in reply to mde.tv

    mde.tv wrote:

     

    I'd also like to note that reading this thread made me physically sick. All the old video pros coming in and chipping in their two cents without reading what people wrote before... "easy fix, just enable temporal smoothing." C'mon, pay attention.

     

    Exactly.  It's a big problem here; they'll ban you for mentioning the names of the old veterans with thousands of posts, but it's totally true.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 14, 2013 3:07 PM   in reply to hpmoon

    has anyone been able to find an alternative to highlights/shadow?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 14, 2013 6:32 PM   in reply to shuenwang

    There is none. Make sure there are no video tracks above/below the track you are adding the effect to, turn off auto amounts, and turn black clip/white clip down to 0%... one or all of those things may be required to remove the flicker effect.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 23, 2013 11:31 AM   in reply to Jack Banatoni

    For those of you that simply notice the "sky" in your clips flickering when using Shadow/Highlight Adjustment, make sure to set at least the Black Clip and/or White Clip from .01 to 0. This will stop that annoying flicker throughout the entire clip.

     

    If you do a crossfade, with two shadow/hightlight adjusted clips, you get another type of flicker. Rendering without GPU acceleration will solve the problem. Go into Project/Project Settings/General and click software only. Save the file, close out, reopen. It works.

     

    The problem occurs when two clips that both have Shadow/Highlight adjusment with different values are crossfaded. You get this light dark bands of flickering in the crossfade. It looks horrible.

     

    Setting the clipping amounts to 0, as opposed to the default of .01 will help with the clip flickering, but NOT the crossfade flikering. It will not help

    Using Opacity keyframes as opposed to the Crossfade Video Transition Effect will not help.

     

    Rendering without GPU acceleration will solve the problem. Another way to solve the problem is to make INTER clips. Render the two clips seperately with all shadow/highlight effects, then replace the clips on your timeline with the rendered clips and THEN crossfade them.

     

    IT IS POSSIBLE THAT ALL SHADOW/HIGHLIGHT ADJUSTMENT FLICKERING IS CAUSED BY YOUR GPU CARD AND THIS MAY BE WHY ADOBE DOESNT SEE THE PROBLEM. Im not sure!

     
    |
    Mark as:
1 2 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points