Skip navigation
monaronyc
Currently Being Moderated

Photoshop and Lion 10.7.2

Dec 14, 2011 5:57 AM

Hi Group!

 

All of the sudden I've been cursed with this problem in Photoshop CS 5.1 where everytime i try to open Photoshop, i get the following error message:

 

'Could not initialize Photoshop because the file is locked or you do not have the necessary access privileges. Use the 'Get Info' command in the Finder to unlock the file or change permissions on the file or enclosing folders.'

 

Get info on WHAT FILE? WHAT FOLDER?

 

I tried whacking the Photoshop Prefs using the Command + Option + Shift trick but that didn't work.

Repaired permissions. That didn't work.

Uninstalled and Reinstalled CS 5.5. Fullyupdated. That didn't work!

Checked the disk for errors. That didn't work.

Dumped any and ALL .plists and/or cache related files. That didn't work.

 

 

And funny enough (which I'll post under the Indesign group), I can't open Indesign either all of the sudden. It just QUITS out as soon as the IDCS5.5 splash screen appears. POP goes the weasle!

 

I am at a stand still with this folks.

 

Any help would be GREATLY appreciated!

 

PhotoshopScratch.png

 
Replies
  • Currently Being Moderated
    Dec 14, 2011 6:41 AM   in reply to monaronyc

    Well, you seem to have gone through the usual trouble-shooting procedures already.

    Have you verified if the application file itself may be locked?

    Have you restarted the computer after repairing permissions?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 14, 2011 9:15 AM   in reply to monaronyc

    Permissions problems can be very frustrating.

    Don't know if this will correct your problem, but give it a try:

     

    In Finder, go to Applications > Adobe Photoshop CS5.

    Contol-click on folder.

    From pop-up, choose Get Info.

    Do the same for the actual application file that's contained within the Adobe Photoshop CS5 folder.

    Check/correct settings as shown below.

     

    privileges_ps forum.jpg

     

    Hope that helps.

     

    edit:

    Since you're having problems with InDesign as well, check permissions on your Applications folder.

     

    Message was edited by: Rick McCleary

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 14, 2011 11:31 AM   in reply to Rick McCleary

    Thanks for the relpy!

     

    c.pfaffenbichler: Yes, I checked all related Photoshop files for permissions. All appears to be in order as far as i can tell.

    And yes, I always reboot after a permissions repair. Thanks or asking!

     

    Rick, everything in Finder checks out. Nothing locked.

    One thing though... I tried opening PS under a local user account.

    And guess what... PHOTOSHOP OPENED! Which leads me to believe we have a PERMISSIONS problem on our hands.

    Indesign still crashed though.

     

    On top of all this... our Macs are joined to Active Directory. AD bind. Which also means MOBILE Accounts.

    So who knows what and where something is getting blocked.

    The local account is an ADMIN account. My user MOBILE account is also and ADMIN account.

     

    I'll keep digging. Somethings definitely up!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 14, 2011 11:56 AM   in reply to harpercollins

    Sounds like a network problem. Yuck.

    From what I understand, AD manages identities and permissions over the network.

    Could this be the source of the problem?

     

    re: InDesign crashing

    Is ID resident on your machine? Or are you opening it over a network?

    If it's resident on your machine, you may want to try rebuilding the disk directory (with Tech Tool or something similar).

    Sometimes the disk directory becomes corrupted and loses track of where all the application's assets are resulting in a failure to open.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points