Skip navigation
jefflamonica
Currently Being Moderated

Extra blank lines in source code

Aug 3, 2011 12:06 PM

I have built a website in Dreamweaver CS4 and have a client editing pages in Contribute CS5. Both of us are working on Windows 7, and the site is hosted on Linux. When she makes edits to the page, something is introducing a GAZILLION blank lines in the source code. A typical page for this site is about 380 lines of code. The problem page is now more than 310,000 lines code with 100-200 blank lines between every "real" line of code. What the...?!

 

I need to know how to stop this and how to remove the blank lines from the source code using Dreamweaver.

 

The page in question lives here: http://www.alexandercitychamber.com/member-category.html

 

HELP!!!

 

Jeff

 
Replies
  • Currently Being Moderated
    Aug 9, 2011 12:00 AM   in reply to jefflamonica

    Please read theblog https://blogs.adobe.com/contribute/2010/06/paragraph_spacing_options_i n_a.html  for more details.

     

    hope this helps

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2011 9:30 PM   in reply to jefflamonica

    Jeff -- have you found a solution?  I have exactly the same problem except the extra lines are up to over about two million!   The apply source formatting command doesn't work.  The extra blank lines in the source code are all in an editable area in the head section, in front of style definitions the client has added to the page.  augh!

     

    I do not have the exact software the person who has been doing the maintenance is using (they move equipment around).  I think it is Windows 7 and Contribute CS5, but I'll find out asap.

     

    Any help will be greatly appreciated.

     

    Thanks! Diane

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 20, 2011 9:48 PM   in reply to Diane123456

    I am able to remove the blank lines by highlighting them and "cutting" them out... but I need to know how to prevent this from happening.

     

    I've noticed that Contribute does add a few extra lines to the source code when I go in and do the heavy lifting on one of my sites that the client is maintaining... which is annoying but until now has been harmless -- this is simply ridiculous...

     

    What about everyone else?  Have you noticed a lot of extra lines in your source code after you (or your client) edits the page with Contribute?

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 24, 2011 12:40 AM   in reply to jefflamonica

    Thank You So Much Jeff,

     

    I turned on some music, bit the bullet and deleted those lines <ugh>.   Maybe I'll try the routine your developer friend found on a forum on a backup copy just to test it.

     

    Yes I'm using Dreamweaver.  I've CS5, but only CS4 for Contribute.   I'm wondering if you're using CS5.   I don't recall seeing server type anywhere.  In my case, all my sites are on Unix servers, so if I saw a Windows server setting I would definitely have changed it. 

     

    However.... now that you mention this, there is a drop down menu for line break type on the editing screen and the options are Windows, Mac, or Unix.  Could this possibly be the CS4 equivalent?  If so, what is the Mac setting for?  I guess I'll do a little experimenting, but not tonight <big yawn, long day>

     

    I'll share my results tomorrow

     

    thanks again,

     

    Diane

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 23, 2011 8:04 AM   in reply to jefflamonica

    Oh boy!  Thank you very much for posting this!  You've just saved me tons of work!  I found out that if you change that setting and republish the page, you don't have to do anything else.  It automatically takes the blank lines of code out.

     

    Unix doesn't seem to want to stick, and I've never had this issue with any other versions of Contribute.  Is there any way to make this a default setting?  That would be great!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 2, 2012 10:38 PM   in reply to JulesN

    Once you had chosen this setting it should remember the saved setting. You can refer to https://blogs.adobe.com/contribute/2010/06/paragraph_spacing_options_i n_a.html for more details on this setting.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 3, 2012 9:16 AM   in reply to Dominic Michael

    Well Dominic,

     

    I don't know if this is a Mac thing, or if my settings are completely out of whack, but it doesn't remember my settings at all.  In fact, I have the entire Web collection cs5.5, and my settings don't get remembered on any other program, either.  Don't know if there's an adjustment for that or not.  I'm using Lion, which I think has created some issues that I never had before.  Hmmmmm....

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 3, 2012 9:24 PM   in reply to JulesN

    I doubt that user account might have some folder access/permission issue. Can you please try creating new User account in Mac and then verify whether the settings are remembered?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 4, 2012 11:35 AM   in reply to Dominic Michael

    Well, I created a new user account.  Logged in... started up Contribute... set up a couple different Websites, the first one to use the Unix setting, and when I set up the second one, it automatically listed Windows again.

     

    I have decided it isn't that important and will just remember to go back in and choose it.  I did rename the preferences files in my normal user account and have seemed to get it to remember last used settings on other programs such as PS.  That's a big deal to me, all by itself!  Maybe that'll stop DW from crashing constantly on me as well!  Really shouldn't have downloaded Lion!!!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points