Skip navigation
stellarceo
Currently Being Moderated

Field Appearance "underline" not visable in Preview PDF

Dec 28, 2011 3:50 PM

Hello,

 

I have tried to set the appearance of a text field with "underline" characteristics and it does not appear in the Preview PDF view.  "Sunken" and "Solid Box" appear fine.  I have tried both FormCalc and Jave languages.  No go!  I have tried also in a table with no success.  Can someone help me please?  Thank you.

 

Bill

 
Replies
  • Currently Being Moderated
    Dec 29, 2011 12:35 PM   in reply to stellarceo

    Hi,

     

    Are you setting the visual appearance of the object at Design Time (eg in the Object > Field palette)? Or are you using script to change the visual appearance at Runtime?

     

    If it is the latter, then have a look at page 2 of this example: http://assure.ly/ewrLMo.

     

    Hope that helps,

     

    Niall

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 29, 2011 8:49 PM   in reply to stellarceo

    Hi,

     

    The "Underline" appearance setting is just the bottom <ui> border. If you have changed the field type from another type, using "Type" in "Field Tab", the <ui> border color may have carried over and you may have a white on white situation. Go into the Custom dialog of the Appearance and check your bottom <ui> border color there. Use "Edit Individually".

     

    uiBorder.png

     

    If you can't figure it out, try deleting the field and replacing it with a new one from the Object Library.

     

    Good luck!

     

    Stephen

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 12:39 PM   in reply to kingphysh

    I have had the same problem sometimes too and have tried everything to get the underline to show in the text field. Changed the border, thickness, color of the line--nothing.

    I finally resorted to drawing lines in. On some files one will work while others won't and the only way I can get them to all work is to copy one of the working ones and replace all the ones that are not working--even thought all of the settings of the 2 fields are the same. Now I copied a text field from a form where it is working to a file where none of them are working and it still doesn't work. Starting to drive me nuts.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 12:51 PM   in reply to BonnieFitchburgState

    Oh, and I also tried grabing a new one from the palete, that was working, but not anymore.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 1:05 PM   in reply to BonnieFitchburgState

    OK--a few things. I have found that some lines require a min of .01in thickness to be rendered. The default .0069in doesn't cut it for check boxes, and I believe the underline style of a text field, also. It really doesn't perceivably change the appearance/thickness but it impacts whether it will be rendered.

     

    Also, try set to "None" the "Background Fill" in the Borders Tab--like in the image I posted a while ago (above). Sometimes the fill interferes with the border rendering. I'm dealing with a similar issue right now--frustrating, for sure.

     

    Good luck,

     

    Stephen

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 27, 2012 1:26 PM   in reply to kingphysh

    I tried making the line as large as 0.1 and it still doesn't show. The fill was set to none before so just to try out something I gave it a yellow fill and that didn't appear either. So then I tried turning off the 'highlight existing fields' feature in the preview and Ureca! I can now see my very ugly huge line with a yellow background--nice--not. But apparenly that is what was causing the lines to now show. It didn't used to do that, do I need an upgrade or something? Or did that happen when we went to Acrobat X? People like to see all the fields they need to fill in but they like the lines too.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 31, 2012 2:16 PM   in reply to BonnieFitchburgState

    Hi,

     

    One option would be to turn off the highlight with the following script in the docReady event of the root node:

     

    app.runtimeHighlight = false;
    

     

    This means that the form will be rendered/displayed as you intend, but still allow individual users to turn back on the highlight if they want it.

     

    Good luck,

     

    Niall

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points