Skip navigation
Currently Being Moderated

Error when launching Flex 4.5 mobile app.

May 15, 2011 5:02 PM

Any ideas why I'm getting this? Its an AIR app, not Firefox, so ???

 

TypeError: Error #1009: Cannot access a property or method of a null object reference.

at ominds::Firebug$/connect()

at flashfirebug/allCompleteHandler()

 
Replies
  • Currently Being Moderated
    May 18, 2011 11:53 AM   in reply to Gregory Lafrance

    Looks like you've pulled in Firebug as a dependency in your library path?

     

    Jason San Jose

    Software Engineer, Flex

     
    |
    Mark as:
  • mattdwm
    219 posts
    Sep 6, 2010
    Currently Being Moderated
    Jun 1, 2011 9:43 AM   in reply to Gregory Lafrance

    I'm getting this error too. It seems to be related to the desktop player. If I debug it with my phone there's no problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 6, 2011 10:43 PM   in reply to Gregory Lafrance

    Hi, there.

     

    I get same error too.

    Looks like installing "FlashFirebug" is the reason of this error.

    Here is the solutions:

     

    1) Quit "FireFox" when using FlashBuilder.

        If FireFox is available behind FlashBuilder working, it catches SWF publishing and try to connect it (that causes error).

     

    2) Edit "mm.cfg" file.

        Delete the line "PreloadSWF=...\flashfirebug@o-minds.com\chrome\content\flashfirebug\flashfirebug.swf" thing from mm.cfg.

     

    Either way works for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 6, 2011 11:12 PM   in reply to yuck

    I just realized that you can solve the problem with the solutions I posted before though,

    you are still messed up when using "Profiler".

     

    You just can't exec FireFox while you do "Profile" with FlashBuilder

    (editting mm.cfg won't work this time.  PrealodSWF is set to FlashFirebug thing).

     

    I don't recommned to install "FlashFirebug extension" for the time being.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 6, 2012 1:40 AM   in reply to yuck

    The option to disable firebug and quit firefox didn't work for me, but yes removing the line

    "PreloadSWF=...\flashfirebug@o-minds.com\chrome\content\flashfirebug\flashfirebug.swf"

    fromt mm.cfg (C:\Users\UserName\mm.cfg) worked for me.

     

    Thanks for the solution.

     

    Regards,

    Saurabh

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points