Skip navigation
shawn moore
Currently Being Moderated

An error occurred when attempting to change modules.

Jan 10, 2012 9:30 AM

I recive an error when changing to Book Mod.

"An error occurred when attempting to change modules."

 
Replies 1 2 3 4 Previous Next
  • Currently Being Moderated
    Jan 10, 2012 10:02 AM   in reply to shawn moore

    I've had this one several times as well. I've yet to see the book module. Maybe there's a corrupted pref that can be deleted?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 10:05 AM   in reply to artemesia66

    I had the same experience. It would then land me on the book module (with nothing on the page) and wouldn't let me go to any other module. I have to shutdown Lightroom then reboot to return to the other modules.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 11:21 AM   in reply to shawn moore

    Same problem here.  When I click on Book, I get the beach ball for a minute, then the error popup.

     

    Mac OSX 10.6.8

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 11:10 AM   in reply to shawn moore

    Having this same problem on ever single module. Restarting doesn't help and neither does reinstalling...

     
    |
    Mark as:
  • Victoria Bampton
    5,302 posts
    Apr 1, 2008
    Currently Being Moderated
    Jan 10, 2012 11:13 AM   in reply to shawn moore

    All on the same operating system?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 11:19 AM   in reply to Victoria Bampton

    Sorry, should have said. Mac OSX 10.7.2, Macbook Pro.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 1:15 PM   in reply to Victoria Bampton

    I'm on 10.7.2 with an iMac.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 1:38 PM   in reply to Victoria Bampton

    Mac 10.6.8

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 2:35 PM   in reply to christopherkmyers

    I've contacted all of you privately to help with troubleshooting and get some log files. 

     

    Becky

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 3:28 PM   in reply to shawn moore

    Having the same issue with the Books Module.

     

    I am very interested in a more flexible and robust alternative to iPhoto or Aperture Books - still hoping Lightroom is it.

     

    Mac Pro

    OS X 10.7.2

    2 X 3Ghz Quad Core Xeon

    32GB RAM

     

    AND

     

    27" iMac

    OS X 10.7.2

    3.4GHz i7

    16GB RAM

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 3:55 PM   in reply to OrionProject

    After uninstalling Lightroom 3.6 AND Lightroom 4 Beta, I reinstalled Lightroom 4 Beta and now have a new behavior - Lightroom crashes when launching the Book module.

     

    All other modules work well - but the Book module will crash everytime I try and launch it.

     

    Uninstalling Lightroom 4 and then reinstalling 3.6 followed by 4 beta takes me back to the state of getting the "An error occured when attempting to change modules" error message BUT Lightroom 4 does not crash - it's useless at this point but it doesn't crash :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2012 5:42 PM   in reply to +becs

    I am having the same issue.  Each time I attempt to change to the Book module, I get the spinning beach ball and then the error message "An Error Occurred When Attempting to Change Modules".  I am running:

     

    Mac OS X 10.7.2

    iMac 3.06 GHz Intel Core 2 Duo

    Memory 16 GB 1067 MHz  DDR3

    ATI Radeon HD 4670 256 MB

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 11:17 AM   in reply to shawn moore

    Has anyone on this thread recieved an answer yet?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 11:23 AM   in reply to OrionProject

    No, not me.

     
    |
    Mark as:
  • Victoria Bampton
    5,302 posts
    Apr 1, 2008
    Currently Being Moderated
    Jan 11, 2012 11:25 AM   in reply to christopherkmyers

    Christophe, error for all modules sounds like an installation problem.  Try the installer again.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 11:25 AM   in reply to OrionProject

    At this point we're doing personal emails with those working on it and they are troubleshooting based off our feedback.

     
    |
    Mark as:
  • Victoria Bampton
    5,302 posts
    Apr 1, 2008
    Currently Being Moderated
    Jan 11, 2012 11:27 AM   in reply to OrionProject

    Everyone else, let's try to figure out a pattern while Becky's busy trying to figure out the logs. 

     

    All Photographs, a folder or a collection?  How many photos in the current view before you switch to the Book module?  Any videos included?

     

    Where they processed in LR3 or are they fresh photos without existing settings?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 11:35 AM   in reply to Victoria Bampton

    Hi Victoria,

     

    I've tried several things; collection of 7 photos, several selected photos, or a single photo.  All new images, not processed in LR3, no videos.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 11:41 AM   in reply to Victoria Bampton

    First try: All photographs, no pre-existing settings. JPGs. Result: no dice.

    Second try: All photographs, new batch of .CR2 and .jpg that were lr3 processed. Result: same.

    Third try: collection of two photos from previous import (second try). Result: same.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 11:55 AM   in reply to shawn moore

    Some additional questions:

     

    1. In Preferences, under the "Presets" tab, is "Store Presets with Catalog" checked or unchecked?  Does switching that setting change anything?

    2. In the same location, if you click the "Show Lightroom Presets Folder" button, and look inside the Lightroom folder, is there a subfolder in there called "directory"? 

    3. In the Presets folder, do you have a subfolder called "Auto Layout Presets"?

     

    Thanks for the help in troubleshooting this issue. 

     

    Becky

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:03 PM   in reply to +becs

    1. In Preferences, under the "Presets" tab, is "Store Presets with Catalog" checked or unchecked?  Does switching that setting change anything?

         a. it was "unchecked"

         b. changing the state to "checked" did not change the behavior - it still produces the same error.

    2. In the same location, if you click the "Show Lightroom Presets Folder" button, and look inside the Lightroom folder, is there a subfolder in there called "directory"?

         a. no sub-folder called "directory."

    3. In the Presets folder, do you have a subfolder called "Auto Layout Presets"?

         a. no subfolder called "Auto Layout Presets."

     

    Of note: when I select Show Lightroom Presets I am presented with a Lightroom folder containibng  "Backups" and "Lightroom Settings" folders.  This looks like it is pointing at Lightroom 3 folders.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:04 PM   in reply to Victoria Bampton

    Once you get the error in Books - all other modules generate the same error.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:04 PM   in reply to +becs

    Hi Becky,

     

    Answers to additional questions:

     

    1.  "Store Presets with Catalog" was unchecked originally.  Checking it did not resolve the issue.

    2.  No, there is not a subfolder called 'directory' in the Lightroom folder.

    3.  Yes, "Auto Layout Presets" exists in the Presets folder.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:05 PM   in reply to +becs

    Answering additional q's:

     

    1. Unchecked. Changing it, shutting down, restarting and then trying the book module didn't change anythying.

    2. No.

    3. Yes, and there are three presets in that sub folder.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:17 PM   in reply to OrionProject

    OrionProject, if you don't have the Auto Layout Presets folder, that could be causing the problem for you.  Those presets should have installed when you installed Lightroom 4.  Perhaps try re-installing, just to see if they get created. 

     

    The presets folder is the same between LR versions, done that way so you can continue using your favorite presets as you migrate versions.

     

    Everyone else, thanks for the quick responses.  Go ahead and change your preference back to store presets in the usual location - I think you've proved that isn't the cause.

     

    The next step to try is to weed through existing presets to see if any of them are causing a problem.  Here's how I'd like you to do that.

     

    1. Exit Lightroom

    2. Uninstall Lightroom 4 Beta.

    3. Move your existing presets folder to a different location.

    4. Reinstall Lightroom 4 Beta.

    5. Start Lightroom, and see if you can switch into the Book module.

     

    If you can, that means that LR4 is choking on a preset you had existing prior to installing the Beta.  If this is the case, precede with the following steps.

     

    6. Quit Lightroom

    7. Go to the presets folder you moved in step 3.

    8. Pick one folder, drag the presets from that folder into the folder of the same name in the real presets location (which should have been created when you re-installed LR4 Beta).

    9. Start Lightroom and try to switch modules.

    10.  repeat steps 6-9 with each folder until you run into the module switching error again. 

     

    If you can narrow the problem to a specific preset or set of presets, I'd be interested to get those preset files for further investigation.

     

    Thanks,

    Becky

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:21 PM   in reply to +becs

    Hi Becky, in step 2, are you referring to only Develop presets or the other types as well?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:25 PM   in reply to Julie McLeod

    Hi Julie.

     

    Actually, move the whole Lightroom folder.  The things you need will get created again on install, and the rest you can add back after figuring out which set of presets is causing the problem.

     

    Thanks,

    Becky

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:27 PM   in reply to Julie McLeod

    Hi Becky,

     

    I followed the 1-6 (moving just the Develop presets to another location) and the inability to switch to the Book module persists.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:29 PM   in reply to Julie McLeod

    Our messages crossed paths.  I'll try again by loving the entire LR folder.  Thanks.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:35 PM   in reply to Julie McLeod

    Hi Becky,

     

    No luck.  Still can't access the Book feature even after moving the Lightroom folder and reinstalling.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:47 PM   in reply to Julie McLeod

    Uninstalled LR4, reinstalled and same thing is happening. The new install shows the Auto Layout Presets available, but no directory sub folder.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:57 PM   in reply to +becs

    Becky, I notice now that upon reinstall, the Auto Layout Presets folder is empty now.  It did contain 3 files before the uninstall/reinstall.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:58 PM   in reply to jbdiggable

    OK - thanks for trying, and thanks for sticking with me through this investigation process. 

     

    Regarding the 'directory' subfolder - this was a long shot.  We had a customer once who was getting module switching errors, and that was the cause. 

     

    Julie, can you tell me the names of the three files that were in Auto Layout Presets previously?

     
    |
    Mark as:
  • Victoria Bampton
    5,302 posts
    Apr 1, 2008
    Currently Being Moderated
    Jan 11, 2012 12:59 PM   in reply to Julie McLeod

    Julie McLeod wrote:

     

    Becky, I notice now that upon reinstall, the Auto Layout Presets folder is empty now.  It did contain 3 files before the uninstall/reinstall.

     

    Do presets appear if you go to Preferences> Presets tab > Restore Auto Layout Presets?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 1:10 PM   in reply to +becs

    Sorry, I don't recall the exact names of the three files that were in the Auto Layout Presets before.  (I'm sure it won't help much but I think one had "left" in the filename and one had "right" in the filename....)

     

    I'm happy to help.  Lightroom has been a great product for me since v.1 and it's nice to be able to help the people who are improving it for us.  :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 1:12 PM   in reply to Victoria Bampton

    Victoria,

     

    Are you asking if the three presets reappear in the Auto Layout Presets subfolder in the Lightroom folder?  No, they don't return after doing the restore you mentioned. 

     
    |
    Mark as:
  • Victoria Bampton
    5,302 posts
    Apr 1, 2008
    Currently Being Moderated
    Jan 11, 2012 2:11 PM   in reply to Julie McLeod

    I was wondering if it put anything in that folder, but it sounds like it didn't.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 2:19 PM   in reply to +becs

    Just to confirm, I did the delete, move lightroom folder, reinstall, with the same result--still no books.

     

    The file names in the Auto Layout presets that I have are:

    Left Blank, Right One Photo, Caption.lrtemplate,

    Left Blank, Right One Photo.lrtemplate

    One Photo Per Page.lrtemplate

     

    They appeared in both the old folder, and in the new one when I reinstalled.

     
    |
    Mark as:
1 2 3 4 Previous Next
Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points