Skip navigation
Steve.2c
Currently Being Moderated

Illustrator CS5 Error - "Not enough memory to save the file"

Oct 21, 2011 1:36 AM

Tags: #file #illustrator #cs5 #memory #save #not #to #the #enough

Hey guys,

 

I'm experiencing difficulties in exporting website from .AI to .PSD using Illustrator CS5.1 under Windows7 Home Premium 64bit. The error message says "Not enough memory to save the file".     


I can assure you that i've got enough memory for scratch disks and my computer is powerful enough to handle this operation. The funny thing is that i am able to export the very same .Ai file using Illustrator CS5.1 under Windows XP 32bit on different PC.

 

I've tried to find a solution online, but it gave no satisfying results so far. So, i think the problem comes from the operating system, but i don't know how to fix it... any suggestions?

 

Thanks, Steve.

 
Replies
  • Currently Being Moderated
    Oct 21, 2011 1:43 AM   in reply to Steve.2c
    I can assure you that i've got enough memory for scratch disks and my computer is powerful enough to handle this operation.

     

    Doesn't matter. AI is a 32bit app and will only use so much memory and resources... What size is the doc? Any other Adobe software on the system? Anything else we might need to know?

     

    Mylenium

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 17, 2011 11:03 AM   in reply to Steve.2c

    Sad to say I'm running into the same problem with a 40KB file.....

     

     

    (download the following file and use it)

    http://upload.wikimedia.org/wikipedia/commons/8/8c/2.4_GHz_Wi-Fi_chann els_%28802.11b%2Cg_WLAN%29.svg

     

     

    File -> Open

     

    Modify the file slightly:

    doubleclick the image

    remove the channel 14 info  (the text block "14" & "2.484",  the T shaped path, the dotted half circle path)

    drag a square around the "Channel", "Center Frequency", "(GHz)" text blocks and hold left shift and press the left arrow until the selected items are tighter to the rest of the image

    select the bold base line, grab the right middle point to shrink the line (dragging from right to the left) until 'intersect' shows up, then release

    click the top left "Back One Level" arrow 2 times so that you are back to the top level (out of isolation mode)

     

    File -> Export -> Choose PSD

     

    Export Options (all default settings)

    Color Model RGB

    Medium (150ppi)

    Write Layers

      Preserve Text Editability

      Maximum Editability

    Antialias

     

    Click OK.....

     

    POOF! ERROR!

    "Not enough memory to save the file"

     

    note: saving as .ai file before exporting doesn't solve the problem

     

     

    My Environment:

    Adobe Illustrator 15.0.2

    Win7x64 SP1

    6GB free RAM (8GB installed)

    55GB Free HDD space (256GB total, it's a SSD)

    4GB pagefile

     

     

    Please try the test method provided for yourself and advise, thank you

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 15, 2011 12:54 PM   in reply to drivetheory

    I'm having the same problem with a 120K file.  Same setup.  Same results.  This is my first attempt at this fucntion since upgrading to 5 and windows 7.  Worked fine using Windows XP and CS4.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 3, 2012 1:03 PM   in reply to Steve.2c

    I am having the exact same error no matter how big or small the ai file is...

    I am running Illustrator CS5.1

    My software was installed direct from discs

     

    Here are my system specs:

     

    Operating System: Windows 7 Ultimate 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)

    Processor: Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz (8 CPUs), ~2.0GHz

    Memory: 8192MB RAM

    Available OS Memory: 8086MB RAM

    Page File: 5461MB used, 10709MB available

    Graphics Card name: NVIDIA GeForce GT 555M

    Display Memory: 2725 MB

    Dedicated Memory: 3034 MB

    Shared Memory: 3787 MB

     

    Drive: C:

    Free Space: 316.5 GB

    Total Space: 456.8 GB

    File System: NTFS

     

    Drive: D:

    Free Space: 476.8 GB

    Total Space: 476.9 GB

    File System: NTFS

     

    Drive: F:

    Free Space: 869.8 GB

    Total Space: 953.9 GB

    File System: NTFS

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Jan 11, 2012 7:17 PM   in reply to Steve.2c

    THIS CASE HAS BEEN OPEN SINCE OCTOBER??? ADOBE SLACKING OFF? I'M HAVING SAME PROBLEM.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 7:05 AM   in reply to MIKELAWELL

    This is a user-to-user-forum, not a support ticket system. There are no "cases".

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 8:10 AM   in reply to Monika Gause

    You mean there isn't anyone from Adobe watching the forums to say, hey,

    here's a bug...maybe we should look into this?

     

    Sounds like a hole in your development processes to me.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 8:51 AM   in reply to MIKELAWELL

    MIKELAWELL wrote:

     

    Sounds like a hole in your development processes to me.

     

    well, certainly not in mine.

     

    We are all just users here, just as you are.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2012 3:54 PM   in reply to Steve.2c
     
    |
    Mark as:
  • Currently Being Moderated
    Jan 16, 2012 3:50 PM   in reply to Steve.2c

    One thing to check:

     

    Make sure 'Use Artboards' is checked in the original save dialog box. That's the checkbox at the bottom left of the export dialog below the exported file name.

     

    This problem plagued me for months until I realised Illustrator is trying to export the ENTIRE document edge-to-edge and not cropping it down to the artboard.

     

    Hope this helps someone.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 21, 2012 5:01 PM   in reply to Steve.2c

    Uncheck the Anti-Alias box and Voila! That worked for me.

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Jan 22, 2012 3:54 AM   in reply to Steve.2c

    **** Try to free enough Space on you HDD (Hard Disk Drive), upgrade your RAM, Always clean up your dive, choose the processor designed for graphic designing and set-up your PC into BEST PERFORMANCE  under the personlize settings... Hope this will help cause this issue helped me...

     

    OR - if you are making a large sized project lay-out it into 20% - 50% smaller and Proportioanally and after the project is done print it according to your deisired size of file....

     
    |
    Mark as:
  • Currently Being Moderated
    Calculating status...
    Feb 16, 2012 1:58 AM   in reply to Steve.2c

    I had the same problem and made an interesting discovery:

     

    If there is any object in the document that is wider or taller than 2048 pixels, Illustrator will give this error. Even if the object is smaller than that (for example 1600x1600 pixels) to start with, and your export resolution (i.e. 144dpi) will make that object bigger than 2048 (in that case 3200x3200 pixels), Illustrator will just say "NO WAY".

     

    I don't know why this is - just found out by trial and error.

     

    If you have problems, try deleting objects that are bigger than 2048 pixels wide or high and it will work.
    For the bigger objects, you might have to find a different solution to convert it to Photoshop.

     

    PLEASE NOTE: even if an object inside a Clipping Mask is bigger than 2048 pixels, it will not export to a PSD.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 20, 2012 6:55 AM   in reply to Steve.2c

    I have the same issue. The only way I was able to export from Illustrator CS5.5 to PSD was to uncheck Antialias.

     

    HD space for scratch disks is NOT an issue. My primary has 450GB free, and my secondary has 900GB free.

    I'm running an i7 (Sandybridge) processor, and running 16GB RAM.

    I am running Windows 7 64-bit.

    My file is onlty 1024x768 and no object is larger than that, so the dimensions are not the issue for me either.

     

    This did NOT happen in CS5, only after I moved to CS5.5 (which was actually a clean install after I uninstalled CS5).

     

    There is most certainly some sort of bug.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 9, 2012 5:05 PM   in reply to Steve.2c

    Hi, I have the same issue on a Mac. I can't export to

    layored psd from Illustrator CS5.5 running 10.7 I have tried deleting all preferences and I am still stuck. I did try unchecking the anti-alias also. Does anyone know of a work around? Thank you

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 9, 2012 8:28 PM   in reply to Steve.2c

    Just uncheck the AntiAlias box when you go to do the export and it will work.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 18, 2012 1:29 PM   in reply to Steve.2c

    If you're using a video illustrator preset, there are actually two artboards. One is the 1080p or whatever frame, and the other is the huge whatever frame around it. Be sure to select your 1080p or video artboard first before saving for web, and that could help. If that is actually the issue you're having.

    Godspeed.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 8, 2012 8:07 AM   in reply to joachimwiese

    I'm having the same problem! I'm using a circle with a gradient, but when I try to revolve it, it says "The operation cannot complete because there isn't enough memory (RAM) avilable." I know I have enough RAM and it's weird because I was able to manipulate objects and copy and paste things earlier, but I can't now.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 15, 2012 10:28 PM   in reply to Steve.2c

    I was having this issue with any file over 150dpi. I am using CS4.

    After unchecking the Anti-alias checkbox during the export options the file saved correctly at 300dpi.

     

    I was suspicious at the error saying I do not have enough RAM.

    I have 16GB. What do you mean I do not have enough RAM!?!?

     

    OS: Win 7 Home Prem 64

    CPU: i7 2600k (O.C. to 5.4 GHZ) liquid cooled via AquaComputer Airplex 360 with Lang D5 pump.

    MOBO: ASUS P8 Z77 V-Pro

    RAM: 16GB Corsair (O.C. 2100)

    HDD: Dual WD Caviar Black 1TB.

    GPU: ASUS Direct CUII 6970 2GB RAM (Liquid cooled via EKWB VGA block)

    Case: Cooler Mater HAF 932

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 16, 2012 8:53 AM   in reply to ANdreaF5000

    CS4 is a 32bit application and as such cannot access more than 3GB of memory. How much you have installed doesn't make much difference. If you want to use more memory, you will have to jump to CS6 which can be installed as a 64bit app.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points