Skip navigation
Currently Being Moderated

ClipboardFormatsPriorities maker.ini setting in Frame 10?

Jan 11, 2012 3:39 PM

I recently installed Frame 10 and I want to change the ClipboardFormatsPriorities setting so that "TEXT" is the first option in the list. I've done this in previous versions. Is this still possible in 10? If so, what did I do wrong?

 

Here's what I tried:

 

  1. Located the maker.ini file in the following directory: C:\Users\mboyd\AppData\Roaming\Adobe\FrameMaker\10.
  2. Made a backup of the original maker.ini file.
  3. Opened maker.ini in a text editor and saw that the setting was no longer included.
  4. Tried adding it. I added the following line first to the [Preferences] section and then to the [Frame] section:

    ClipboardFormatsPriorities=TEXT, UNICODE TEXT, MIF, RTF

 

Result: Nothing changed. MIF was still the default when I copied and pasted.

 

Granted -- changing the default from OLE to MIF was definitely an improvement, but I'd still like the default to be TEXT. Let me know what I'm doing wrong.

 

Thanks!

Melanie

 
Replies
  • Currently Being Moderated
    Jan 12, 2012 6:35 AM   in reply to M_Boyd

    Mine reads ClipboardFormatsPriorities=TEXT, FILE, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP, UNICODE TEXT

    but it's in the c:\program files\adobe\adobeframemaker10\ folder in the Re: ClipboardFormatsPriorities maker.ini setting in Frame 10? section

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 9:10 AM   in reply to M_Boyd

    Hmm, looks like some crap got copied into my last reply.

     

    Are you running Win7 or Vista? In those newer O/S's you have to give yourself (as admin) the rights to mess around with your own C:\ drive - it doesn't automatically follow when being an admin like it used to under WinXP. Mr. Bill's just trying to protect us from ourselves ;>)

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 9:54 AM   in reply to M_Boyd

    From what I remember, you have to use Explorer to get down to the C:\ drive root, then right-click and select Security (or something like that) and give yourself Full Control. It will take a while as it goes through and applies the change to all files & folders under C:\

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 11:15 AM   in reply to M_Boyd

    What are you uninstalling & reinstalling? There's no need to do that as far as I can see from your posts.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 11:36 AM   in reply to M_Boyd

    You shouldn't have to reinstall it - just restore the backup copy of the maker.ini you made before monkeying with its innards. You did make a copy, didn't you ;>)

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 11:39 AM   in reply to M_Boyd

    Both times I've made a change to maker.ini under the \Program Files, Frame won't start again until I uninstall and reinstall.

     

    When you did that, were you doing anything about the custom copy under /Users//AppData ?

     

    Frame is obviously checking both locations, and I'm wondering if having a newer mod timestamp on the "master" file vs. the "user" file is what's causing it to enter self-destruct-enable mode.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 12, 2012 1:48 PM   in reply to M_Boyd

    Were you able to give yourself "full rights" as a local admin?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2012 1:47 PM   in reply to M_Boyd

    A topic on an email from framers@lists.frameusers.com was to copy and paste straight from a Word document. Below was the correct answer and it works great.

     

    Although a co-worker of mine told me just to use paste special and select text...didn't know that.

     

     

    Edit the line:

    ClipboardFormatsPriorities=FILE, OLE 2, EMF, META, DIB, BMP, MIFW, MIF,

    RTF, UNICODE TEXT, TEXT

     

    Change the line to:

    ClipboardFormatsPriorities=UNICODE TEXT, FILE, OLE 2, EMF, META, DIB,

    BMP, MIFW, MIF, RTF,  TEXT

     

    ls

     

    Message was edited by: lsk2002

     
    |
    Mark as:
  • Currently Being Moderated
    May 1, 2012 3:33 PM   in reply to M_Boyd

    M Boyd I am having the same problems with FM10 now. The ini changes do not work and if I modify the Program Files instance FM blows up and I have to reinstall. Did anyone solve this mystery?

     
    |
    Mark as:
  • Currently Being Moderated
    May 1, 2012 3:51 PM   in reply to M_Boyd

    Thanks for letting me know. Very frustrating for a product to go backwards

    in usability.

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 7:32 AM   in reply to kmacdowe+brdcom

    Are you running Win7? Editing the maker.ini's shouldn't cause FM to fail to launch - are you getting an actual error message?

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 9:05 AM   in reply to M_Boyd

    @M_Boyd - Sorry, I was replying to @kmacdowe+brdcom to see if they were running the same o/s as you. My suspicion in your case is something to do with rights. If you're getting a hard error, I hope you've sent it into the FM tech guys and reported it to Adobe Support.

     

    I've just installed a copy of TCS3 on a Win7 laptop, so I'll have a chance to see if I can reproduce what you've reported, as I use the TEXT paste quite often while hauling material in from Word.

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 10:12 AM   in reply to M_Boyd

    It is my understanding that one should not edit the maker.ini file that is in the Programs directory. Each user has a personal copy located in:

     

    C:\Documents and Settings\user_name\Application Data\Adobe\FrameMaker\9(or 10)

     

    This maker.ini file is not a full copy of the one in Programs but it contains your personal changes. So try adding or editing the line in that file. When FrameMaker opens it first reads the file in the Programs folder and then the one in your Documents and Settings folder.

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 12:32 PM   in reply to M_Boyd

    Melanie,

     

    Did you have all 11 parameters in the modified entry separated by a comma and a space?

     

    Was the maker.ini file saved as an ascii text file (i.e. what editor did you use)?

     

    It really doesn't matter whether you edit the main maker.ini in the Program Files area or the user specific one, just keep in mind that the user-specific version is read last and the settings there will override the Program Files maker.ini settings.

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 2:16 PM   in reply to Reviewer1066

    It is my understanding that one should not edit the maker.ini file

    that is in the Programs directory.

     

     

    Unless you want the changes to apply to all users.

     
    |
    Mark as:
  • Currently Being Moderated
    May 2, 2012 10:02 PM   in reply to M_Boyd

    Melanie,

     

    I just re-read your original posting and when you say that editing the user-specific maker.ini has no effect, are you doing this for FM-to-FM or other-app-to-FM pastes? FM-to-FM pastes have always carrried along the formatting (even since FM3 ). You need to test this by copying formatted content from another app like Word or from a browser.

     

    If you want to paste unformatted FM text, then use the "ctrl+shift+v" (paste special) and then "t" (for text) and then "enter" as a shortcut.

     

    Not being able to edit the Program Files area maker.ini in place indicates a configuration issue on your machine that you need to resolve.

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 6, 2012 11:44 AM   in reply to Jeff_Coatsworth

    June, 6, 2012: - Jeff, sorry for the late response to what Op Sys and FM I am using. I was/am using Windows XP and FM10.

    Today I am able to edit the program-maker.ini file using Notepad (ASCI) without blowing up FM. I am not sure what changed.

    Now I cannot copy and paste tables within FM10. I willl start a new thread about that if I cannot solve it.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points