Skip navigation
sborstadt
Currently Being Moderated

Can I create one button with multiple actions?

Jan 26, 2012 7:47 AM

I need to create a button that will got to a specific state in one MSO and go to the preious state in another MSO in the same tap.  I have read that DPS supports multiple button actions and that "actions are played in sequence", but I'm not sure what that means and I haven't been able to get it to work so far.  Any tips or work-arounds?

 
Replies
  • Bob Bringhurst
    4,643 posts
    May 29, 2007
    Currently Being Moderated
    Jan 26, 2012 8:55 AM   in reply to sborstadt

    What you describe works fine, and it should happen virtually simultaneously, especially if you turn off cross fade. Create two different MSOs with different state names, and add the button actions. If it doesn't work, let us know what goes wrong.

     
    |
    Mark as:
  • Bob Bringhurst
    4,643 posts
    May 29, 2007
    Currently Being Moderated
    Jan 26, 2012 1:07 PM   in reply to sborstadt

    Do all three slideshows work apart from the button? Do any of the slides have an autoplaying object, or are they plain images?

     
    |
    Mark as:
  • Bob Bringhurst
    4,643 posts
    May 29, 2007
    Currently Being Moderated
    Jan 26, 2012 1:22 PM   in reply to sborstadt

    I just created a quick article that does exactly what you're suggesting. Did you install the v18 Folio Producer tools that came out earlier this week?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 26, 2012 7:28 PM   in reply to sborstadt

    I am having the same issue:

     

    I have two events controlling two MSOs in one button. When I do just one event, it works fine. Try the other event by itself, works perfectly. When I do both events on the same button, nothing. It works fine in the preview, but no luck on the iPad.

     

    Tried making two small buttons (1/8" x 1/8" each with 1 event each) and placed them next to each other with hopes that they would be triggered simultaneously underneath the same finger press, no luck.

     

    Tried switching the order of events, nothing.

     

    Haven't found a solution yet.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 27, 2012 5:37 AM   in reply to risd2227575

    There are known issues with the new tools that are affected MSOs. I can’t say for sure if yours is one of them but the fact that it works on the desktop but not the iPad would indicate that it is.

     

     

     

    The bug is in the iPad Content Viewer.

     

     

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2012 10:01 PM   in reply to Bob Levine

    Hi Bob(s), i'm still at the same point as in january : creating buttons that action many MSOs one after the other.

     

    It still works fine on the Desktop, and perfect on Android, but still not on the iPad.

     

    So i'm on february 21st (2.3.1) on the iPad, the project is compiled with 1.8 Folio Producer Tools.

     

    Is this supposed to be solved in the 2.4.0.7 that apple hasn't accepted yet ? (in which case i could upgrade FPT to 1.9 too…)

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 22, 2012 10:45 PM   in reply to Franck Payen

    Bob (B), in the comments of the HotSpotButton help page, you stated :

    Now that buttons can be nested within slideshows, you can create on/off buttons in the same place. The nested button on slide 1 jumps to slide 2; the nested button on slide 2 jumps to slide 1.

     

    I seem not to be able to do this on the Desktop Content Viewer.

     

    If i have "myMSO" with :

    State 1 being 1 button whose action is "go to State 2 in myMSO"

    and State 2 being 1 button whose action is "go to State 1 in myMSO"

     

    I tried creating buttons first, I also tried creating MSO, then inside creating the buttons, etc, but they don't seem to have any action now they're inside a MSO…

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 16, 2012 7:48 AM   in reply to sborstadt

    Hi!

     

    Now, in middle of april using drop 19 all way through the production chain, I seem to have a similar problem. But the erratic result seem to differ form above.

     

    I'm using one button to control two different MSO:s but only the one that is on top in button actions panel works. When I switch the MSO order in the button actions panel the other one works but not the first one.

     

    This error appears on the iPad but not on the content viewer on my desktop (which is sad since I could have prefered the opposite...)

     

    Anyone who knows about this issue and might have a solution?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 18, 2012 4:24 AM   in reply to Jannesaa

    Well it sure seems like the content viewer on iPad has some bugs. Anyhow I managed to find a roundabout way for my problem above. I changed the overlay settings for the MSO:s to fade and set them to highest possible speed (0.125 s). And then, suddenly, it works on the iPad too. Hope this could be helpful with other problems reported here. Good luck!

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2013 8:44 AM   in reply to Bob Levine

    Hi,

     

    More than one year later than the last post, I still have the same issue.

     

    I have 2 MSOs triggered by one button.

    If there is a cross-fade on the MSOs (I used the shortest possible = 0.125), the button is correctly changing the states on the 2 buttons.

    If there is no cross-fade on the MSOs, only the first action in the list for the button is triggered, the other one is not doing anything.

     

    Not working on the iPad content viewer, works on the desktop (Drop 26).

     

    Is this bug on the list for a future update (v27 hopefully)?

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points