Skip navigation
novad3
Currently Being Moderated

Who/Why did recent updates embed default double-side printing all PDFs

Jan 11, 2012 9:22 AM

Tags: #pdf #printer #to #updates #items #correct

Until the recent updates, I have had no difficulty saving and printing online/saved pdf documents. Today, my printer (set up for single page printing) was comandered by

Adobe PDF and went into double sided printing when when recent and past pdf documents were printed and checked.     

 

THIS IS AN "UNACCEPTABLE" UNANNOUNCED IMPROVEMENT (?).    I was not provided with any list of "options" to include/add/choose regarding default printer behaviour embedded in PDF saved/read/new documents. This used up printer time and  ink with loading, notices to reverse and/or note to add more paper. I now have to double check and clear the checked box for double sided, and clear PDF default.  When the same supposedly defaut free document is closed then reopened, the default free status has reverted to "double sided" 

 

It should be that this eco-friendly politically correct option should be a printing option that one should check to obtain when appropriate and wanted.  I should not be this stupid unannounced, poorly thought-out, aspberger-teckie enforced assumption of proper consumer conduct and needs.

 
Replies
  • Currently Being Moderated
    Jan 11, 2012 9:49 AM   in reply to novad3

    You probably would be better off posting this in the appropriate Acrobat forum, but there certainly has not been any feature added by Adobe to either Acrobat, Adobe Reader, or the PDF file format to save some type of printing defaults within a document.

     

    When invoked, the Acrobat / Reader print dialog will typically use the settings more recently used. Thus, if I print a.pdf with duplex, unless I change the setting, it will print the next print job, whether a.pdf or b.pdf with duplex. If after printing a.pdf with duplex, I print b.pdf as simplex and then attempt to print a.pdf again, the print dialog will indicate simplex, not the duplex setting I previously used for a.pdf.

     

    No eco-friendly, politically correct option is being forced on you or anyone else.

     

    You may want to check your printer driver settings. They may be the source of the symptoms you are observing.

     

              - Dov

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 12:34 PM   in reply to Dov Isaacs

    Sorry Dov, but novad3 is correct, at least in terms of the outcome if not the reason. It's a bug in the installer script for 10.1.2 (Acrobat and Reader) on Windows.

     

    The redesigned print dialog has a "Print on both sides of paper" checkbox. Despite the concept of duplex-simplex being present in the old dialog, this new checkbox involved adding a new persistent flag to the code, which is stored in the new registry key HKCU/Software/Adobe/[[product]]/10.0/AVGeneral/iDuplexMode (where [[product]] is either "Adobe Acrobat" or "Acrobat Reader"). It's a DWORD value, and was not present before now.

     

    For obscure reasons, many of the bit flags in Acrobat are inverted, so 1="off" and 0="on". If iDuplexMode is 0 or null (i.e. the key is missing) then the checkbox is ticked, and duplex mode is active (irrespective of whether the printer hardware actually supports it). If iDuplexMode=1, it's unchecked and you print simplex.

     

    Unfortunately, the patch catalog script doesn't create that key, so the first time you print from 10.1.2 you'll get duplex mode. By unticking the box and printing something, Acrobat or Reader will create the missing key, set it to 0x0, and you're sorted - as Dov says it'll then stay in simplex until you change your mind again. There's no need to manually create the missing registry value, but you can if you want to (e.g. as part of Da Customizer rollouts).

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 1:00 PM   in reply to Dave Merchant

    novad3's post claimed that the duplex mode was not only persistent, but reset to duplex on even after turning it off. As far as all our tests show, that is definitely not the case.

     

              - Dov

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 11, 2012 1:31 PM   in reply to Dov Isaacs

    It depends when you look. As with all the hive values, iDuplexMode is written when the application exits, and the flag in memory is updated only when a willPrint event fires - so for example if you open the print dialog, untick the box, then press Cancel, opening the dialog again will still show it as ticked. You actually have to print something to change the value. Of course that's how it's supposed to work, but it can easily seem that it's not remembering your choice.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2012 8:33 AM   in reply to Dave Merchant

    If I am deploying the updates, 10.1.2.msp, how can I use the customizer to change the Print on both sides default?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 13, 2012 8:35 AM   in reply to Dov Isaacs

    I have tested that this is the case.  If you uncheck, print, close.  Reopen the box is checked again.  However, if you go to print/properties/finisher and uncheck duplexing, it retains the settings. 

     

    Jamie

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 16, 2012 7:39 AM   in reply to jsaucier101

    Thanks for all the good feedback so far, but unfortunately even after testing several of the proposed fixes in this thread we're still having issues getting this setting to "stick".

     

    Specifically, we are using a Konica-Minolta C353 which is already set to print single-sided through the web config (it does not appear to have this option in the driver settings, so the printer's configuration page is the only place to set it).  Adobe Reader continues to periodically default back to checking the "print on both sides of the page" checkbox for multiple users, even after unchecking it in Reader and successfully printing.  While this is checked, it causes all manner of oddities with the printer, including flipped pages, blank sheets printing between pages, and sometimes the printer jamming as it tries to duplex but cannot.

    We can uncheck the box again and print, after which the setting sticks for a few hours - or at most a day - but then reverts again.  While the checkbox is inactive, all .pdfs print normally.

     

    Does anyone have input on getting this setting to stay unchecked in a scenario like that?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 16, 2012 8:02 AM   in reply to Karpel_HD

    It's being investigated. For local printing in typical setups, the "print both sides" checkbox does seem to be working properly, and remembers your choice until you change it again. However I'm seeing a number of reports that in enterprise scenarios (networked printers, multi-user profiles, etc.) it's going wrong in unpredictable ways. So far, I can't offer you any magic solution.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 16, 2012 8:07 AM   in reply to Dave Merchant

    Thanks for the update, Dave.  I'm just glad to hear it's being looked into and that we aren't an outlier with this problem.

     

    For now, the users have been educated to verify that checkbox if they start having trouble printing .pdfs, and to uncheck it again if it has reverted.  That's not a long-term solution, but it will keep us running relatively smoothly until a proper fix is established.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 16, 2012 8:48 AM   in reply to Dave Merchant

    I have the same problem but when I change my setting to single sided printing it goes back to double-sided as soon as I reboot my computer.

     

    It doesn't seem to retain the single sided printing.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 18, 2012 9:12 AM   in reply to Dave Merchant

    NOT Nice!

    We ran across this issue after our domain-wide rollout of 10.1.2 - adding the iDuplexMode registry entry via Group Policy has fixed this for everyone for now...

     

    Thanks Adobe :-)

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 26, 2012 7:33 PM   in reply to (--0|0--)

    Found this in another discussion this forum: seems to work for me ---- so far !!!

    #

         LoriAUC Community Professional  

     

     

    This blog entry also offers some workarounds (if you're comfortable with registry edits):

    http://blogs.adobe.com/dmcmahon/2012/01/17/acrobatreader-10-1-2-printe r-blinkingpaper-tray-messages-caused-by-duplex-print-option/

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2012 1:34 PM   in reply to novad3

    I have a single user setup - one computer: one printer.  Every pdf I open is set to print duplex.  Additionally, if I uncheck the "print on both sides of the paper box" and return to the Print Properties dialog box, its right back to duplex printing.  Please help.

     

    Update - if I try to print the document, I get the following message, "The document has been configured to print using the Automatic Two-Sided Printing Modeul but the module is not installed in the device.  The document will be printed one-sided."  What module?  My printer defaults to single sided.  Is this an Acrobat module

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2012 5:36 AM   in reply to novad3

    Novad3,

     

     

     

    Thank you for this fix.  It seems to have worked.  It seems that more than one user has had this problem.  It would be nice if Adobe investigated it more thoroughly and fixed it.  I guess that is too much to ask.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points