Skip navigation
Currently Being Moderated

Captivate 5.5 Playback controls disappear after playing embedded animation (swf)

Jan 27, 2012 12:22 PM

Tags: #playback #captivate #skin #disappear

I've just discovered a new problem with Captivate 5.5.

 

I have a project created from importing PPT slides. Near the end, I added a slide with a short swf animation object, then the slides continue after.

 

What happens is that during playback, after the swf plays, the playback controls vanish from the main project. (The embedded swf has no skin). The bottom border is still visible, but the play/pause buttons are just gone.

 

Anyone ever seen this?

 

Oh, and I tried splitting the presentation after the swf and daisy-chaining the two parts together, but that doesn't work either. It won't play the "new project".

 

Thanks for any help!

 
Replies
  • Currently Being Moderated
    Jan 27, 2012 9:09 PM   in reply to SMattox

    What can you tell us about this embedded SWF?  How was it created?

    Is it perhaps a Captivate simulation that you have nested inside the main Captivate project?

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 30, 2012 6:26 AM   in reply to SMattox

    OK, the news I have to give you is not good.

    The reason your playbar is probably disappearing just when you play this embedded SWF is that the embedded SWF doesn't have a playbar of its own, and since it's also a Captivate project file, the settings in the embedded SWF are affecting the settings in the parent SWF at runtime.

     

    It's been mentioned many times on this forum that it's a bad idea to nest Captivate SWFs inside other Captivate SWFs.  It causes lots of issues.

     

    Your better solution is to add the slides from the nested project into the main project and edit them from there.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 30, 2012 6:42 AM   in reply to SMattox

    I hope you don't mind me adding my 2 cents here....

     

    I had a client who had this same issue.  The work around for him was to add a playbar to the embedded/nested swf... BUT you can hide it by setting the playbar's alpha to zero, set it for "overlay", removing all the buttons, and also removing the border at the bottom.

    playbarSettings.jpg BorderSettings.jpg

     

    Give that a try and see how it goes.

     

    Jim Leichliter

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 14, 2012 5:50 PM   in reply to SMattox

    Another 0.2 cent's worth ...

     

    I spent a good few hours on this problem yesterday and manage to crack it, in a manner of speaking, before spotting this Forum entry.

     

    Just to add a quick comment to Jim and Rod's excellent advice: I found that the embedded SWF would still play, without causing the main project's playbar to disappear, if you follow Jim's advice, above, for each embedded SWF's Skin Editor settings, with the following minor tweak, which may be appropriate for some situations ...

     

    a) Clear the Playbar Overlay check box

    b) The Playback Colors check box becomes available, so select it

    c) For Background, select the same colour as your slide background (white, in my project's case)

    playback.jpg

    This is just another option to try, if you experience the "disappearing playbar" problem.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2012 10:54 PM   in reply to Johan van Eeden

    ... and yet another .2 cents worth.

     

    Have we been making this needlessly complicated? I suspect so. I've just stumbled across the solution proposed here:

    http://www.dorna.nl/?cat=56

     

    All that's needed is to "add an action Assign that sets cpCmndShowPlaybar to 0 to the first slide in the small [i.e. the embedded] project".

     

    I haven't tested it, but I can't think of a reason why it shouldn't work!

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2012 11:56 PM   in reply to Johan van Eeden

    I just tested this and it seems to work fine.

     

    I'm still not a fan of embedding Captivate SWFs inside other Captivate SWFs but it's nice you know that there is a workaround for at least one of the issues this causes.

     
    |
    Mark as:
  • Currently Being Moderated
    May 27, 2012 3:47 PM   in reply to Jim Leichliter

    Jim - thank you - I had this problem in a software demo for a client and your fix worked - now I can go to sleep without dreading tomorrow in the office - Laura xxxxx

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 8, 2013 6:06 AM   in reply to Laura LS Marketing

    But what about the 'test42.png' issue?

     

    I'm now getting this, very weird.

     

    I have 6 of them over 6 different products. But mine have the letters E C D C D C across the 6 files. Just one letter per file.

     

    I'm bemused.

     

    I cannot find any reason as to why this is being created!

     
    |
    Mark as:
  • Currently Being Moderated
    May 10, 2013 12:15 PM   in reply to Colday213

    I GET THE STUPID IMAGE ALL THE TIME

     

    test42.png -> just a frking letter E

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points