Skip navigation
tumdax
Currently Being Moderated

Problem with origin module installation

Feb 3, 2012 2:04 AM

Tags: #apache #origin

Hey,

 

I'm trying to install the origin module on my apache2.2 server. I'm working with a win7 x64 machine.

 

I followed the instructions and copied mod_f4fhttp.so, hds.dll and libexpat.dll into my modules folder.

I then added the line LoadModule f4fhttp_module modules/mod_f4fhttp.so into my httpd.conf.

When I try to start the apache server, I get a "cannot load mod_f4fhttp.so into server" error.

 

I first thought apache couldn't find the files, so I tried different names and folders, but obviously it's not the problem.

I then thought it could be the access rights, so I changed these as well, but it doesn't help.

 

My current supposition is that it comes from the 32bits dll files. Because my OS is 64bit, apache is the x86 version.. and the origin module is only available in 32bit version for windows..

 

Does anyone have a clue ? Thanks for your help.

 
Replies
  • Currently Being Moderated
    Feb 3, 2012 10:53 PM   in reply to tumdax

    Hi,

     

    Thanks for trying out the origin module.

    Apache does not build a 64 bit version for Windows. It is available separetely for Linux but not for windows.
    We use only 32 bit for all the windows platforms. So, the origin module is also build for 32 bit. THis should be a problem in deploying on 64 bit OS. We have tried it for windows 7 64 bit as well.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points