Skip navigation
Currently Being Moderated

Where is Flash builder 4.6 for php ?

Nov 30, 2011 1:18 AM

Tags: #flash_builder #4.6 #for_php

Hello,

 

I found flash builder 4.5 for php and flash builder 4.6, where is flash builder 4.6 for php ?

 
Replies
  • Currently Being Moderated
    Nov 30, 2011 2:35 AM   in reply to devomatic

    Wondering the same too.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 30, 2011 8:52 AM   in reply to devomatic

    Alison Huselid, Adobe Flex and Flash Builder Product Marketing Manager, posted this in another forum...

     

    Like Flash Builder 4.5 for PHP, our releases will be staggered and our plan is to release Flash Builder 4.6 for PHP in Q1’12.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 3, 2011 10:17 PM   in reply to Godly_Dev

    Yeah, I was asking around at Adobe and got several different answers... no real date, however one of the guys told me straigh out it will be in May 2012... Errr!!!!

     

    So I just took the free 4.6 Premium upgrade and will stick to 4.5 w/PHP on my alt workstation.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2011 10:24 AM   in reply to devomatic

    Devomatic-

    I got the same info from Adobe help on chat.

    My 4.5 w/Zend has never worked at all... Nothing, wont even install

    correctly and so I was hoping to see it working the 4.6 that rolled out

    last week.  The Adobe rep said May for the 4.6 w/PHP.

     

    Adobe's misinformation is plowing full steam ahead! 

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2011 10:32 AM   in reply to KesherMedia.Com

    Yeah, I would not have bought the PHP version had I known that "staggererd out" meant a 6 month delay.  Hopefully that will not be the case.  I have only read first quarter, which if early January, would mean a 4-6 week delay. 

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 5, 2011 3:28 PM   in reply to Jamie McDaniel

    If i pulled the $hit off at work i would be fired on the spot!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 28, 2012 10:08 PM   in reply to Jamie McDaniel

    I was told in the beta it would be January not Q1...this is Very Frustrating.

     

    Not as much as the long-term vision though.

     

    Adobe has 2 classes of software users, some are both, Digital Publishers and Developers.

     

    I think they are digressing to their roots as Digital Publishers and leaving Developers holding the bag.

     

    Danny Winokur really did some damage.

     

    Edge is great, but that's just more money...now will FB 4.6 for PHP include the latest version of Zend Studio since that is what we purchased it for?  There's already a Zend PHP plug-in for Eclipse.

     

    I think the FB 4.6 for PHP team needs to get really into the Eclipse WTP and hand select the best Plugins that are for the Adobe kind of developer. Bundle the AWS Plugin or put it in the Readme.txt Notes.

     

    The 4.6 for PHP version I think has the capability to really separate the Digital Publisher from the Developer commitment by Adobe.

     

    There's too little Flash Builder or FLEX jobs out there and too many Java EE with Spring 3 MVC and HTML5...can Adobe eventually make an Edge div type Plugin and a PhoneGap Packager Plugin.

     

    Adobe + Eclipse has the ability to put Adobe's brand name on an IDE that serves so many purposes from Agile SCRUM Plugins to familiar things such as JSP calling Swing or Spring 3 with MVC...try to get Tomcat or JBoss involved.

     

    There's so much potential, but if Adobe doesn't really carry the Developer community, all that FutureWave and Macromedia stood for is for not, and all that Adobe has added is for not because most Jobs now require many different skills, including things like AIR 3.1

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 31, 2012 12:53 PM   in reply to plasmaphonic

    Fully agree!!!

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2012 3:02 AM   in reply to devomatic

    I was wondering is flash builder 4.6 for php same as flash builder 4.6 premium ?

    Or do we need to be patient and wait some more ?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 6, 2012 5:09 AM   in reply to Lemtz

    FB 4.6 for PHP is Premium.

     

    Sent from my iPad

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 12, 2012 1:25 AM   in reply to devomatic

    Any News on this? Just bought an Upgrade for 4.5 for PHP Premium and wondered why it is only 4.5. May is over since two weeks. So its about time Adobe, right?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 1, 2012 1:39 PM   in reply to robert.brendler

    I have a copy of the 4.6  for php which I downloaded from the adobe downloads page a few weeks a go but now the dwonload link has disappeared! What's going on ?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2012 1:23 AM   in reply to suffrin_mick

    I bought fb 4.5 php two weeks ago and wondered where the 4.6 is. I called the sales hotline in Germany, they said its not likely that there will be an update for 4.6.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 4, 2012 3:41 AM   in reply to robert.brendler

    I'm not sure what's going on. I have both windows and mac versions of 4.6 for php.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 4, 2012 11:09 PM   in reply to suffrin_mick

    I gave neither and paid for it and qualifies for 4.6, now Adobe hint

    respond to me.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 17, 2012 6:00 AM   in reply to devomatic

    The obvious answer is Adobe failed to meet their first quarter deadline this year.  Why that is, is anyone's guess if they even plan on still making good on this for that matter.

     

    Workarounds?  Of course:

     

    • If you own Flash Builder for PHP, the simplest answer is to download the Flex 4.6 framework and set that to your default as opposed to 4.5.  But what about the auto generated code that is only available in design view?  If you're using auto generated code or are that concerned about design view, perhaps you should stick to designing until you're more proficient at programming and let the programmers handle the programming.
    • Of course the other alternative and "better" alternative for some people would simply be to install Zend Studio, and then install Flash Builder as an eclipse plugin that you can load into Zend Studio (something I myself did before Flash Builder for PHP was even on the market).
     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 7:22 AM   in reply to kremisoski

    @Kremisoki

    You totally missed the point...

    We paid for the full product and the upgradewas to be included on the next

    release, which was NOT delivered as promised, end of subject!!!

     

    For us, this has nothing to do with programming and is more of the ongoing

    BS from Adobe.

     

    KM

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2012 4:56 PM   in reply to KesherMedia.Com

    I missed nothing.  I clearly expressed that I understood your point in the first two sentences I posted.  I then provided workarounds for you to be helpful.  You then decided to be obnoxious and rude as if Adobe's failure is somehow my fault when I was only trying to be helpful.  End of subject.

     
    |
    Mark as:
  • Currently Being Moderated
    Oct 19, 2012 7:24 AM   in reply to kremisoski

    One more dissapointed user here! My company also bought FB for PHP 4.5 last year, and we never got an update.

     

    According to this guy the FB for PHP version 4.6 once existed online: http://jaspreetchahal.org/flashbuilder-4-6-for-php-released/

     

    But it doesn't anymore. I tried to use "ordinary" Flash Builder 4.6 (and forget Zend Studio), but guess what: because I had setup my project to have client (Flex) and server-side (PHP) on different machines, it doesn't allow to autogenerate proxy classes fro AMF-ing with PHP if those classes are on another server. So, I uninstalled the 4.6 and installed 4.5 for PHP again. Seems we are doomed to use the old version of FB and never get an update.

     

    Very illogical and non-transparent moves from ADBE. I think the logic was something like: we haven't sold so much copies of FB for PHP, so we will buy some time and constantly move the release date for FBPHP 4.6 - eventually users will be out of their subscriptions, we will never ship it, and nobody will ever ask.

     

    Perhaps their Zend business is also over, but they don't tell it publically?

     

    Seems ADBE is getting rid of all the programming/IDE businesses. IMHO: if there could get a time machine - whey would use it to change the past and never acquire Macromedia.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2012 12:38 PM   in reply to dankokozar

    Adobe ist the only company I konw which reverses its own innovations for years.

    Never trust Adobe. This could break your business.

    History:

    - reduction of external interface made thousends of web-apps useless (file uploades etc.)

    - no update for FB for PHP in spite of announcements.

    - canceling of design view in FB makes FB nearly useless, unless you like to do skinning etc. on the good old way like in the early Flash 8 - times with AS3.

    - AE is now more a 3party product then from Adobe because they missed a bunch of innovations over years.

    - documentations for products are going more and more useless.

    - Adobe forces its cloudsourcing by hiding inforamtions from non-members. Therefor the Edge-Projects will fail.

    ...and so on...

    There must be something wrong with the complete management...

    ...time to choose another software vendor!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2012 8:43 PM   in reply to steviex1

    I forgot:

     

    - canceling of data centric featrues, leaving ten thousends of RIA-developers alone with there outdated tools and products.. Adobe never realised the big chance having a living mobile-server bridge based on FB reaching a ton of web software and web data.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2012 10:42 PM   in reply to steviex1

    Is it really that difficult to add Flash Builder 4.6 as a plugin to Zend Studio?  I did that for a long time prior to Flash Builder 4.5 for PHP, which is essentially the same thing.  It really doesn't take a rocket scientist.  =/

     

    On that note, if you own Flash Builder 4.6 and don't feel like shelling out the extra money for Zend Studio or waiting for Flash Builder 4.6 for PHP, then it's really as simple as adding Flash Builder as a plugin to Ecliplse for PHP using PDT.  Also, doesn't take a rocket scientist.  Personally, I don't see the big deal myself.  I don't even bother with using Zend Studio anymore and prefer to use Komodo Edit since it's autocomplete features are awesome and it's very quick at auto complete by simply adding a folder for your favorite PHP apps from different frameworks to different content management systems.  Furthermore, there is still support in Flash Builder 4.6 to connect to a PHP data service if you really just want to create some automated code.  Ultimately though, I don't understand why anyone would use amf.ini or the default options in production.

     

    Rather than pointing to the default endpoint, if you're using a framework in the first place, it makes a lot more sense to setup a service controller and have the endpoint point to that such as index.php/services/amf (or if you're like me and prefer cleaner url's modify .htaccess to remove index.php).  The bottom line is there really was nothing great about Flash Builder 4.5 for PHP.  Alot of things were broken for one and it was far easier to use the datawizard which still exists for testing purposes.

     

    After that, you should be focusing on deploying the applicaiton for production, and adjusting the settings in the Zend Framework to create a new project the correct way, dumping your HTML file to a view along with the swf file, and it may be a good idea to point the HTML file to swfobject on the Google Ajax Libraries page.  Everything else is a cakewalk.

     

    In other news, if you'd like a ligher footprint than using the entire Zend Framework, why not use something like CodeIgniter and create the necesssary hooks to use Zend AMF?

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 8, 2012 10:45 PM   in reply to steviex1

    Cancelling data centric features?  What the heck are you talking about?  All of the data centric features are still available and it seems to me that a lot of the compaints on here are from people who want to use development settings in production.  I'm wondering if half the people on here are actually AS3 and PHP programmers or just want Flash Builder to do everything for them.....

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 9, 2012 3:30 AM   in reply to kremisoski

    Adobe has anounced to no longer support data centric features in FB in the future. They also recomend using AS3 instead of Flex while building mobile apps. They are moving back to the history. READ THE INTERNET DUDE!

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 9, 2012 3:33 AM   in reply to steviex1

    And yes I'm coding PHP and AS since more then 10 years.

     
    |
    Mark as:
  • Currently Being Moderated
    Dec 9, 2012 3:46 AM   in reply to steviex1

    Has someone tried to use ANE in FB for PHP...good luck. Unfortunately we can't upgrade ;-).

    ...so we have to comment out ANE references- if we want to develope further more in FB before compiling stuff...Great solution!

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 16, 2013 11:47 PM   in reply to Jamie McDaniel

    Version 4.6 for PHP is really good.......Thanks for sharing ......

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points