Skip navigation
docksidemarley
Currently Being Moderated

Widget Help

Jan 31, 2012 4:47 PM

I'm very new to using Dreamweaver and very much a beginner.  The problem I am having is that I can't seem to get the jquery cycle on one part of my page and the jsocial in the footer.   Either the jsocial won't show up at all or if the jsocial shows up, the jcycle is disabled. 

Any ideas what I am doing wrong?

Thanks

 
Replies
  • Currently Being Moderated
    Feb 7, 2012 4:27 AM   in reply to docksidemarley

    There are two possible causes

     

    1.- Cycle uses jQuery 1.6 and jSocial uses jQuery 1.4.2: Maybe Cycle won't work with 1.4 and jSocial won't work with 1.6: You can try removing the link to one of the jQuery core files to see what happens

     

    2.- jSocial doesn't use $(document).ready trigger: Not sure about this, but this also could be a cause. You can try wrapping the function call in your document

     

    Before:

            $('.social').jsocial({

                twitter        :  'myID',

                ... more options here...

                newPage        : false

            });

     

    After:

    $(document).ready(function() {

            $('.social').jsocial({

                twitter        :  'myID',

                ... more options here...

                newPage        : false

            });

    });

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points