Skip navigation
XEyedBear
Currently Being Moderated

How to import into required folder (LR3.6)?

Feb 8, 2012 12:09 PM

Tags: #import #folders #destination

The import action in LR 3.6 utterly confuses and frustrates me. I have spent the best part of 8 hours trying to import a single image into the logically correct, sensible and desirable place in my folders list. LR is bizarre to the point of being perverse in where it chooses to place the imported photo. Can somebody expain to me how to make it work correctly?

 

Within the 'My Pictures' folder on a hard disk I have a 'My LightRoom Photos' folder. It has a number of sub-folders, the most important of which is where I want to copy/add a particular image. The name of the sub-folder is irrelvant. I'll call it 'Digital'. The physical organisation on the harddisk within Digital is firstly by year number folder: 'yyyy'. Within each year folder there are subfolders for the month/day of the shot, with folder names of the form 'yyyymmdd'. This structure appears replicated in the folders pane on the left hand side of the LR Library module - just as I want. This is all standard stuff, right?

 

To make things easier to understand I have now moved the image I want to import to a different hard disk, into the 'Public Pictures folder'. It's there in Windows Explorer.

 

Now I Import this image by a number of different methods: I expect it to go into the folder <Digital><2010><20100615> (that's the date it was shot) to join other photos shot on that date. No matter what options I choose, the image is added to a newly created folder, named '20100615', within 'My Pictures' at the same level as the  'My LightRoom Photos' folder,' in the Folders panel in LR. But this folder does NOT exist on the hard disk and the imported image is, in fact, inside the physical folder I expect. It just doesn't show to be there in LR. This is highly confusing and totally counter-intuitive.

 

The options I have tried are:

- 'Copy' or 'Add'

- right click the 'Digital' folder in the Folders pane and select 'Import into this folder'

- ditto with the '<Digital><2010>' and '<Digital><2010><20100615>' folders

- selected the relevant folder in the Desination Folders pane on the right hand side of the Library module

- selected or deselected 'Into subfolder'

- selected or deselected 'Organise into 1 folder'

- selected or deselected 'Organise by date'

 

 

So why does LR choose this bizarre place to catalog the photo? Why dies it pretend there is a new folder on my hard disk and re-create it in the catalog, which I absolutely do not want and which does not actually exist?

 

The above is the simplified problem. The real problem - which I have abandoned working on, is where the new image already exists within the folder (on my hard disk), but does to appear in the LR catalog, in the folder into which I am trying to import it (Add) (in my catalog). This is the default position for any new image I wish to Add to the catalog when I edit a .NEF raw image and want to save (i.e export it) as a jpeg. That is, LR gets things quite wrong when I do what is intuitively obvious to me. This makes it very difficult to trust and use the product.

 
Replies
  • Currently Being Moderated
    Feb 8, 2012 12:27 PM   in reply to XEyedBear

    Here is a video that I think will help you understand importing how little better .  It takes about 15 minutes, but I think it will answer many of your questions . 

    http://tv.adobe.com/watch/adobe-evangelists-julieanne-kost/lr3-two-way s-to-import-/

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 8, 2012 3:39 PM   in reply to XEyedBear

    Get ready to throw your computer, because you probably already know this.  But to reiterate, if the file is already on your computer you don't want to copy it, you simply want to add it to your Lightroom catalog.  There is no destination folder required because it's already in the folder that you want.  If you copy the file then you have to designate a folder (option 1 in the video) and that means that you now have two copies of the file on your computer.  And if that is what you did then you need to know exactly where you copied that file.

     

    After you copy the image the import dialogue will close and the newly imported image should have focus.  If you don't see that folder in your folder tree in the library module right click on the image and find the option to display the folder.  I don't remember the exact words.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 9, 2012 7:39 AM   in reply to XEyedBear

    There is something you are missing, but I don't know what it is.  You might try closing Lightroom and moving the file to the desired folder.  Also, are you trying to import individual images?  If so, why?  I obviously have no more suggestions that might help you.  I'm convinced that you're not doing something correctly.  But I don't know what it is.  The import process works for me just as it's explained in the video.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 9, 2012 9:18 AM   in reply to JimHess

    I don't know if this is going to help.  But this is my last attempt.

     

    First of all, if you are going to COPY the images and you want to put them in one folder, you need to choose that option in the right hand panel of the export dialog.  Then I usually put them in a named sub folder which is the first option under the destination panel.  After you have named that sub folder you need to scroll down and locate and select the drive and the main folder on that drive under which you want the sub folder created.  If you have done this correctly you should see the sub folder you have named, but it will be shaded (a shade of gray rather than white).

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 11, 2012 8:30 AM   in reply to XEyedBear

    That is how Lightroom downloads for you. I still can't understand what you are doing wrong, because when I download it works just the way it should.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 24, 2012 1:47 PM   in reply to XEyedBear

    Hello,

     

    I have a very similar issue.

     

    I intend to import files into two new subfolders under

    • d:\backup\pictures\original
    • d:\backup\pictures\modified

    Both subfolders would have a name of oday's date: 20120224

     

    The two screenshots below show the settings I used to achieve this and the results.

    Issues:

    1. There is no room to specify two new folder names. Only one.
    2. You would assume that is used at both locations, but that's not the case.
    3. Only the first location is imported into LR 3.6.

     

    Any help would be highly appreciated!!!

    Thanks,

    Gabor

     

    settings.png

     

    result.png

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 27, 2012 9:23 AM   in reply to grevesz

    Nobody knows????

    Thanks,

    Gabor

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2012 8:47 AM   in reply to grevesz

    Is there no way to do this? (Still unanswered... Same behavior in Lightroom 4.0)

     

    Thanks,

     

    Gabor

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2012 10:02 AM   in reply to grevesz

    No, there's no way you can import image files to two separate folders and have them both appear in the Catalog.Why would you want to?

     

    The 'Make Second Copy' option is designed as a byte-for-byte copy of the contents on the import card, it's principal purpose being to take a quick backup of the card so that the card can be re-used before the usual post-processing backup takes place. It has never been designed to duplicate the folder structure of the prime imports, though some people have requested this.

     
    |
    Mark as:
  • Currently Being Moderated
    May 12, 2012 8:09 PM   in reply to Jim Wilde

    Thanks.

     

    Gabor

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 1:39 PM   in reply to XEyedBear

    I have had the exact same problem and it has been driving my nuts. I found a possible solution which I intend to try when I return from vacation. I found it on photography-on-the-net/forum/

    It involves taking that stray folder and adding a parent folder to it and then possibly adding  another parent folder to that parent folder. Then try dragging the topmost parent folder where you want it to be. It knows that name of the parent folder already which surprised me somewhat.

     

    I was playing with that a little before I read the post and I think it may work for me but I leave tomorrow on vacation so won't have time to try it out. If you want more information I can try to dig up the exact page I was looking at in the forum. You may try a google also  otherwise I will try to accomodate you in 10 days. Good Luck. Pete

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 2, 2012 8:58 PM   in reply to XEyedBear

    Hi, I tried a few things and I found a solution to my problem which you may want to try also for LR 3.6 .

     

    In looking/comparing my LR Catalog Hierarchy and my Q: harddrive Hierarchy I noticed a discrepancy which was causing me some grief. I noticed my LR Cat was showing (lowercase) /Pictures. During import LR would put the pictures into a new folder called (uppercase) /PICTURES/2012/2012-05-01. I didn't see or know what the parent folders were since they were not showing in the LR Catalog. To find the parent I selected the LR Catalog folder (of the one that was driving me nuts)  and selected ADD PARENT. Afterwards my /2012-05-01 folder  showed up as /2012/2012-05-01. Then once again I selected 2012 and selected ADD PARENT. Afterwards (uppercase) /PICTURES/2012/2012-05-01  showed up. Still not wanting my pictures at that location I tried to move the 2012-05-01 folder into my main LR Cat folder but got the message the folder already exists even though it was not showing.I was very frustrated but pressed on. I finally went to my main LR Cat folder /Pictures where my 8000+ photos reside and selected the (lowercase) /Pictures folder (now knowing that it didn't exactly match my (uppercase) PICTURES folder on my Q: harddrive). I updated the folder location and then I was able to move that folders w/photos into my main LR Cat. The folder that were there but not visible before were now showing. Eureka! That was it. I simply removed the unwanted (uppercase) /PICTURES/2012/2012-05-01 folders but not the pictures from the LR Cat.    Now when I import the folders w/pictures go right where I want them. I experimented by importing one photo at a time until I got it all figured out.

     

    Bottom Line: Triple check your harddrive folders against your LR Cat folders for upper/lowercase differences or any other differences for that matter. I supposed if you wanted to you could just simply select your main LR Cat PICTURES folder and simply update it's location.

     

    Worked great for me and now I am ready to really enjoy my vacation not having to worry about coming back to this black cloud. Any questions feel free to contact me. Pete

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 3, 2012 9:35 AM   in reply to XEyedBear

    I have thought of dumping LR at times but have a friend who uses it and works fine for him after a steep learning curve. I am still only halfway up the curve and agree it could definitely be more user friendly.  Thanks for your input. Take care. Pete

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points