Skip navigation
Currently Being Moderated

LrUUID

Feb 8, 2012 1:24 PM

Tags: #lruuid

I've been using the undocumented LrUUID namespace for a while now without any problems, however I just had a user report the error:

 

Could not find namespace: LrUUID

 

He's using Lr3.4 on Vista

 

Anybody know in which version of Lightroom this namespace first appeared?

 

I can't imagine it being an OS thing(?)

 

Thanks,

Rob

 
Replies
  • Currently Being Moderated
    Feb 8, 2012 5:03 PM   in reply to Rob Cole

    The perils of using undocumented interfaces (of which I'm equally guilty :-<).

     

    Seems unlikely that this would be dependent on the Windows version (i.e. not available in Vista).  The result of LrUUID (on Windows 7) looks like a Windows GUID:

     

    "C57FA964-8A58-4195-9A76-B6002A9633AC"

     

    Windows GUIDs have been around since at least Windows NT 3.5, I think, when Microsoft collaborated on the DCE standard.

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 9, 2012 9:52 PM   in reply to Rob Cole

    It does seem like an odd error to experience. Namespaces aren't typically

    something that would change across OSes or even within a major release

    cycle. Would have expected that namespace to have been available since at

    least LR3.2 (but more likely LR3.0) so the upgrade shouldn't really be

    necessary. Lets hope the upgrade fixes the problem for your user.

     

    Thanks, Matt

    (Apologies for the brevity - sent from my Android)

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points