Skip navigation
Helgoesthere
Currently Being Moderated

Cannot find Flash for Mac OS X 10.5.4

Feb 16, 2012 1:07 PM

Tags: #flash #install #problems #flash_player

I'm really not used to macs, so maybe this is just a communication issue. I'm using a Mac OS X 10.5.4
I'm using Safari (3.1.2) browser as well.
I have tried to install the newest flash, but it doesn't work with this computer, because it's a PPC.
I've read that people have been able to get it to work with later versions of Flash, but on the adobe site, there are no links to the actual downloads (FlashPlayer 9-10, for example).

I've tried to do it from the macromedia site, and I was able to download the installer.
Now when I open the downloaded content, I've got a box with 2 icons that say internet plugins, 1 icon that says flashplayer.xtp, and one that says flash player.plugin

When I try to open them, it says to choose an application to open it with...
None of them will open the program..
Please help!

 
Replies

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points