Skip navigation
Currently Being Moderated

Flash Player doesn't play every video

Jan 7, 2012 2:47 AM

Hello there!

 

After reading this forum and without finding a solution for my problem, I started this topic.

I'm using Firefox (9.0.1) with the newest Flash Player (11.1.102.55) on Windows 7 64-Bit. For security I use "Microsoft Windows Security Essentials" and the Windows Firewall.

I did uninstall and install Flash Player with the guide posted on this forum (source: http://forums.adobe.com/message/4041846#4041846).

 

But the problem still exists: I can't watch every video.

Youtube or livestream.com isn't a problem, but I can't watch twitch.tv or megavideo.com. On twitch.tv I can only see a black frame without sound, play/pause button etc.. Megavideo.com just tells me to install Flash Player.

On the forum I found a solution with deactivating the hardware acceleration but it doesn't save the setting. Thus I think about a problem with the rights of files/folders... but it's just a thought.

 

Maybe anyone of you can help me. I have this problem on 2 computers and on another 2 computers it works perfect.

 

Greetings from Germany!

 

Treuben

 
Replies
  • Xircal
    753 posts
    Mar 29, 2011
    Currently Being Moderated
    Jan 8, 2012 2:46 AM   in reply to Treuben

    Please follow my instructions to uninstall/reinstall Flash player again here: http://forums.adobe.com/message/4081633#4081633

     

    To disable Microsoft Security Essentials, do the following:

    1. Open MSE and go to Settings, then Real Time Protection
    2. Remove the checkmark from: "Turn on real time protection".
    3. Close MSE and proceed with the uninstall/reinstallation process.
     
    |
    Mark as:
  • Xircal
    753 posts
    Mar 29, 2011
    Currently Being Moderated
    Jan 9, 2012 6:22 AM   in reply to Treuben

    Treuben wrote:

     

    Hello Xircal!

     

    I did exactly what you told me, but the problem still exists.

     

    Megavideo still tells me:

    "

    You need a newer Flash player version to use this player. Please click here and update your Flash player to the latest version or open the following link manually:

     

    http://get.adobe.com/flashplayer/

    "

     

    http://www.adobe.com/software/flash/about/ -> You have version 11,1,102,55 installed

     

    Thus the twitch.tv livestreams don't work for me.

     

    Any other ideas?

     

    Check to make sure that both boxes displayed in the panel on this site are checkmarked: http://www.macromedia.com/support/documentation/en/flashplayer/help/se ttings_manager03.html

    What you see there are the actual settings on your own machine. Set the slider to read 100KB.

     
    |
    Mark as:
  • Xircal
    753 posts
    Mar 29, 2011
    Currently Being Moderated
    Jan 9, 2012 9:44 AM   in reply to Treuben

    Treuben wrote:

     

    Hey!

     

    I can set it to 100kb, but I can't check the two boxes.

    If I close the page and open it again, the 100kb isn't saved.

     

    Please do the following.

     

    1. Open Firefox, then hit ALT to toggle the text links on.
    2. Next, click Help, then "Restart with add-ons disabled".
    3. Firefox will close and you'll see a menu. Click "Continue in Safe Mode" without checkmarking any of the boxes.
    4. When Firefox restarts, all your Add-ons will be disabled. Go to the Global Settings panel again and see if you can checkmark the boxes. If you can, then one of your Firefox Add-ons is blocking your ability to do so.
    5. In that particular case, repeat steps 1 & 2, then when you get the menu, checkmark the top option which is "Disable all add-ons". Then click the button called "Make changes and restart".
    6. When Firefox restarts, re-enable your Add-ons one-by-one until the problem recurs. Then you'll know which one is the culprit.

     

    Unfortunately, I'm going on vacation for two months and my flight departs in about 12 hours from now and I still have to pack. So regretably, won't be able to update this thread again until I get back again in mid-March. But the fact that you can't checkmark the boxes would seem to indicate that something you have installed is preventing that. Here's a list of problematical extensions which might provide a few clues: http://kb.mozillazine.org/Problematic_extensions

     
    |
    Mark as:
  • Chris Campbell
    9,455 posts
    May 4, 2010
    Currently Being Moderated
    Feb 28, 2012 5:43 PM   in reply to Treuben

    Can you try this with Chrome and IE to see what happens there?  Can you give me a URL where this is failing?

     

    Thanks,

    Chris

     
    |
    Mark as:
  • Chris Campbell
    9,455 posts
    May 4, 2010
    Currently Being Moderated
    Feb 29, 2012 4:28 PM   in reply to Treuben

    Could you try disabling temporarily your security software and reset your hosts file to see if that helps?  When you bring up the live stream pages (like on twitch) what does the player show?  Just a black screen?  If you right click on it, does it show the flash player menu?

     

    How do I reset the hosts file back to default?

     

    Chris

     
    |
    Mark as:
  • Chris Campbell
    9,455 posts
    May 4, 2010
    Currently Being Moderated
    Mar 1, 2012 5:31 PM   in reply to Treuben

    Could you try disabling all your startup items/services and see if that makes a difference with either the playback or the ability to disable hardware acceleration?

     

    http://kb2.adobe.com/cps/404/kb404984.html

     

    Thanks,

    Chris

     
    |
    Mark as:
  • Chris Campbell
    9,455 posts
    May 4, 2010
    Currently Being Moderated
    Mar 2, 2012 5:39 PM   in reply to Treuben

    Let's try doing a clean install.  In particular, please manually delete the folders called out in this FAQ:

     

    How do I do a clean install of Flash Player?

     

    If that doesn't work, try putting UAC back to normal and see what happens.

     

    Thanks,

    Chris

     
    |
    Mark as:
  • Chris Campbell
    9,455 posts
    May 4, 2010
    Currently Being Moderated
    Mar 5, 2012 11:19 AM   in reply to Treuben

    With the new user account, did you try installing Flash Player for Firefox?  It sounds like you're running into file/folder permission issues, I'll see if I can find some commands that will spit this information out for us so we can compare against your working account.

     

    As for the black box, when you right click it does the Flash Player context menu appear?

     

    Thanks,

    Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2012 4:18 PM   in reply to Treuben

    Herr Treuben ... danke.

    I've had this same problem for a long time.  It's always an embedded object of the form:  application/x-shockwave-flash that fails for me.  The problem is the same with IE8, IE9, Firefox 11, Firefox 13, Opera, and Safari ... on my desktop computer.  My laptop shows the flash on those same sites without a problem.  Note that flash content which is NOT embedded plays just fine on my desktop.

    I've also deleted, cleaned up, and reinstalled everything with the firewall and antivirus disabled ... but no change.

    Following reading your information, I enabled and logged in to my Guest account ... and the embedded flash objects play without any problem.

    I have no idea what's up, but it's nice to see that something works to solve this.

    (There's one website that I refused to order from, because I couldn't see their images.  Now I can.)

     

    Thanks.

    Tim

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 15, 2012 4:02 PM   in reply to Treuben

    I also had this problem and managed to fix it by doing the following, found at http://forums.adobe.com/thread/889577?tstart=0:

     

    1. Close all browsers
    2. Open an explorer window
    3. Navigate to the following folders and delete the contents
      • %appdata%\adobe\Flash Player\
      • %appdata%\macromedia\

     

    Perhaps it will help you as well.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points