Skip navigation
Currently Being Moderated

Flash Builder 4.6 horribly unresponsive

Feb 16, 2012 8:43 AM

I'm using Flash builder 4.6 (and have used prior versions of flash builder as well) with a flex/actionscript project on a Windows 7, 64 bit box.  Flash Builder itself (not the launched application) is horribly slow and unresponsive.  I do not have the auto build turned on or design mode on

 

Here are some of the problems I regularly have:

- Opening the window, if it has been minimized, and clicking anywhere on it causes the window to be greyed out and have the "(not responding)" message added to its title bar.  It starts working after 15 seconds.

- Using the arrow keys to move up and down in a .as or .mxml file is jerky.  I.e., some keystrokes move at the rate I hit them, but others pause, wait a few seconds, and then move.  This also occurs with mouse actions.

- Using code navigation like F3 or <CTRL>-<SHIFT>-G causes Flash Builder to pause while it thinks.  In the case of <CTRL>-<SHIFT>-G, it pauses so long that one thinks there are no references (because the search starts with 0 results).

- Building code within flash builder takes minutes.  Even the modification of a single file takes forever.

 

In general, I've found working with Flash Builder one of the worst development experiences (I've worked with Eclipse for the last 6 years, VIM, & Visual Studio too) I've had.

 

 

These are the installed components:

  Adobe Data Modeling Core Components 4.5.304901.v20110217 com.adobe.model.feature.core.feature.group Adobe Systems Incorporated

  Eclipse IDE for Java Developers 1.4.0.20110615-0550 epp.package.java null

  org.eclipse.equinox.p2.operations NLS Support 3.7.0.v20110716043402 org.eclipse.equinox.p2.operations.nl1_3.7.0.v20110716043402 Adobe Systems Incorporated

  org.eclipse.wst.internet.cache NLS Support 3.7.0.v20110716043402 org.eclipse.wst.internet.cache.nl1_3.7.0.v20110716043402 Adobe Systems Incorporated

  RDS Core and Database Components 4.5.304901.v20110217 com.adobe.rds.feature.feature.group Adobe Systems Incorporated

 
Replies
  • Currently Being Moderated
    Feb 16, 2012 9:02 PM   in reply to Nick_Goodman

    No solution, but I get similar results. I use a new 27" imac with bootcamp Win7 x64, and the response time is appalling, although not as bad as you are having. When I boot into the OSX part and use FB4.6 there, it is absolutely fine. I am getting a second or two of non-response when adding variables and generally slow otherwise when using Windoze only.

     

    I'm pretty critical, but when FB is working well, like in OSX, it is quite good for me.

     

    Joe

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 17, 2012 12:43 AM   in reply to joe_orac

    I have similar problems with some .as files. The compiler/formatter/assistant seems to hang, consuming 100% cpu (or 25% on my quad-core) and blocking the UI. Each keystroke / click takes 10-15 seconds. The cursor flashes very slowly. Sometimes the window goes white with "not responding" in the title bar.

     

    I have not yet been able to pinpoint the problem precisely or reproduce with a simple code sample, but it seems to happen when

     

    a)  your code contains inline (anonymous) functions and

    b) you have typed an opening bracket but no closing bracket yet -  ( ), { }, [ ].

     

    The situation continues until the brackets are balanced.

     

    Can either of you confirm that this is so in your case?

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 28, 2012 9:51 AM   in reply to Jon Webb

    Jon

    I have the same issue. Working with fb 4.6 is nightmare. Especially with mxml files.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2012 9:03 AM   in reply to Nick_Goodman

    It does run better on OSX, but the build times have gotten out of hand and are killing productivity. Another problem I see frequently with the Windows version are Heap errors, JVM out of memory.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 22, 2014 8:06 AM   in reply to Nick_Goodman

    Are there still no solutions to this issue? This is by far the most sluggish and unresponsive adobe product I've experienced.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points