Skip navigation
Currently Being Moderated

Error connecting via RDS

Aug 22, 2011 7:59 AM

I rarely use RDS, but I've been trying to connect to a ColdFusion 8 enterprise multi-instance server from ColdFusion Builder 2.  The particular instance I want to connect to is listening on port 80 via IIS, and port 8050 using JWS.  I've set an RDS password in the ColdFusion administrator.

 

When I try to connect to the server via RDS, I get this error: "could not initialize class com.adobe.rds.core.services.messages".  What am I doing wrong?

 

I'm connecting over a VPN to a Windows server, using CF Builder on Mac OS X Lion.

 

Thanks,

- Andrew.

 
Replies
  • Currently Being Moderated
    Aug 25, 2011 12:05 PM   in reply to AndrewNClarke

    A coworker of mine has the same problem and we determined it's because his evaluation copy converted to

    the "Free" version which does not allow the configuration of Remote servers. 

     

    Maybe the same cause for you?

     

    - Joe

     
    |
    Mark as:
  • Currently Being Moderated
    Feb 23, 2012 9:42 PM   in reply to Joe Chahine

    Joe, Andrew,

     

    We are not able to repro in our installtion of standalone and plugin configuration. Can you please extract the RDS Core plugin(com.adobe.rds.core_*.jar) check for the class com.adobe.rds.core.services.Messages.class.

     

    Also check the password in your RDS settings at ColdFusion Administrator and ColdFusion builder server configuration dialog.  You can reset your RDS password, to eleminate possiblity of any configuration errors.

     

    Also check regstering the other remote server and try accessing the RDS for the same.

     

    Thanks

    Shilpi

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 3, 2012 11:29 AM   in reply to AndrewNClarke

    Anybody else having this RDS connection issue within ColdFusion Builder 2? 

     

    After a new install of ColdFusion 10 beta on a fresh Windows 7 box with Apache 2.2, I can visit http://127.0.0.1/CFIDE/componentutils/packagelist.cfm and RDS connection is good.

     

    But when I try RDS connection from within CF Builder 2, I get the following error message: "The HTTP request to talk to your server returned with the following message: Could not initialize class com.adobe.rds.core.services.Messages"

     

    Thanks,

    Marty McGee

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2012 7:40 AM   in reply to damartman

    Marty,

    Is it your server?  In IIS try setting the /CFIDE folder to "anonymous access" and see if that helps.  It solved

    a similar problem for us where other frontends like CF ReportBuilder and DW could connect via RDS,  but CFBuilder 2 could not.

     

    As far as I know, the new setting is not impacting our security because the console still asks for administrator login. 

    (we are on an Intranet and less worried than www though). Frontends also continued to ask us for login.  So If anyone

    can tell me the drawbacks of setting /cifide to anonymous, please let me know. 

     

     

    Joe Chahine

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2012 9:31 AM   in reply to Joe Chahine

    Hey Joe,

    Thank you for the suggestion.  I am running CF on Apache server, so I cannot try this approach.  But I'm sure others using IIS that are having RDS connection issues could be successful using your solution.

     

    In my opinion, it should be okay to allow "anonymous access" to the /CFIDE directory, as long as you are requiring RDS login password.

     

    Still trying to figure out RDS connection using CFBuilder 2, ColdFusion 10 beta, and Apache server.

     

    Thanks,

    Marty McGee

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 5, 2012 10:08 AM   in reply to damartman

    I saw "Windows 7" in there and thought IIS.

    I would think that Apache has a configuration for "Authentication" technique as well.

     

    I look forward to whatever solution you come up with (hopefully).

     

    Joe Chahine

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 13, 2012 8:22 AM   in reply to Shilpi Khariwal

    Experiencing the same issue. Intermittently RDS connection will stop working and generate the "Could not initialize com.adobe.rds.core.services.Messages" error. Sometimes removing and re-adding the RDS Server will fix it, sometimes not. Eventually, it seems, it will just decide to start working again. Two instances of CF9 running on Windows, if one goes they both go. Not sure if relevant, but we also have a box running CF6 on Windows as well that DOES NOT seem to be affected by the issue. Meaning, right now I can connect to the CF6 box, but both CF9 boxes throw the error. Just started happening in the last couple of months, but I'm struggling to trace it back to any specific event. Will keep looking for a solution and update if I find anything.

     

     

     

    UPDATE: By the time I finished writing this post, I tried and successfully opened a file via RDS. I did absolutely nothing during that time. Strange.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points