Skip navigation
Martov-photo
Currently Being Moderated

Lightroom 4 download doesn't start.

Mar 6, 2012 9:57 AM

Hey, I've just purchase de Lightroom 4 and I'm unable to download it. Safari can't find the associated link file. I've tried from Europe site as well as the download link that came with the order. I've also tried the trial version. Nothing to do, is there a problem with the server ? Even tried with Firefox !

 

Thank you for your time.

 
Replies
  • Currently Being Moderated
    Mar 6, 2012 9:57 AM   in reply to Martov-photo

    I am currently download Lightroom 4 successfully as we speak utilzing Chrome on Mac OS.  Perhaps try a different web browser or Internet connection?

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2012 10:13 AM   in reply to Martov-photo

    It might have to do with an add-on or plug-in you have installed in Safari and Firefox.  I was able to initiate the download process in Safari as well.  If you just installed Chrome then the other software you have installed, which might install add-ons or plug-ins, would not be installed.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points