Skip navigation
Currently Being Moderated

"Unhandled win32 exception occurring in RoboHTML.exe[2056]."

Mar 5, 2012 5:59 PM

Hi,

 

I've recently converted my HTML help system to RH 9. I initially had some trouble with an unhandled exception that triggered the Visual Studio debugger. Following an instinct, I looked for and renamed any files and folders whose names contained apostrophes, and the trouble seemed to go away.

 

Things have been going well, until I tried to build today. When I try to build my project, I receive the subject error message in the Visual Studio debugger. The failure occurs within seconds of posting the "Updating files..." message in the Output view.

 

Are there any build log files I can look at to help me figure out what is causing this problem? 

 

I've recently built some other, smaller HTML projects without any trouble so I have to suspect some kind of trouble with this specific help project.

 

I'm a pretty experienced RH user, but have rarely had to do any serious troubleshooting, so I have no clue where to start. Any ideas would be much appreciated. Anyone who wants to contact me directly can send email here.

 

Thanks in advance,

Mary Schoppmeyer

 
Replies
  • Currently Being Moderated
    Mar 6, 2012 12:16 AM   in reply to marysch0pNH

    Welcome to the forum.

     

    Generally we prefer answers to be via the forum so that others with the same problem benefit from the answer(s).

     

    Occasionally we see posts related to the Visual Studio Debugger with no real answer. The only log files I am aware of are those built into Windows and from what I am told they are for serious geeks and of little real help. Happy to be contradicted on that.

     

    My first step would be to move this project to another machine that does not have the debugger on it and see if it builds OK.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

    @petergrainge

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 6, 2012 3:13 PM   in reply to marysch0pNH

    What I am getting at is something in this project that is only a problem as far as Visual Studio is concerned.

     

    Ordinarily I would say send me a copy of the project but it's too close to some travel plans.

     

    Have you tried deleting the CPD file? Should have mentioned that earlier.

     


    See www.grainge.org for RoboHelp and Authoring tips

     

    @petergrainge

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points