Skip navigation
Currently Being Moderated

Elemements 10 Photo Downloader "Please Wait" does not go away

Mar 5, 2012 10:25 AM

I just installed PSE 10 and when I try to download pictures from a camera - I tried two cameras - it never gets past the "Please Wait" dialog once you pick the camera. The system then hangs and the only way to un-hang it is to turn off the camera or via the PC's task manager. I have waited 10 min. It worked fine on PSE 9.


Any suggestions?

  • Currently Being Moderated
    Mar 5, 2012 1:08 PM   in reply to wbr15



    Just to clarify, was PSE 9 and PSE 10 on the same system? Which version of windows?


    Are you trying the Advanced dialog?



    Mark as:
  • Currently Being Moderated
    Mar 9, 2012 7:43 AM   in reply to wbr15



    PSE 9 and PSE 10 can co-exist on the same PC - the reason I asked was to eliminate any hardware or Operating system differences.


    If you start with PSE closed and your camera disconnected, what happens when you first connect your camera? - Does the downloader pop up or do you have to load PSE and do a get from camera?


    What cameras are you connecting?


    I'm assuming that you haven't changed the communication settings on the camera since you had it working on PSE 9.


    No messages showing up on the camera?



    Mark as:
  • Currently Being Moderated
    Mar 9, 2012 11:17 AM   in reply to wbr15



    I have been testing using a Canon SX30 and the autostart feature doesn't work there either - I think it is a funny with using 64bit system - is yours 32 or 64bit?


    If you connect your camera and switch it on, does it show up in the Start -> Devices and Printers list?


    If there, double click on the camera and that should open another window


    You should be able to browse the camera and see the images on the card.


    Are your options set correctly at Edit -> Preferences -> Camera or Card Reader?


    There is a new version of the downloader out for a fix to the date problems. It shouldn't affect your situation but it might be worth a try.




    The only other thing I can suggest at this stage is to uninstall PSE 10 and install it again. It seems as though one of the files has become corrupt.



    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points