Skip navigation
Andre_The_Giant_0
Currently Being Moderated

Flash Builder 4 Strange Behaviour

Jan 30, 2011 10:42 AM

Hi, I'm using the Flash Builder 4 trial version for creating custom xmp panels for use in InDesign and Photoshop.

 

I've built and published a panel which is working fine, but if I shut down my Mac and then try to update this project later in the day after quitting the app, the panel isn't published correctly and don't work anymore, the same thing happens even after creating a new XMP project.

 

If the panel is working then the swf file shows green after opening it, and white (blank) if it's not working.

 

This don't exactly help my company in making a purchase of this software.

 

Hopefully someone has an idea of what's going on.

 

P.S. This even happens with new project and the default code.

 

Thanks

 
Replies
  • Currently Being Moderated
    Feb 1, 2011 6:03 AM   in reply to Andre_The_Giant_0

    Hi,

     

    http://forums.adobe.com/community/design_development/xmp_sdk?view=disc ussions might be the best place to post this question.

     

    I'm not familiar with the XMP SDK, so this may not apply: Make sure your panel shows up. Delete the SWF that Flash Builder created, make sure your panel doesn't work. Now make a change in your code and check.

     

    Also, you may want to check if Project -> Build Automatically is checked.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 16, 2012 8:54 AM   in reply to Andre_The_Giant_0

    Andre:

     

    Hi. I'm trying to do the same thing (create custom xmp panels) and I'm having miserable luck following the XMP Fileinfo SDK.

     

    I've installed Flash Builder 4. I've installed Apache Ant. Dumped the appropriate .jar file in the plugins section. Downloaded the AntView plugin and installed that and then created the MySample example.

     

    It runs fine as a web application from FB and it appears to publish correctly (creating a .swf file in the target bin and writing it all out to the proper location in the Adobe xmp custom panels folder) but when I access the File Info screen in an Adobe product, I get a tab with MySample but the dc field doesn't show up.

     

    I assumed it was a Flash trust file issue and created one, but it still doesn't work. I'm getting no errors and I've tried this a dozen times with the same results.

     

    Was there some step that I missed that you see by any chance?

     

    Thanks.

     

    --jon

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points