Skip navigation
JWW001
Currently Being Moderated

Lightroom 4 - GPS coordinates not saved in EXIF when Exporting JPGs

Mar 19, 2012 7:58 AM

Tags: #export #gps #exif #lightroom4

I have updated GPS coordinates using the new Map module but these are not output with the EXIF when I export JPGs.

 

I have ensured that Remove Location Info is unchecked.

 

I welcome any advice

 

regards

 

JWW001

 
Replies
  • Currently Being Moderated
    Mar 19, 2012 8:00 AM   in reply to JWW001

    I had the same issue. It has to be toggled several times, then it's OK.

     

    Check it on, then off again, then save. See if the data  is being exported then.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 19, 2012 3:53 PM   in reply to JWW001

    Can you post a small JPEG, together with screen shots of the metadata panel and the export dialog here?

     

    Beat

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 20, 2012 1:26 PM   in reply to JWW001

    OK, I can reproduce what you're seeing. It seems to be happening when exporting a JPEG file with updated GPS data as JPEG. Doesn't happen when changing GPS data on a Raw image and exporting it as JPEG (export contains updated information).

     

    I would report it as a bug here.

     

    Beat

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 20, 2012 2:25 PM   in reply to JWW001

    What are the exact steps to produce with a Raw?

     

    Beat

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 21, 2012 3:46 PM   in reply to JWW001

    OK, I now can see what you mean. It only happens on Raw files if they already contained GPS data in Raw-Exif while importing them.

     

    Beat

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2012 9:43 AM   in reply to b_gossweiler

    This was happening to me when the original RAW did not have any GPS data, then added via Map view (and jf Geocodeing plugin via GPX file). I found that the suggestion above of cycling the "remove location info" checkbox in editing publish settings for my service did the trick.

     

    Steven

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2012 6:08 AM   in reply to JWW001

    https://img.skitch.com/20120408-rpxkgd9thsg4y9c8ejf9dikif5.jpg

     

    Maybe your file still hold old data, as the Metadata Status has been changed and not updated?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2012 7:27 AM   in reply to JWW001

    Oh... Okay, I just saw that this question was not answered. Hope it gets solved for you!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 9, 2012 5:02 AM   in reply to JWW001

    I can confirm this behaviour of Geodata not being exported to JPG files by LR 4.0. It works fine for DNG and CR2 files, though.

     

    I wonder if this has already been fixed in LR 4.1 RC. Did you try LR4.1 already?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 10, 2012 1:19 PM   in reply to Guenther Blumenstock

    I try LR4.1 RC version but it doesn't works : my GPS coordinates are not output in my export JPGs. I don't understand.

     

    Note : My GPS coordinates have been saved in my origins JPGs, without problem.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points