Skip navigation
Jessie2109
Currently Being Moderated

"This FXP project is invalid and cannot be opened"

Nov 10, 2010 1:45 AM

I am working on this project and all of the sudden Catalyst doesn't allow me to open this file and pop-up the message: "This FXP project is invalid and cannot be opened"

I am thinking if its because I deleted a swf file from the fxp library, which is a gallery slideshow that I want to take out.

It popped up a message about it might case some kinda problem, but I ignored.

I have read those posts in Adobe forum about this issue and tried to solve it but doesn't work.

can some one help?

 
Replies
  • Currently Being Moderated
    Nov 10, 2010 1:54 PM   in reply to Jessie2109

    Hey Jessie - what version of Catalyst are you using? CS5 or Panini?

    Thanks!

    Tara

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2010 3:10 PM   in reply to Jessie2109

    Hi Jessie,

     

    If you said you were using the Panini preview build, the problem would've sounded like a bug with a new part of the product which checks project compatibility between Builder and Catalyst. But since you're using Catalyst CS5, the best way for us to diagnose what happened is to check out the FXP. Can you attach it, or send a copy via email?

     

    Thanks,

    Eric

     

    Catalyst QE

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2010 3:33 PM   in reply to Jessie2109

    Hi Jessie – Thanks, just downloaded a copy and am checking it out now.

     

    Eric

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 11, 2010 10:18 AM   in reply to Eric Lopatin (Adobe)

    Hi Jessie,

     

    I've removed the transition code that was corrupted by the last edit you mentioned, and the project now opens fine. I'll send a copy to you via email or ftp.

     

    Eric

     
    |
    Mark as:
  • Currently Being Moderated
    May 28, 2011 7:35 AM   in reply to Eric Lopatin (Adobe)

    Hi Eric,

     

    I'm having the same issue that I've been trying to sort for over two weeks and the forums aren't getting me anywhere. how do you remove the last action that makes the program crash?

     

    Thanks in advance

     

    Christian

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 1, 2011 11:17 AM   in reply to ChanceDogUSA

    Hi Christian,

     

    My apologies for the late reply. The best way to do this is to import the file into Flash Builder 4.5. Once imported, Builder will automatically generate a list issues in its Problems panel. If you hit a similar snag as the other user in this post, look for a corrupted Transitions tag (e.g. missing code and improper closure of the tag in MXML). In this case deleting the damaged transitions code will result in a need to rebuild transitions in Catalyst, but the rest of the project will be intact. Once done, export the project from Builder to a new FXP.

     

    Re-opening the project in Catalyst requires use of Catalyst CS 5.5, as the earlier version won't open Builder-edited projects. If you don't have Catalyst CS 5.5 and you'd rather not deal with editing in Builder, let me know. It's possible to manually edit files inside an FXP (which is similar to a ZIP archive). I can take a look at the project's content this way and send you an updated FXP that will still open in Catalyst CS5.

     

    Eric

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2011 5:54 AM   in reply to Eric Lopatin (Adobe)

    Eric,

    I just lost a file very similarly. Catalyst seems to have gotten hung up on a transition and has thus rendered the file inoperable. I'm about 15 hours in and was putting the finishing touches on the final today (figures). Is there any way I might be able to have you take a look at it?

     

    Thanks,

    Shane

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 21, 2011 10:17 AM   in reply to ColoradoDesigner87

    Hi Shane,

     

    Sure, I'd be happy to check out the project file. If you'd like, send me an message with the location of the file off-thread, via the forum's email service. Attachments here are limited to 5MB.

     

    Thanks,

    Eric

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 22, 2011 9:24 AM   in reply to Eric Lopatin (Adobe)

    Eric,

    Thanks for the quick reply. I rebuilt the file and have it in working order now, luckily the process only a took a few hours due to the majority of the work in catalyst being interactive links. While I have you, I do have a quick question concerning linking to Youtube videos in Catalyst. I have looked around a bit on the forums and am downloading your trial version of Builder to give it a shot there (looks like I can rename the video tag to the specific URL) but I wanted to make sure you didn't have any other recommendations. The video file is too large to upload to our server as it continues to time out at 18 of the 70mb. I might be able to compress the video in Encoder to get it smaller and perhaps "uploadable" but I'm concerned about the resulting loss of resolution.

     

    Thoughts? Recommendations?

     

    Again, thanks for your help.

     

    Shane

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2011 10:25 AM   in reply to ColoradoDesigner87

    Hi Shane,

     

    I researched this a bit and discovered the limitation to the simple solution of using a SWFLoader tag in FlashBuilder: you will not be able to re-open the project in Catalyst CS 5.5 once such a tag exists in the project.

     

    If re-opening the project in Catalyst isn't a concern (e.g. adding the video is the very last thing you'll want to do), then I'd suggest these steps:

     

    1. In Catalyst, drag/drop a Video placeholder from the Common Library panel onto the artboard, so you know where you'll know where to revise code in Flash Builder.

    2. Save out the FXP

    3. In Builder, choose File>Import Flash Builder Project to import your FXP from Catalyst

    4. Find the placeholder video code, which will be:

     

    <s:VideoDisplay x="276" y="85" autoPlay="false" scaleMode="stretch"
                            source="assets/media/fpo_video.flv"/>

     

    5. Replace the instance of VideoDisplay with an instance of SWFLoader:

     

    <s:SWFLoader x="200" y="200" source="http://www.youtube.com/v/hPUGNCIozp0?version=3"/>

     

    Note the above example points to a video on YouTube who's video ID is hPUGNCIozp0

     

    When you initially copy the URL from YouTube that points to you'll end  up with one like this:

    http://www.youtube.com/watch?v=hPUGNCIozp0

     

    Per Google's suggested embedded Player parameters (see: http://code.google.com/apis/youtube/player_parameters.html), the URL must be modified to call out the version of ActionScript in use; ActionScript 3. So you end up adding: /v/VIDEO_ID?version=3, where VIDEO_ID is the ID of your particular video. See the completed SWFLoader example URL above.

     

    To preview the project in Builder, right-click its folder in the Package Explorer and choose Run As>Web Application

     

    Hope this helps. I know it isn't ideal, but it's the most straightforward way of solving the problem if the video needs to be accessed straight from YouTube.

     

    Eric

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 23, 2011 10:28 AM   in reply to Eric Lopatin (Adobe)

    Eric,

    Thank you for your detailed reply, I greatly appreciate it. Perhaps we can both hope for a simpler integration in the next iteration of Catalyst. I'll let you know if I have any further issues.

     

    Thanks again!

     

    Shane Miles

    Graphics Technician

    High Plains Library District

    2650 W. 29th St.

    Greeley, CO  80631

    970.506.8571

    SMiles@highplains.us

    www.MyLibrary.us

     
    |
    Mark as:
  • Currently Being Moderated
    Jun 24, 2011 9:47 AM   in reply to ColoradoDesigner87

    Hi Shane,

     

    No problem, glad to help. Yes, simpler integration in the future for a common use case like this one would be good (fingers crossed).

     

    Eric

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 28, 2012 8:36 PM   in reply to Eric Lopatin (Adobe)

    I have a student that has been working on a flash catalyst project and she has just today got this message. We dont have flash builder.

    Are you able to give me any ideas as to get the project back up and running. This was due for submission next Thursday and is a major component of her course work.

    If you can give me some idea of what may have caused it I can also get a heads up and tell the kids not to do whatever they are doing.

    Cheers and I hope that you can help

     

    Andrew

    (IT Teacher)

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points