Skip navigation
Currently Being Moderated

LR4 Lens data problem

Mar 20, 2012 4:12 AM

Hi,

 

I'm a Sony user and installed the Lightroom 4 trial.  It imported the old 3.6 catalog and gave me a nice new Lightroom 4 catalog.  So far so good.  Everything looked normal.

 

Now, when I import new .ARW (Sony Raw) pics into LR4, I'm not getting the lens information correctly.  I use a tool call 'alphalensinfo' that reads .ARW files and creates .XMP files with the correct lens name.  LR3.6 used to import the pics and read the XMP, giving a correct lens name in the LR catalog.  LR4 seems to fail at this. 

 

For instance, with my Samyang 8mm, Alphalensinfo would add the exif field to the XMP file saying "Samyang 8mm".  LR3.6 then shows "Samyang 8mm" for the lens, after import.  LR4 shows "---" for the lens.

 

Has something changed in the way LR 4 handles Lens EXIF information?

 

Thanks

 
Replies
  • Currently Being Moderated
    Mar 20, 2012 5:12 AM   in reply to mikey_2000

    Maybe alphalensinfo needs an update for LR 4. Check their web site.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 20, 2012 6:22 AM   in reply to mikey_2000

    I use ExifToolGui for one of my Tamron lenses and it worked under Lighroom 4 (it also worked under 3.x).

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 27, 2012 4:20 AM   in reply to mikey_2000

    This has been reported several times:

     

    http://feedback.photoshop.com/photoshop_family/topics/exif_lens_id_lr4

     

     

    I also wrote it here:

     

    http://forums.adobe.com/thread/980863

     

     

    I also repeated the test using the very latest version of exiftool (the revision history says they fixed a couple of bugs in handling the lens tags for sony images).

    From some empirical evidence, it looks like if the lens was correctly identified by LR4, then you can rename it with exiftool.

    However the samyang lens, which is tagged as "----" in LR4, cannot be fixed and no matter what you do, it always displays as "----" (and if you resave the xmp, it overwrites your valid lensid string with ----).

    As an example, I have a tamron lens which was previously called "60 F2.0" and now is just "60 F2", and I was able to fix it.

    I have seen that the xmp file for samyang images is slightly different, but I have not yet a solution.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2012 12:44 AM   in reply to mikey_2000

    Ok, I may have a workaround, but I'm not familiar enough with sqlite to give you a working solution yet: I give you the idea just in case there's a sqlite expert listening...

    According to this page, the EXIF lens name is AgInternedExifLens.value

     

    http://www.max.grenkowitz.net/?topic=1057

     

    So I guess it may be possible to issue a command from terminal like

    sqlite -csv LR.lrcat "select * from AgInternedExifLens where AgInternedExifLens.value = '----'"

     

    then rewrite the string and re-import with an "update" command, possibly something like

     

    "update AgInternedExifLens set AgInternedExifLens.value = '500mm F4' where AgInternedExifLens.value = '----'"

     

    However I'll have a look at the schema and let you know.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2012 1:13 AM   in reply to mycroft.holmes

    This field holds a sort of lens name cache for quick acces. It is used in the Library Filter. The actual value that is displayed in the Metadata panel is taken from Adobe_AdditionalMetadata.xmp.

     

    Also, the AgInternedExifLens.value will be updated (ovewritten) the next time you do a Read Metadata.

     

    So, if all you need is correct display in Library filter and you're not going to re-read the metadata, that is an easy fix.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2012 5:39 AM   in reply to Dorin Nicolaescu-Musteață

    Is Adobe_AdditionalMetadata.xmp a piece of xml (i.e. the entire xmp) stored in the db?

    In this case I should probably rewrite both.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2012 6:24 AM   in reply to mycroft.holmes

    Yes, xml.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2012 2:07 PM   in reply to mikey_2000

    You might add your 2-cents to the feedback thread linked near the beginning of this thread, along with doing a +1 to indicate you have the same problem.  The feedback site is where to report issues, and the camera-raw engineer Eric Chan has already commented on that thread.

     

    Like you, I am both a computer guy and a camera guy, and cannot quite determine from what people have said, none being official Adobe people, whether there is a way to use some plug-in or SQLite command to fix things or not.  LR4 is obviously doing something different than LR3 but since the fix for previous versions of LR seems like a hack, then LR4 doing something different wouldn’t be a bug, but having a new hack would be useful.  I would guess that a plug-in might need to be written to do this specific function if that Adobe_AdditionalMetadata.xmp data area needs to be modified.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 31, 2012 5:52 AM   in reply to ssprengel

    Ok, the sqlite query works fine, it just requires some manual work: here are the Mac commands.

    close lightroom, open terminal and enter:

     

    sqlite3 -csv Lightroom\ 4\ Catalog.lrcat "select AgInternedExifLens.value, AgHarvestedExifMetadata.lensRef, count(*) c from AgHarvestedExifMetadata, AgInternedExifLens where AgInternedExifLens.id_local = AgHarvestedExifMetadata.lensRef group by AgHarvestedExifMetadata.lensRef order by c desc;"

     

    you will see some stats in the form

     

    LENS,CODE,COUNT

     

    e.g.

    "8mm F3.5 Fisheye",871646,89

    ----,524399,87

     

     

     

    the following command rewrites the lens identifier, so all photos linked to ---- are now linked to "8mm F3.5":

     

    "update AgHarvestedExifMetadata set lensRef = 871646 where lensRef = 524399;"

     

     

     

    you can also add a condition: e.g. limit to some particular day

     

    "update AgHarvestedExifMetadata set lensRef=871646 where dateMonth=12 and dateYear=2011 and dateDay=26 and lensRef=524399;"

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 19, 2012 1:21 PM   in reply to mikey_2000

    I would strongly suggest Adobe to make the lens field editable, like caption.

    This is probably a trivial change on their side, and it would get rid of all this sort of problems, and it would solve many more.

     

    Just a trivial example: when I put a filter on the lens, of course it won't show up in EXIF data , so I usually add a keyword.

    It would be nicer to select all the photos and modify the lens name directly in LR to (say) "85mm + Closeup".

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points