Skip navigation
Keith Howe
Currently Being Moderated

Trying to deploy a font with an app generates "Cannot access font page" error.

Mar 29, 2012 1:02 PM

Tags: #cq5 #font_management #font_installation

I'm trying to deploy a font within an app in CQ5.5 (Windows 64-bit JRE 1.6.0u31) using these instructions.

 

The server throws a "Cannot access font page" error when trying to process the font entry. Both the temp source file and temp target directory listed in the error seem to exist fine and have wide open permissions. I've tried clearing out these directories entirely but to no avail. The server generates the same error when it tries to process the font on startup as well.

 

29.03.2012 13:57:17.622 *INFO* [OsgiInstallerImpl] org.apache.sling.audit.osgi.installer Installed configuration com.day.cq.image.internal.font.FontHelper from resource TaskResource(url=jcrinstall:/apps/myapp/config/com.day.cq.image.internal.font.FontHelper, entity=config:com.day.cq.image.internal.font.FontHelper, state=INSTALL, attributes=[org.apache.sling.installer.api.tasks.ResourceTransformer=:50:, service.pid=com.day.cq.image.internal.font.FontHelper], digest=eecad2d31d8c73df7f30b84630205d87)

29.03.2012 13:57:17.626 *INFO* [CM Event Dispatcher (Fire ConfigurationEvent: pid=com.day.cq.image.internal.font.FontHelper)] com.day.image.internal.font.FontFileProviderImpl No files to delete in temporary folder C:\Users\khowe\AppData\Local\Temp\day_gfx_FontFileProviderImpl_1333051030580_2

29.03.2012 13:57:17.627 *INFO* [CM Event Dispatcher (Fire ConfigurationEvent: pid=com.day.cq.image.internal.font.FontHelper)] com.day.image.internal.font.FontFileProviderImpl Activated - using temporary folder C:\Users\khowe\AppData\Local\Temp\day_gfx_FontFileProviderImpl_1333051037627_3

29.03.2012 13:57:17.641 *ERROR* [CM Event Dispatcher (Fire ConfigurationEvent: pid=com.day.cq.image.internal.font.FontHelper)] com.day.image.internal.font.resource.ResourceFontCache addFont: Cannot access font page /apps/myapp/fonts/verdana.ttf java.io.IOException: Error renaming C:\Users\khowe\AppData\Local\Temp\com.day.image.internal.font.FontFileProviderImpl5221572673902143379.font to C:\Users\khowe\AppData\Local\Temp\day_gfx_FontFileProviderImpl_1333051037627_3\c7889920eee18bea9f4051ef58e949e1a69266a6.font

    at com.day.image.internal.font.FontFileProviderImpl.getFileForStream(FontFileProviderImpl.java:127)

    at com.day.image.internal.font.resource.ResourceFontCache.addFont(ResourceFontCache.java:386)

    at com.day.image.internal.font.resource.ResourceFontCache.syncFontMappings(ResourceFontCache.java:330)

    at com.day.image.internal.font.resource.ResourceFontCache.setupCache(ResourceFontCache.java:547)

    at com.day.image.internal.font.resource.ResourceFontCache.<init>(ResourceFontCache.java:150)

    at com.day.image.internal.font.resource.ResourceFontProvider.init(ResourceFontProvider.java:140)

    at com.day.image.internal.font.FontHelper.addFontProvider(FontHelper.java:210)

    at com.day.image.internal.font.FontHelper.activate(FontHelper.java:180)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:227)

    at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38)

    at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:591)

    at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:472)

    at org.apache.felix.scr.impl.helper.ActivateMethod.invoke(ActivateMethod.java:146)

    at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:226)

    at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118)

    at org.apache.felix.scr.impl.manager.AbstractComponentManager$Unsatisfied.activate(AbstractComponentManager.java:1140)

    at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal(AbstractComponentManager.java:334)

    at org.apache.felix.scr.impl.manager.ImmediateComponentManager.reconfigure(ImmediateComponentManager.java:426)

    at org.apache.felix.scr.impl.config.ImmediateComponentHolder.configurationUpdated(ImmediateComponentHolder.java:258)

    at org.apache.felix.scr.impl.config.ConfigurationSupport.configurationEvent(ConfigurationSupport.java:210)

    at org.apache.felix.cm.impl.ConfigurationManager$FireConfigurationEvent.run(ConfigurationManager.java:1832)

    at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:104)

    at java.lang.Thread.run(Unknown Source)

 
Replies
  • Currently Being Moderated
    Mar 29, 2012 2:43 PM   in reply to Keith Howe

    Hi Keith,

     

    I believe the problem is that in CQ5.5 (by default), is that anonymous user no longer have access to /apps, /libs, /home like it did in CQ5.4  Try moving /apps/myapp/fonts/verdana.ttf to /etc/designs/myapp/fonts/verdana.ttf and update the 'Day Commons GFX Font Helper' configuration in OSGi.

     

    Hope that helps.

    -Ron

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 29, 2012 11:46 PM   in reply to Keith Howe

    What type is your "font" folder? It should be a sling:folder and not a nt:folder.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 30, 2012 9:32 AM   in reply to Keith Howe

    I would suggest open a Daycare ticket then.  I suspect the documentation for 5.5 hasn't been updated, and possibly things have changed since 5.4.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points