Skip navigation
fedster72
Currently Being Moderated

Flash Builder 4 - Debugger fails to connect

Jul 2, 2010 12:07 PM

I've looked at the various other threads but no luck so far.

I'm using Flash Builder 4 and the Flex API 4 and until yesterday all was well - i.e. I could run my app in debug mode. Somehow today things stopped working. Not sure why - I didn't tweak anything in Flash Builder's options. When launching any app (most complicated to the simplest) I get a status bar telling me

 

launching: waiting for Adobe Flash Player to connect to debugger

 

that always gets stuck at 57%. Then after a few minutes I get

 

Failed to connect; session timed out.

Ensure that:

  1. You compiled your Flash application with debugging on.

  2. You are running the debugger version of Flash Player.

 

I'm using Chrome on Windows 7. I really need to debug.

 

thank you for any help.

 
Replies 1 2 Previous Next
  • Currently Being Moderated
    Jul 2, 2010 12:33 PM   in reply to fedster72

    It happens many a time ...but you can solve it in 3 ways

     

    1) Clean the project and try.

     

    2) Close flex builder and reopen it. try it...If that doesn't work than go for 3 option

     

    2) Change your workspace and import that project in it or best is create new one and make the changes in it...

     

     

    Sometimes the workspace get corrupted and so it happens...

     

    If this post answers your question or helps, please kindly mark it as such.

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2010 1:32 PM   in reply to fedster72

    Reboot and try again.

     

    There are sites that will tell you if you have a debugger player or not

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 2, 2010 10:24 PM   in reply to fedster72

    Hit this link: http://flashplayerversion.com/

    Does it say you have a debugger version?

     
    |
    Mark as:
  • Currently Being Moderated
    Jul 7, 2010 3:07 PM   in reply to fedster72

    I had the exact same issue. It appears the problem is an auto updater in Chrome that installs a non-debug version that trumps the debugger.

     

    Found the solution here:

     

    http://www.timo-ernst.net/2010/04/chrome-flash-debugger-not-connecting -to-flexflash-builder/

     

     

    Cheers!

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2010 8:43 AM   in reply to fedster72

    Hopefully Adobe is reading this. I've had this exact same problem since FlexBuilder v3. It's extremely frustrating. I have also experienced this with multiple versions of Firefox and IE all running debugger Flash players, and it has happened about 10 times so far this morning. Restarting Flash Builder sometimes lets me do maybe two or three builds before it happens again. I'd appreciate a more detailed report from Adobe on what exactly is the problem, especially since it is a huge time waster.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2010 8:52 AM   in reply to alpinegps

    Are you referring to a specific bug?  If not, file one with a project so we

    can analyze.

     

    Also see the "flashlog.txt" thread from yesterday.  Maybe PS is a factor

    here as well.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 6, 2010 9:20 AM   in reply to Flex harUI

    Yes, this is a specific bug that's been around a long time. I've experience this on multiple machines and many different browsers. I also thought I had opened a ticket several years ago and got the same answers that only provided temporary fixes: e.g. re-install project, re-install Flash/FlexBuilder etc.

     

    - Where do I go to officially file a bug? Do I have to have a support contract with Adobe to do this?

    - Can you please provide a link to the "flashlog.txt" post? I searched for it and didn't find anything from yesterday.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2010 10:37 AM   in reply to fedster72

    I believe I figured out my problem and it's a bit different. I definately have debugger versions of Flash Player installed. If I stopped a debug session from within FlashBuilder 4.0.1 everything seems to be working fine. HOWEVER, if I stopped a debug session by simply closing the browser tab, then in most instances the very next debug session failed to launch. I've been able to duplicate this on 4 different machines. Since Adobe never responded to my questions above for additional details on where/how to file a bug, I have not filed this as a bug. I hope this helps someone else.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 30, 2010 6:18 PM   in reply to alpinegps

    I get this issue ~ 40 times a day and it is extremely frustrating.   I have tried reinstalling flash builder, uninstalling anything that I think might affect it (fiddler & servicecapture), and have tried chrome, firefox, and internet explorer as my default browser for flex to no percievable difference.  The only recourse is to force a project clean and rebuild - which is absolutely horrible as the app I work on is ******* huge and basically adds about 2 minutes everytime i want to do a build.  Soooo frustrating....     

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 6, 2010 1:34 PM   in reply to fedster72

    I think I can help because I had the same problem and I spent a lot of hours trying to fix the problem. I tried several solutions but none of them worked. The problem is that the Flash Player in the browser hasn't debugging capabilities. The link mention earlier, http://flashplayerversion.com/, is a really good one to check if your browser's Flash Player has this feature.

     

    The solution for IE and Firefox can be found from this link http://www.adobe.com/support/flashplayer/downloads.html.

     

    Make sure you download:

     

     

    The first link will install debugger player for your IE and the second one for your Firefox. I think it's a bit misleading to mention "Netscape" nowadays, it should be switched to Firefox.

     

    Because Chrome has the Flash Player integrated (which is GREAT) it does, however, cause more problems to get a debugger player for it. However, as long as I have at least one browser that makes debugging in Flash Builder function -- I'm happy!

     

    One last thing, in Flash Builder make sure your web browser in Preferences is one that has a debugging supported browser. Go to Window > Preferences and choose General > Web Browser. Make sure the browser is either IE or Firefox. I also tried with Opera (v. 10.63) and it had the debugged version of Flash Player. So, Google just needs to do add a little improvement that developers can have a debugged player and everything is perfect.

     

    I hope this helps!

     

    --Herman

     

    Small typos fixed. Message was edited by: UpNorthWeb

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 7, 2010 5:50 PM   in reply to fedster72

    Hi,

     

    I have a problem when running debug in my Flash Builder 4. When i click on the debug button, when it launch i have ERROR 404 showing up in my browser.

     

    I have check the debug folder path and compare it with the browser they are the same. I noticed that the index.html is missing. Then i tried to copy the index.html from my release folder and somehow it run. But the when i run the debug again, it shows the ERROR 404 in my browser. Somehow it deleted the index.html that i copied from the release folder. 

     

    Anyone experiencing it?

     

     

    Regards.

    Cris

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 7, 2010 5:51 PM   in reply to MasterDrive

    By the way i'm using MAC and Safari brownser. Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 7, 2010 9:55 PM   in reply to MasterDrive

    What's in your html-template folder?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 8, 2010 4:43 AM   in reply to drkstr_1

    Hi,

     

    Inside my html-template folders are:

     

    history - folder

    swfobject.js - file

    playerProductinstall.swf - file

     

     

    thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 8, 2010 2:04 PM   in reply to MasterDrive

    Well that's your problem. You should have a index.template.html file in there. I'm not sure how you would regenerate this, but try going to Project -> Properties -> Flex Compiler and then try changing around some of the settings for HTML Wrapper. This should trigger a regeneration of that file.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 8, 2010 11:10 PM   in reply to drkstr_1

    Hi,

     

    Thanks for the advice, it works. But its very strange, because when i checked the flex compiler properties, the Generate HTML-Wrapper File is enable. What i did is, i disable it then enable it back, and  whoala.. it generate the html file. Is this a bug or something?

     

     

    Once again, Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2010 8:23 AM   in reply to MasterDrive

    Nah, stuff happens. It probably got deleted on accident. I personally wouldn't bother with a bug report.

     

    Glad you got it worked out.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2010 3:13 PM   in reply to drkstr_1

    Hi It's me again. I am trying to debug my application but somehow it pop me this error,

     

    FP_plugins.png

     

    I downloaded and tried to install Adobe Flash player, but then when i tried i still have this error. I check the path and found out that the Flash Player.plugin is in the correct directory. Below is the directory captured image.

     

    library.png

     

    Appreciate your help on this.

     

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2010 3:20 PM   in reply to MasterDrive

    Just an FYI, for anyone encountering the issue where the debugged sporadically connects to the browser debugger... Download the flash projector (stand alone) debugger.  Edit the projects debug settings and in the url to debug change the .html to .swf.  Instead of luanching in a browser it will launch in the stand alone flash projected application and connect every time.   Happy Coding.   For even more awesomeness use HellFire Daemon Compiler... its freaking insane!

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 9, 2010 3:30 PM   in reply to JTtheGeek

    Hey Geek,

     

    Thanks for the advice... my bad.. i just noticed that my FP is without a dubugger plugin.. stupid of me. LOL.. i managed to download the plugin with debugger and it works ok... Im still new and trying to learn programming.

     

    Thanks Again.. =D

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2010 7:34 AM   in reply to fedster72

    I am having the same issue however it's an AIR app so it is already a stand alone. Any ideas on this?

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 10, 2010 10:30 AM   in reply to llamajuana
     
    |
    Mark as:
  • Currently Being Moderated
    Mar 8, 2011 2:53 AM   in reply to fedster72

    Hi all,

     

    I ran into the same issue today and found this page while searching for help.

     

    None of the suggestions helped. But there was a suggestion to debug in flash itself. So I opened the .html file from bin-debug in the flash builder itself - basically double click, and it worked in the builder. Now the surprising part is I had not closed the applications I'd started for debug, these  were still stuck at 57%. These started opening in my browser with debugger version of flash player!! And it was debugging fine!

     

    Guess the trick is to click on the .html file while the progress bar is stuck at 57% for debugging the application. No clue why this works.. I have tried this 2-3 times and it worked always.

     

    hope this helps someone.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 23, 2011 11:26 AM   in reply to fedster72

    This happens because the Flash Debugger uses sockets and it failing to connect to the flash content in the browser.

    I find this happens to me when I accidently delete my debug configuration when I delete the project and recreate it.

    Developers tend to forget thta if you delete the project and recreate it it will delete your debug configuration as well.

    In my Debugging configuration, the default is to debug it from a html file from your file system, but in almost every case

    you want to specify a URL because you want to debug how your flash app will act after being actived from a web server.

    If it stuck at 57% just terminate it because it will not connect and check you debig configuration setting

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2011 3:22 AM   in reply to fedster72

    I'm having this exact issue with Flash Builder 4.5.1, flex sdk 4.5.1 and air 2.7

    My apps are air apps, they run fine, but can't debug. For a mobile application, i can debug on the mobile device, but not on desktop (emulator).

    The error is always debugger can't connect to the application.

     

    This is the error when i kill the app before Flash Builder times out trying to connect, it halts at 57%:

     

    Process terminated without establishing connection to debugger.

     

     

     

    Launch command details:  "I:\Adobe\Adobe Flash Builder 4.5\sdks\4.5.1\bin\adl.exe" -runtime "I:\Adobe\Adobe Flash Builder 4.5\sdks\4.5.1\runtimes\air\win" -profile mobileDevice -screensize 480x762:480x800 -XscreenDPI 252 -XversionPlatform AND "C:\Users\mia\Adobe Flash Builder 4.5.1\test\bin-debug\test-app.xml" "C:\Users\mia\Adobe Flash Builder 4.5.1\test\bin-debug"

     

    This is the error if i let the process to time out:

     

    The Flash Builder debugger failed to connect to the running application.
    Ensure that:
        1. For in-browser applications, you are running the debugger version of Flash Player.
        2. For network debugging on a mobile device, you have a reliable network connection to the device, and port 7935 is open on your machine's firewall.
            Device connection help

     

    Flash Player is really got nothing to do here since i'm trying to debug Air apps.

    Debugging worked fine with Flex sdk 4.5 and air sdk 2.6.

    After updating to air 2.7 and sdk 4.5.1 i couldn't debug any Air app, mobile or not (although i can debug on the mobile device, however it's a pain to always debug on the device, it's just a waste of time)

     

    I'm using windows 7 64b btw

     

    Is there any solution for this?

    Thanks

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2011 4:36 AM   in reply to pin05h

    I have encountered this situation many times in Flash Builder 4.5 and it always seems to occur when, prior to launching the application from the Builder I was using phpadmin (wampserver) and failed to close this application in the browser before staerting the debugger.

     

    The app load hangs at 57% every time.

     
    |
    Mark as:
  • Currently Being Moderated
    Aug 9, 2011 1:37 PM   in reply to Scott R. Hamilton

    I don't have wampserver installed nor am I using phpmyadmin on this computer.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 1, 2011 10:49 AM   in reply to pin05h

    flex 4.5

     

    Window xp sp3

     

    wamp

     

    This worked for me.

     

    debug your application en FLEX, when the message appears (bla bla bla 57%), go to your browser.

     

    Right click on the application (in you browser), you will see a menu.

     

    Select Debugger (you must have installed the flash player debug)

     

    In the new window, select "localhost" and Click on the button "connect"

     

    And that's all.

     

    I hope this helps.
     
    |
    Mark as:
  • Currently Being Moderated
    Sep 6, 2011 9:53 AM   in reply to A_O_9

    I'm having the exact same problem that pin05h is having - debugging in AIR, Flash Builder hangs at 57%, get the same error message every time, not running phpadmin or wampserver. However, when I debug the application, not only do I have nowhere to right click and say Connect (the window does not appear until the error does), but the error only lasts 3 or 4 seconds.

     

    How do I specify that I want the app to run in the browser? And, if we are using AIR-only features (which I'm not sure I am), how do we fix the debugging issue there? Thanks for working to fix this issue.

     
    |
    Mark as:
  • Currently Being Moderated
    Sep 6, 2011 10:58 AM   in reply to Compynerd255

    If you have many browsers installed in you pc, you can choice one of them doing this:

     

    FLEX:

     

    Window->Preferences

    General->WebBrowser;

     

    Then, you can select the browser where you have installed the debug plugin.

     

    Now, in the code: Right click->Debug as Web Appication.

     

    Message was edited by: A_O_9

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 30, 2012 8:02 PM   in reply to fedster72

    hi i have the same problem, adobe flash builder keep proceeding on 57%, i tried the solution of disabling chrome plug in but nothing happens, please help

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 31, 2012 1:03 AM   in reply to nico8691

    Are you sure you don't have a JS error in your HTML wrapper?

     

     

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 24, 2012 4:36 AM   in reply to fedster72

    Steps to resolve this issue, on window machine

     

    • Go to control panel -> add and remove programs
    • Uninstall Flash player 64 Bit and Flash Player 64 Bit Active X Player
    • Re-install Flash Player 32-Bit version Debugger player.
    • Exit your browers if required and Restart you IDE.

     

    This solved my problem, i hope it solves your problem with the warning message on debug click in the IDE.

     
    |
    Mark as:
  • Currently Being Moderated
    May 8, 2012 2:40 AM   in reply to krishnamrajgoud

    If you are using Chrome and the Flash plugin, be sure to disable the build in Flash plugin in Chrome:

    1. Type in you addressbar about:plugins.
    2. Click on details (in the upper right corner).
    3. Scroll to the flash plugin. Here you see two files (if you installed a debug version yourself).
    4. Disable the build in Flash plugin (which is located inside the chrome install folder).
    5. Restart Chrome, and start debugging your flash content.
     
    |
    Mark as:
  • Currently Being Moderated
    Jun 26, 2012 5:52 AM   in reply to Flex harUI

    Hi,

     

    I'm facing same issue, "Failed to connect;session time out". For the background, I'm using FB 3 and IE . A strange thing is happening in my Flex Builder though, for one application the debugger is working successfully but for the other its giving this error at 91% launch.

     

    Please suggest.

     
    |
    Mark as:
1 2 Previous Next

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points