Skip navigation
bellesoft
Currently Being Moderated

[Air 3.2] Windows 7 - Video Display upside down!

Mar 29, 2012 3:41 AM

Tags: #air #windows #issues #3.2

Hi, after upgrading many Windows client machines from 3.1 to 3.2 (being prompted to do so automatically by Air updater) my air applications are displaying the Video content upside down. the Mac machines are so far ok after the 3.2 air update.

 

My air application has not changed.  I even dowloaded the 3.2 sdk and recompiled the app on windows, but the Video is still flipped along the Y axis (flipped upside down).

Here is how I am using the Video:

 

video=new Video(uic.width,uic.height);

uic.addChild(video);

video.attachNetStream(screenNS);

screenNS.play(name);

 

 

Any clues, is this a known bug?

 
Replies
  • Chris Campbell
    9,456 posts
    May 4, 2010
    Currently Being Moderated
    Mar 30, 2012 6:29 PM   in reply to bellesoft

    I was not aware of this one, so probably not known.  Any chance you could send me your app so I could verify it internally?  Feel free to contact me directly at ccampbel@adobe.com.  In addition, could you please open a new bug report on this over at bugbase.adobe.com?  Please post back with the URL so that others affected can add their comments and votes.

     

    Thanks,

    Chris

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2012 4:32 AM   in reply to bellesoft

    Hello!

    Is there any update?

    I faced the same problem and need a fast solution.

     
    |
    Mark as:
  • Chris Campbell
    9,456 posts
    May 4, 2010
    Currently Being Moderated
    Apr 12, 2012 11:53 AM   in reply to sadensmol

    We're actively working on this bug, unfortunately I do not have any workarounds for you at this time (other than rolling back to the previous AIR runtime).

     

    If you have a minute, please visit bellesoft's bug and cast your vote.

     
    |
    Mark as:
  • Currently Being Moderated
    May 14, 2012 5:47 AM   in reply to Chris Campbell

    My testing team reported a bug which said there was a problem with seeking the video. I am using mx:VideoDisplay component and the problems surfaced after upgrading to 3.2 runtime. Why I am saying this is I have 3.1 sdk with my FB and this problem is not there when I debug the app, but when I export a build and install it, the problem begins with 3.2 runtime runtime. I was not aware of this difference as the update happens automatically. Is there any solution to go around this one? Also, I am now downloading the 3.2 sdk so that I can try debugging with 3.2 environ.

     

    Video display is straight forward, but the problem occurs only when I try to seek it or maximize the display, ie, when we have to deal with playheadtime.

     

    Message was edited by: evyavan

     
    |
    Mark as:
  • Chris Campbell
    9,456 posts
    May 4, 2010
    Currently Being Moderated
    May 15, 2012 5:36 PM   in reply to evyavan

    This should be fixed in our AIR 3.3 beta 3 release.  Can you try this out and let us know how it works for you?

     

    If you'd like to move away from automatic updates, I'd like to encourage you to take a look at AIR's captive runtime option.

     

    Thanks,

    Chris

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points