Skip navigation
gottothinkpositive
Currently Being Moderated

surface blur slow

Apr 1, 2012 4:46 PM

So i was pretty excited cause surface blur was super fast when i first tried cs6...takes 5 min run time for me now in cs5... but its slow like in cs5 now. any ideas?

 
Replies
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Apr 1, 2012 5:06 PM   in reply to gottothinkpositive

    Check your GPU settings in Preferences - Performance.  I believe Photoshop is adaptive, meaning if it encounters problems in your display driver it might reconfigure itself not to use the GPU in the same ways it originally tried.

     

    If it's deconfiguring use of of your GPU, perhaps you need an updated display driver on your system. 

     

    What computer, OS, and video card do you have?  For PCs the manufacturers all release new drivers fairly frequently.  For Macs the display driver updates come with OS updates from Apple.

     

    -Noel

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Apr 1, 2012 7:36 PM   in reply to gottothinkpositive

    Did you check in Photoshop's Preferences - Performance menu as I mentioned to see if the GPU has been disabled?

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 1, 2012 8:03 PM   in reply to gottothinkpositive

    When Noel mentioned the video card, he meant what video card is in your computer driving your display rather than if you are using a camera card to access your photos. Your problem may very well be GPU related.  See this link to GPU issues and supported video cards.

     

    http://forums.adobe.com/message/4289204#4289204

    Please verify that the video card in your computer is on the list of those supported and visit the web site for the manufacturer to be sure you have a current driver.

     

    Then, try changing the settings mentioned and follow the GPU troubleshooting suggestions.

     

    Let us know how it goes.

     

    Pattie

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 1, 2012 8:05 PM   in reply to gottothinkpositive

    Looks like we were posting at the same time- I'm glad you got it working

     

    Pattie

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 1, 2012 8:20 PM   in reply to gottothinkpositive

    First you should verify the video card and driver and the settings mentioned in the  GPU link. Let us know what you find after checking those.

     

    Thanks,

     

    Pattie

     
    |
    Mark as:
  • Noel Carboni
    23,526 posts
    Dec 23, 2006
    Currently Being Moderated
    Apr 1, 2012 9:04 PM   in reply to gottothinkpositive

    Note that it says ATI Radeon 4670 - that's your video card.

     

    -Noel

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 1:19 AM   in reply to Noel Carboni

    you can read in this FAQ how to get to the system information and cut and paste it into the reply:

     

    Pattie

    FAQ: How do I share my System Information?

     
    |
    Mark as:
  • Pierre Courtejoie
    7,043 posts
    Jan 11, 2006
    Currently Being Moderated
    Apr 2, 2012 1:22 AM   in reply to gottothinkpositive

    Yes, do check your GPu information in Help>system info, you might be running an old driver. Normally, using the GPU makes things faster, unless the driver has an issue, or the card is seriously underpowered.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 3:07 AM   in reply to Pierre Courtejoie

    Surface blur is not GPU accelerated! Are you talking about one of the new blur filters? Only those are.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 2:36 PM   in reply to gottothinkpositive

    I see your use graphics processor is not checked. If you are able to run when you check it,  try it using these different settings to see if one works better for you:

     

    Pattie

     

     


    Choose Edit > Preferences (Windows) or Photoshop > Preferences (Mac OS).

    In the Performance panel, make sure Use Graphics Processor is selected in GPU Settings.


    Click Advanced Settings and specify one of the following options:

      • Mode > Basic
      • Mode > Normal
      • Mode > Advanced Provides the benefits of Normal mode as well as newer OpenGL advances that can result in improved performance.
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 2:50 PM   in reply to klsteven

    klsteven wrote:

     

    Surface blur is not GPU accelerated! Are you talking about one of the new blur filters? Only those are.

     

    i wonder too.... (unlikely he speaks about the new blur filters in CS6 because he compares it to CS5). 

     

    anyway, if it is about the SURFACE BLUR filter (like the topic says).... keep in mind surface blur is quite fast on 8 bit images but very slow for 16 bit images.

    that maybe explains the speed differences you noticed.

     

    from my experience nothing has changed for the surface blur filter... it is as slow in CS6 as it was in CS5.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points