Skip navigation
some steps
Currently Being Moderated

How to integrate buttons into mulri state objects?

Apr 2, 2012 3:50 AM

Tags: #publishing #adobe #dps #ipad #buttons #5.5 #multi_state_objects

Hi there,

 

I saw layouts using buttons being integrated into MSO. Means that the buttons are inactive till the state is active, where these buttons are placed. And it worked!

After retrying this it did'nt worked. I'm working on Mac but I saw this layouts on a Windows system (both with CS5.5). Is there a difference?

How can I integrate buttons into MSOs in a working way?

 
Replies
  • Currently Being Moderated
    Apr 2, 2012 5:15 AM   in reply to some steps

    Without seeing your file, the easiest workaround would be to create empty buttons and put those into your MSOs above the actual button artwork.

     

     

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 6:03 AM   in reply to some steps

    Hi,

     

    I'm having the same problem I think. And from what I can observe here, you can't put any interactive content INTO a MSO - except buttons that would go to a specific state, (like go to state 2, tehn on state 2, a new button appear to bring you back to state 1).

     

    You can't import or create a button into a specific state of the objet that would link you to an other page or an other document for example. Am I wrong?

     

    Thank you.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 7:10 AM   in reply to some steps

    Ok... So something must be wrong in my settings. I want to make a navigation menu which is a MSO.

    In my simple example, you click on a "chapter 1" button, you have a pop-up with the sub-chapter entries (which is the 2nd state of a MSO), then I'd like to put links on these sub-menu entries to go to the different parts of the book. Each time I cop/paste the button, it loose its function.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 7:13 AM   in reply to Bob Levine

    @Bob,

     

    How would you do another work around, I feel I am having the same problem

     

    I want to place buttons in MSO's so that their interactivity is only there when the state they're in is active

     

    it doesn't seem to want to work for me

     

    Tim

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 7:14 AM   in reply to hardtofindscreename

    @hardtofindscreenname

     

    sometimes interactivity doesn't copy over - you have to reapply it

     

    -Tim

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 7:15 AM   in reply to tim.hughes

    Are you pasting the buttons in before or after adding the functionality.

     

     

     

    Do it after.

     

     

     

    Bob

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 7:30 AM   in reply to Bob Levine

    After, but they don't work.

     

    I group the buttons (with no instruction) to their respective image > then create an object state

     

    so that one image has a "button" below it

    and the next state has an image with a button further below that

     

    then once inside the state I add the button instruction to both "buttons"

     

    I want to do this so that when the state is not selected, the "button" area can not be accidentally tapped to move states

     

    I know how to use the clear box trick that would acomplish the aesthetical side of what I wish to achieve, it just wouldn't do for the practical side.

     

    -Tim

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 7:38 AM   in reply to some steps

    I've created text hyperlinks and it works, I've tried everything with buttons, in my file it does not work, maybe an exception. Thanks for your help.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 7:42 AM   in reply to hardtofindscreename

    @hardtofindscreename

     

    don't worry matey, I might have your answer

     

     

    make sure "swipe to change image" is checked in the slideshow overlay

     

    i know it's not the perfect solution but it works!!! well for me

     

    Let me know how you get on dude!

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 17, 2012 7:43 AM   in reply to some steps

    @some steps

     

    This works for me too except when I want the button to change state inside the same MSO

     

    but if you check - "swipe to change image" it works a treat

     

    Thanks for the help guys!

     

    Tim

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points