Skip navigation
hotdes
Currently Being Moderated

How to reduce the time of publication in the swf from the fla in Adobe Flash Professional CS5.5?

Apr 2, 2012 5:36 AM

My fla-file (27mB) is graphic resources to a project, split into pieces is very problematic.Publication time on my computer is 4 minutes. I tried setting "preferance / publish cache" - not result.

 
Replies
  • Currently Being Moderated
    Apr 2, 2012 5:42 AM   in reply to hotdes

    oh thanx a lot for telling about this problem! I have the same trouble and it's so disgusting! Hope, Adobe or other users will help to clear this case

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 7:18 AM   in reply to sergpetrov

    Tell us what your computer specs are please. Also tell us what the contents of your project primarily contain (vectors, bitmaps, etc). Also tell us the target of your publish (mobile app like IPA or SWF?).

     

    If you're publishing a mobile app such as an IPA there will be no way to cut down on this. Even my dual quad xeons with 32gb ram take about a minute to produce a non-quick-publish IPA.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 7:46 AM   in reply to hotdes

    Your processor is a budget processor although not old. You have sufficient RAM and it must be new enough to use an i5 (DDR3) so that's fine but your video card doesn't matter when it comes to publish (all CPU/ram/HD).

     

    However, you have 1819 items........ (!!!!!!!!!)

     

    I've never had a library with more than 300 items and most of those were symbols of other assets.

     

    Being the majority is vector you're not dealing with waiting for compression. If you have embedded a lot of fonts, you absolutely will suffer for this. Especially of you embed the entire set of glyphs with the font for all languages. Are you embedding lots of fonts?

     

    BTW what is the total size of your SWF after export?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 8:27 AM   in reply to hotdes

    Try doing this, just for fun.

     

    Save this file to a new file for testing purposes. Remove all 4 fonts from your library. Publish.

     

    How much faster? Chances are, a lot.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2012 7:02 AM   in reply to hotdes

    You must just be embedding a subset of the fonts, like just latin. That exports nearly instantly.

     

    I think you need to chalk it up to having almost 2000 library element graphics. You could try unchecking "compress movie" in publish settings to see if Flash is taking a lot of time compressing your assets.

     

    Why don't you try taking only 20 of those symbols in your library, copy them and paste them into a brand new document. Try exporting that document and see if it takes an abnormally long amount of time. Only 20 items should export in just a few seconds.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 3, 2012 8:11 AM   in reply to hotdes

    Yes Arial will always export lightning quick.

     

    Compress movie was a chance that you used some bitmaps that might have agressive compression. Oh well.

     

    You copied 120 symbols and received good results. Great! Try copying half your library and do the same. Soon you will find out which item is causing this gigantic halt.

     

    Over a decade ago it took my old P4 about 5 minutes to export a movie I was making and I never knew why. It always ran very cruddy in one specific area too. I finally took a look inside one vector that was insanely complex and huge (like 3000x3000 size 8 years ago is HUGE). It was being scaled down to 5% of its size to fit on screen haha. I simply exported it to a bitmap and all of a sudden everything was fixed. Lots of these things happen. You just need to find out what part of your library is causing issues. So I'd keep copying more and more symbols while exporting until all of a sudden you copy, export and it takes forever. Then you know what the culprit is.

     

    In my experience the 2 things that have ALWAYS caused a ridiculos amount of time to export is audio and fonts with all glyphs exported.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 4, 2012 5:56 PM   in reply to hotdes
    • try going into publish settings and then actionscript settings and unchecking 'Strict Mode' and 'Warnings Mode'
     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2012 7:16 AM   in reply to hotdes

    Were you previously getting any warnings? That's not necessarily safe. Good for a quick publish to test something but when you're ready to make the final you should enable those and clean up anything it warns you about for optimal performance (typically embedding fonts properly, etc).

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 5, 2012 8:24 AM   in reply to hotdes

    I think you can just turn off 'Warnings Mode' and leave 'Strict Mode' on while still getting compile speed increase.  Try it out and see.

     

    Here is more info about those options:

     

    http://help.adobe.com/en_US/flash/cs/using/WS3e7c64e37a1d85e1e229110db 38dec34-7fa4a.html

    Strict Mode reports compiler warnings as errors, which means that compilation will not succeed if those types of errors exist. Warnings Mode reports extra warnings that are useful for discovering incompatibilities when updating ActionScript 2.0 code to ActionScript 3.0.


     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points