Skip navigation
Currently Being Moderated

how to disable progressive downloads

Apr 1, 2012 11:34 PM

Tags: #download #progressive

We have FMS interactive configured to do RTMP and HLS streaming. However the clips still can be downloaded through http://domain.name.com/vod folder. Is there a way to disable progressive downloads? While at it is there a way to disable HDS also? I want to allow HLS and RTMP only.

 
Replies
  • Currently Being Moderated
    Apr 2, 2012 1:39 AM   in reply to Vilius Šumskas

    Reason for your data available for progressive dowload is because its there in webroot. Webroot/<extendend-path> is by default available to any client via http://server-name/<extendend-path> unless you have taken measures to protect it inside Apache's httpd.conf.

     

    You can do one thing. Keep your content outside Apache's webroot. Say C:/myvideos/. for example there is a video there sample.f4v i.e C:/myvideos/sample.f4v

     

    Now you can change the location "HttpStreamingContentPath" pointing to from "../webroot/vod" to "c:/myvideos/" under hls-vod inside httpd.conf (Apache/conf)

     

    <Location /hls-vod>

        HLSHttpStreamingEnabled true

        HLSMediaFileDuration 8000

        HttpStreamingContentPath "C:/myvideos/"

        HLSFmsDirPath ".."

        HLSJITConfAllowed true

       Options -Indexes FollowSymLinks

    </Location>

     

    Or you can disable(modify) content availibilty by making appropriate changes unders in httpd.conf

    <Directory "../webroot">

        Options -Indexes FollowSymLinks

        AllowOverride None

        Order allow,deny

        Allow from all

    </Directory>

     

    To disable HDS-Live, set "HttpStreamingEnabled" to false under hds-live location directive

    <Location /hds-live>

        HttpStreamingEnabled false

     

    To disable HDS-vod, set "HttpStreamingJITPEnabled" to false under hds-vod location directive

    <Location /hds-vod>

        HttpStreamingJITPEnabled false

     

    To disable HDS-vod offline fragmented content, set "HttpStreamingEnabled" to false under vod location directive

    <Location /vod>

        HttpStreamingEnabled false

     

    You need to restart the Apache server after making the changes to get them reflected next time..

    Hope it help

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 1:56 AM   in reply to Vilius Šumskas

    I guess, yes .. but it may deny all request to webroot.. Even everything beyond FMS usage like your own hosted pages, FMS default index.html will not be allowed.. I hope you underrstand what all you are restricting as per your usage/requirement..

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 2, 2012 2:14 AM   in reply to Vilius Šumskas

    In that case just change HttpStreamingContentPath to correct location of the media folder under hls-vod tag. like this:-

     

    <Location /hls-vod>

        HLSHttpStreamingEnabled true

        HLSMediaFileDuration 8000

        HttpStreamingContentPath "<application-folder-path>/vod/media"

        HLSFmsDirPath ".."

        HLSJITConfAllowed true

       Options -Indexes FollowSymLinks

    </Location>

     

    Restart Apache.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points