Skip navigation
Currently Being Moderated

Can't start Photoshop - 'Could not open a scratch file'

Apr 4, 2012 9:48 AM

Tags: #permissions #crash #photoshop_cs5 #error_message #scratch_file #photoshop_cs6_beta

Hi, I recently installed Photoshop CS5, however every time I open the application, I am receiving this error message at the loading screen:


"Could not open a scratch file because the file is locked or you do not have the necessary access privileges. Use the ‘Get Info’ command in the Finder to unlock the file or change permissions on the file or enclosing folders."


I've looked online for solutions everywhere, but I've obviously been unsuccessful and I'm at the point where I have no idea what else to try, other than a clean install of my OS, however that is a last resort as I currently do not have an external hard drive to transfer my files to do so. So far I have tried these things:


  • Reinstalled Photoshop many times, even the CS6 BETA is giving me the same error.
  • Deleted preference files within /Library/Preferences/
  • Used the cmd+alt shortcut when starting Photoshop to select a different scratch disk location.
  • Used the cmd+alt+shift shortcut to delete the settings file, which I cannot do as the error message mentioned above appears before the window for deleting the settings file does.
  • Tried rebooting several times, even into safemode and I still get the same message.
  • Tried changing the permissions on the Applications folder, Adobe folder, CS5 folder and CS5 application, however they are all set to 'read & write access' for me. I am also set as an administrator.
  • Cleaned my cache of any unneccessary files.
  • I have also repaired my permissions using Disk Utility, but that didn't solve the problem.


I have a 2010 Macbook Pro, 4GB RAM running OS X Lion 10.7.3 with 2 patitions on my harddrive (OS X and Windows 7). I have 15GB free on my OS X partition currently, which may not seem like much, however I have run Photoshop CS5 previously as a trial and other versions of Photoshop and the small amount of harddrive space has never affected the software's ability to create a scratch file.


The strange thing, however, is that I can use Photoshop CS5 & CS6 on a guest account that I created recently, which means that the problem I am having is permissions based. Logging into a seperate account is a good enough solution for now, but it is incredibly tedious to keep changing accounts just to use Photoshop.


Has anyone got any other ideas? As I mentioned previously, reinstalling is a last resort as I currently don't have the neccessary resources.



  • Currently Being Moderated
    Apr 4, 2012 5:14 PM   in reply to Selrek

    Here's something to try:


    While in the Finder and BEFORE launching Photoshop, highlight the icon of the hard drive where the scratch disk resides, do a Get Info (Command I) and see if you can check the box that says "ignore ownership of this volume" or some such verbiage.

    Mark as:
  • Currently Being Moderated
    Apr 4, 2012 6:01 PM   in reply to Selrek

    Sorry, I overlooked the fact that you are on a MacBook laptop and are using your boot drive as your scratch disk drive.  My bad. 


    Then, I have no further ideas.  15 GB is way too little space for Photoshop's scratch disk drive, especially when that very small space is being shared with the swap files of the OS.  I wouldn't be surprised if the reason only an administrator can run it on your machine is actually a protective measure.

    Mark as:
  • Currently Being Moderated
    Apr 4, 2012 9:56 PM   in reply to Selrek

    It's painfully obvious that I'm not qualified to give advice in a situation like yours.  Sorry.


    Generally speaking, one should NOT partition the only drive in a laptop, as the space available to the swap files of the OS and to the Photoshop scratch disk does not need to be limited a priori by the constraints of partitions.


    Of course, I'm deliberately ignoring your apparent need for a Windows partition, because i wouldn't remotely know how to handle that.

    Mark as:
  • Currently Being Moderated
    Mar 14, 2013 9:02 AM   in reply to Selrek

    When I do the '/private/' command the OS tells me that the folder can not be found.

    Mark as:
  • Currently Being Moderated
    Mar 14, 2013 9:27 AM   in reply to MarkRomine

    The /private folder is a hidden folder. However, if you navigate to Go > Go to Folder and within the Go to Folder window enter just "/private/" without the quotes, then it should take you to the private folder. Make sure you're typing it exactly as it is here. Folder/file names are case sensitive.

    Mark as:
  • Currently Being Moderated
    Mar 15, 2013 6:38 AM   in reply to Selrek

    Well I tried all of these steps finding the /private/ folder and changing the permissions to 'Read and Write' and the OS is still not saving the changes to the 'ignore ownership' button.

    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points