Skip navigation
Currently Being Moderated

date/time based rename incorrect for Video

Mar 14, 2012 8:13 PM

Tags: #video #template #filename #time #editor #date #rename #yyyymmdd #hhmmss

Hi,

 

When I import photos and video using lightroom, I rename all my files based on date and time using a YYYYMMDD_HHMMSS format. For example:

filename_template_editor.png

This works perfectly for photos. That is, the (LR renamed) filename reflects the time the photos was taken (I suppose this is the "capture time"). However, the video time is totally wrong. For example, a video taken at 7PM gets renamed to something corresponding to 1AM.

 

I notice the following:

- Date/time based renaming of this particular iPhone 4S video works properly in other applications (e.g. Dropbox and PhotoMechanic)

- The resultant filename in LR4 appears to correlate to "Date Time Digitized", which in my case does not reflect when the video was actually taken (I'm not sure if it should or not, I'm only saying that it does not).

 

Is this expected behavior from LR4?

 

The behavior I'm seeing means that I have to use yet another application (e.g. PhotoMechanic or other) on the front-end of my workflow (before LR) in order to ensure video files are named "correctly". This is obviously not the desired solution, I'd prefer to do the renaming inside LR at the time of import since it provides a function for precisely this purpose.

 

Any comments appreciated.

 
Replies
  • Currently Being Moderated
    Mar 15, 2012 2:26 AM   in reply to cjs007

    iPhone videos have exif metadata? I thought videos do not support exif metadata at all...

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2012 6:46 AM   in reply to Dorin Nicolaescu-Musteață

    Videos do support EXIF data, but LR doesn't read much of it, and doesn't read any of it from many type of cameras.

     
    |
    Mark as:
  • Currently Being Moderated
    Mar 15, 2012 7:58 AM   in reply to cjs007

    I think Lightroom just uses file modification time for videos.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 7, 2012 11:49 PM   in reply to cjs007

    I've got lightroom importing to folders named after the date, and occasionally it puts videos (avchd .MTS files) into folders for the day after they were taken. Occasionally splits a group of videos taken on the same day between two different folders for different days. Not sure what the trigger is for this, but wonder if it's a related bug?

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2012 12:40 AM   in reply to cjs007

    This is a huge problem, and has existed since Lightroom 3. It basically makes LR3 and 4 useless for managing video files if you do it by date. Windows 7, for free, does a much better job.

     

    The basis of the problem, from what I have been able to work out, is if the video does not contain a specific 'Date Taken' (or whatever*) value, then LR3 and 4 use the 'Date Created' as the time of the video. This is useless, as (in Windows anyway) that is generally the time the video was copied to your machine or HDD, rather then when it was taken.

     

    That I think is the basics, but it gets worse and more complicated. Sometimes it seems to use GMT (as opposed to your local time). Sometimes it will change the time depending of whether or not you have daylight savings enabled in your camera. I spent a couple of hours testing, and with all my cameras set to the correct local time, I could get 7 different LR 'Capture Time' with 7 different cameras. Its a bad joke.

     

    The very very very very easy solution would be to have LR just use the 'Date Modified' time instead of 'Date Created' or whatever they use now. Thats what Windows 7 and a whole bunch of other programs use by default. But a number of us have been raising this since LR3 beta, and have been systematically ignored.

     

    And its why I dont use Lightroom to manage my videos.

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 8, 2012 8:31 AM   in reply to Thronsen

    I agree that video needs full LR support for metadata. Please add your vote and opinion to this topic in the LR feedback forum, Adobe's preferred forum for getting feedback:

     

    http://feedback.photoshop.com/photoshop_family/topics/lr4_beta_video_t agging_not_complete

     

    In the meantime, I still use the Any File plugin to manage video files; this gives me full metadata capabilities.

     
    |
    Mark as:
  • Currently Being Moderated
    May 26, 2012 11:09 AM   in reply to cjs007

    I shoot AVCHD on a Canon HFS20, and when I import the .mts files to LR4, the metadata has no Capture Date, so LR sorts by Date Created (i.e., when I downloaded to the computer).  A fix that seems to work, however, is to select a batch of videos that have been imported, select "Edit capture time" from the "Metadata" tab, accept the default selection of "Adjust to specified date and time," and click "Change All."  Even though the selected date will show the capture date for the last selected video, it actually sets the Capture Date in the catalog metadata for each video to the right data and time (presumably based on the file's Date Modified but maybe based on some other metadata in the .mts file).

     

    That's a pain, and it's no good if you actually want to set all the videos to the same date (which is what this function would seem to do), but so far it works for me even when the selected videos have a range of dates.

     

    Of course, you still can't write that metadata back to an XMP file, but at least it's in the catalog for your clips.

     
    |
    Mark as:
  • Currently Being Moderated
    Nov 2, 2012 6:24 AM   in reply to Synergy1281

    Read through the discussion here and investigated further to find a solution that would work for me.

     

    The issue, as reported, is that LR4 uses a video file's modified date/time when renaming.  So the solution that worked for me was to download Attribute Magic Free and to change the modified date of my video files to the date the video was actually taken on.  When renaming in LR4 now, the video files are correctly named - I rename my files: YYYY-MM-DD <sequence within the day>.* i.e. 2012-10-02 016.avi.

     

    Hope this helps.

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2014 7:50 AM   in reply to cjs007

    Did anyone find a reasonably simple workaround for this?  Attribute Magic Free seems like a decent one, but I'm on a Mac, and it only runs on Windows.  Any help would be much appreciated!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2014 7:55 AM   in reply to John R. Ellis

    Thanks John, but I tried Any File and it's a bit of a pain.  It's asking me to import files that I've already imported into Lightroom.  Since this thread is a couple years old, can you suggest anything new to solve this issue?  Thanks in advance!

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2014 9:40 AM   in reply to JonnyZ123

    I still use Any File to manage my videos, since I want full metadata capabilities, including the ability to save metadata to "sidecar" files outside of the catalog.

     

    Any File should not ask to import files that are already in LR -- send me a private email (address on the Any File Web page) and I can help you sort through that and any other issues you might have with the plugin.

     

    Alternatively, you could check out the Video-Asset Management plugin -- it works similarly to Any File but has features just for video:

     

    http://regex.info/blog/lightroom-goodies/video-assets

     
    |
    Mark as:
  • Currently Being Moderated
    Jan 10, 2014 2:09 PM   in reply to cjs007

    After spending the better part of the day researching this, I found a solution that works reasonably well, if you have a Mac.  For $6 you can buy an app called Shootshifter from the app store here: https://itunes.apple.com/app/shootshifter/id521567274

     

    You have to play with the settings, and check the option to "fix differing filesystem dates on import".  In the options for that specific setting, have it use the EXIF Digitizing Date to generate the File creation date.  Also, in Advanced Settings, enable the Quicktime Movie Import option if you're dealing with them.  Then, you would have to add each folder containing the movies one-by-one, and import them.  Once imported, you should not have to do anything else in Shootshifter, as it should have modified the creation date.  From there, go into Lightroom, and go to Metadata / Edit Capture Time and choose the option for "Change to file's creation date".  In my case, this only changed it by a few hours, but from there I was able to change trename the movies, in LR, using the date function, and  the date was accurate.

     

    Hope this helps!

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points