Skip navigation
Currently Being Moderated

Show Parent Folder Bug in LR 4.1 RC

Apr 8, 2012 8:38 PM

Tags: #lightroom #lr4

I have installed LR 4.1 RC and converted my PSE 10 catalog of ~37k images & videos. The import seemed to go well keeping the keyword tags and captions (I checked only a small a random sample so far). 99% of my images are in a specific folder C:\Our Files\Pictures

 

In the Library, I rightclick on a folder and select Show Parent Folder, I get the following error:

An internal error has occurred: Database "c:\Users\Daddy\Pictures\Lightroom\Lightroom\Lightroom 4 Catalog.Iract": columns rootFolder,pathFromRoot are not unique

Statement: UPDATE AgLibreryFolder SET rootFolder = ? WHERE id_local = ?;

 

The images are in the following folder:

C:\Our Files\Pictures

 

However, when I do the very same thing to a folder in:

c:\Users\Daddy\Documents\Adobe\Premiere Elements 4.0\

 

It WORKS

 

This folder and others like it are the default folder that Premiere Elements uses for it’s videos.

 

Any help would be greatly appreciated.

 

PS: I am new to LR but PSE is no longer able to safely handle a large catalog so I am attempting to move to LR.

 
Replies
  • Currently Being Moderated
    Apr 9, 2012 1:50 AM   in reply to Beany from Brooklyn

    You appear to have stored the files in a location where Lightroom doesn't have full permissions (i.e. our files\pictures is probably being blocked)

     
    |
    Mark as:
  • Currently Being Moderated
    Apr 12, 2012 9:38 PM   in reply to Beany from Brooklyn

    Yes Daniel, report your bug here under Problems.

    Thanks.

     
    |
    Mark as:

More Like This

  • Retrieving data ...

Bookmarked By (0)

Answers + Points = Status

  • 10 points awarded for Correct Answers
  • 5 points awarded for Helpful Answers
  • 10,000+ points
  • 1,001-10,000 points
  • 501-1,000 points
  • 5-500 points